LibreELEC Krypton/Leia/Agile build for Odroid C2, Rock64, WeTek Hub, WeTek Play2

  • 1st thnx for this nice release (Wetek Hub). I found 2 problems. 1st. In LiveTV when i make the long pressing OK Button the Channel List doesnt appear. Long term pressing dont work. (with remote Button, with Enter Button it works) 2nd In 4K resolution the side by side 3D Modus dont show correctly. It show all on the left side. I hope anyone can help.

    Edited once, last by cracyfloyd ().

  • About remotes:You need to setup your favorite actions yourself. There is a Kodi wiki page about longpress. I would do it for everyone but I 'll hear complains eventually because everyone has it's taste.

    About 3D: I can't support it because I have no 3D TV. Currently there is no solution in Kodi for 3D on Amlogic devices (some ideas though). Eventually there will be a fix.

  • About remotes....

    Hi Raybuntu,

    the switch to 32bit didn't work for me with - either via your hints from the 1st post or wrxtasy's script.

    Nevertheless i got it workin with your image and 32 bit support. amazon and skygo works flawless. Thank you very much for that. :D

    But i've got a new problem: i am using my panasonic zt`s remote via cec. The remote commands repeat to fast - i am jumping over several settings even with the shortest touch. It seems the delays in the cec settings doesn't have any effect on the behaviour - even with highest delay times.

    Any hints avaiable ? :huh:

    update: solution: :idea: just cover your ir receiver or stop lirc via libreelec config :D

    Edited once, last by SPo ().

  • I haven't test those delay settings yet. I just took the patch wrxtasy send me.

  • hi,

    is it possible to integrate the 3D ISO Blu-Ray Playback? with the builds of kszaq and wrxtasy this is indeed integrated. ;)

    regards and thanks for the excellent work.


    Edited once, last by jochenf ().

  • TraduttoreDisattiva traduzione istantanea
    Rileva lingua

    thank Raybuntu, and Kszaq for the work you do.
    Yesterday I tried to install on the nand wetek hub, version LibreELEC-WeTek_Hub.arm-8,0-rb-krypton1.img.gz of Raybuntu.
    - I installed before;
    - Then I gave the command with putty: touch /storage/.update/.nocompat;
    - Then I put in the Update folder LibreELEC-WeTek_Hub.arm-8,0-rb-krypton1.img.gz.
    E 'went well it seems.
    I tried to play through the network lan HEVC movie to 23.976 fps, but playback wasjerky.
    I may have done something wrong in the installation?
    The same film with the 8.0.0b version of kszaq have no problem.
    It 'possible that the versions of Raybuntu, which are specific to wetek hub, work worse than the versions of kszaq?
    Now I'm using the 'latest version of kszaq (8.0.0b) of nand of wetek hub. When playingH264 and H265 seems to be going much better.

    Edited once, last by dibotto ().

  • check my new build: Release rb-krypton2 · Raybuntu/ · GitHub

  • [font][font]Serbatoi [/font][/font]
    [font][font]a partire dalla versione 8.0b kszaq, qual è la procedura da seguire per installare la nuova build?[/font][/font]

    Thank you.
    You were right. I installed LibreELEC-WeTek_Hub.arm-8,0-rb-krypton2.tar and is much better. The films H265 and H264 1080p 23.976 fps are much better, playback is fluid.
    For a clean job, so I installed:
    - I put of sd and restarted by pressing and holding the reset button
    - I gave the command touch /storage/.update/.nocompat
    - I put the file LibreELEC-WeTek_Hub.arm-8,0-rb-krypton2.tar in the update folder, and restarted.

  • Hi,

    thanks a lot for this great build :-) It's working really smooth on my C2

    There's one issue I have with my remote. I bought a new Panasonic TV and it seems the Internal IR from the C2 does respond to the Panasonic Remote (CEC is deativated). When I logon via ssh and type irw I see the same singnal (e.g. devinput key_up) like I see from my Mediacenter Remote. The problem is that I have to use the Panasonic Remote for same apps like Netflix or Amazon Prime but it also controls the C2 in the same time and this casues problems. Is that really the same IR command, I sounds pretty strange too me.

    Thanks Alex

  • Yeah the IR sensor is picking up your TV's ir pulses. Disable the ir sensor if you don't use it:

    echo "blacklist meson_ir" > /storage/.config/modules-load.d/blacklist.conf

    Does any of these build work on the Wetek Core?

    No, I have no Wetek Core.

    Hi Raybuntu,

    any release info ?

    Just check github. You can go through the commit history.

    Edited once, last by GDPR-1 ().

  • Release rb-agile8 · Raybuntu/ · GitHub

    These are based on kodi-agile which is even more experimental than Kodi master. For those builds there is an special inputstream.adaptive in my repo.
    With these builds you can watch every Video with the Amazon Addon from liberty-developer.

    And also Netflix Plugin was released for the capable users who can debug and compile kodi-agile:
    Wir suchen Beta-Tester für Netflix! - Page 2 - Addon Development - - Deutschsprachiges Forum zum Kodi Entertainment Center

    I can't offer much support here. These are for the more capable users who tried DRM with Kodi before. Please don't send me any bugreports regarding agile.

  • Yeah the IR sensor is picking up your TV's ir pulses. Disable the ir sensor if you don't use it:

    echo "blacklist meson-ir" > /storage/.config/modules-load.d/blacklist.conf

    There's a typo...should be "_" instead of "-"

    echo "blacklist meson_ir" > /storage/.config/modules-load.d/blacklist.conf