rpi2 lock ups

  • Hi Yall


    the latest (OE 6.95.1 and) LE milhouse 7 - 0322b / 0324 - are locking up our pi2 in two different ways.


    when doing video playback (im watching, so i notice) ... i can `ssh livingRoom killall -9 kodi.bin`


    when its idle (i don't notice) ... when i need it, it wont even respond to ssh, nothing to do but pull the cord & reboot.


    i think this is the relevant bit of my journalctl ... seems to be libmicrohttpd is not behaving ? gobbling up all my ram ?


    please let me know if anything else would help getting to the bottom of this
    [hr]
    hmm. my initial assessment my be incorrect. im starting to think its BlueTooth


    right before the segFault... i have this


    Code
    1. Mar 24 18:04:06 livingRoom kernel: Transfer to device 6 endpoint 0x1 frame 1089 failed - FIQ reported NYET. Data may have been lost.


    dev6 is my usbBT.

    Code
    1. # lsusb -t
    2. /:  Bus 01.Port 1: Dev 1, Class=root_hub, Driver=dwc_otg/1p, 480M
    3.     |__ Port 1: Dev 2, If 0, Class=Hub, Driver=hub/5p, 480M
    4.         |__ Port 1: Dev 3, If 0, Class=Vendor Specific Class, Driver=smsc95xx, 480M
    5.         |__ Port 4: Dev 6, If 0, Class=Wireless, Driver=btusb, 12M
    6.         |__ Port 4: Dev 6, If 1, Class=Wireless, Driver=btusb, 12M
    7.         |__ Port 5: Dev 5, If 0, Class=Human Interface Device, Driver=usbhid, 1.5M
    8.         |__ Port 5: Dev 5, If 1, Class=Human Interface Device, Driver=usbhid, 1.5M


    i have a cron script running every 3min to check if my or the wife's phone is in the livingRoom ( `hcitool name $BTmac` )


    looks like after the "frame fail" ... it takes about an 1hr for the hcitool scans to lock the system.


    i've commented out the cron line for now.


    let me know if you think im on the wrong path

    Edited once, last by zosky ().

  • I guess a simple test would be to unplug your usb bt and see if it is fixed?


    Sent from my U65GT using Tapatalk

  • at first i disabled the cron entry... that defiantly made it so it didnt lockup every hour, but it did after about 6 (overnight)


    unplugged the dongle and it hasn't locked up in ~12 hrs.