Locked usr Folder

  • I just have one noob question. I'm using LibreELEC Kodi with the built in Confluence skin, but I'd like to modify the "home.xml" file. I’d like to replace the “Weather” menu item with a custom Menu using one of my favorites. I don’t want to use CCM because it has not been updated for a while.

    I'm able to get to the folder (usr/share/kodi/addons/skin.confluence/720p), and I'm able to modify the XML file, but I can't save it. It keeps giving me an error. Where do I go to give myself permission to modify these files? I'm on a Mac and I tried using Fetch, and using the built in finder "Connect to Server" function. I can access the folder both ways, but I can't modify any files in it. I tried the: ”mount /flash -o remount,rw” command, but that didn’t help. I modified samba.config and added myself writing permissions for the usr folder, but that just made the folder visible in the finder, not writable.

    I hope someone has an answer to my problem.

    Edited once, last by iOSID ().

  • The Confluence skin is the 'system skin' by default, and resides on the System partition, which is a read-only partition by design.

    If you want to make changes to Confluence, you'll need to make a copy of the folder first, and place it in the Storage partition. You also need to rename it to avoid conflicts with the system skin. Rename involves not only the folder name, but you also need to edit the addon.xml file contents within the skin folder.

    Other than that, Kodi 17 with the new Estuary skin is coming soon. So your changes may not last long as Confluence is not (yet?) fully compatible with 'Krypton' as far as I know.

  • You can't modify it there.

    Copy the skin folder to storage/.kodi/addons. Rename the folder to something like skin.confluence.myskinname. Modify the "id" and "name" fields in addon.xml. Make your skin related changes. Reboot. Select your skin in Settings.

    And, if desired, you can download a 17.0 compatible version for confluence from github.

    Edited once, last by doug ().

  • Thanks Klojum and doug,

    I did what you said, REBOOTED, but the new skin does not show up in my settings. It only shows the default Confluence. Could you let me know what I did wrong from the screenshot below:

    I just figured out what I did wrong. I used TextEdit to edit the XML file, which in turn created a file that Kodi can’t read. So, I switched to Xcode for editing... and it worked like a charm. :-) Thank you guys.

    Edited once, last by iOSID ().