Moonlight Addon

  • Thank you :D
    [hr]
    If someone (like me) can't wait a couple days:
    I fixed it myself in a hacky way. Replace the files in /storage/.kodi/addons/script.moonlight/lib with mine and it should work again. Replace the files only, if you got a black screen or else moonlight won't work anymore!

    Files

    • Fix.zip

      (134.47 kB, downloaded 355 times, last: )

    Edited once, last by ByteRaper ().


  • Thank you :D
    [hr]
    If someone (like me) can't wait a couple days:
    I fixed it myself in a hacky way. Replace the files in /storage/.kodi/addons/script.moonlight/lib with mine and it should work again. Replace the files only, if you got a black screen or else moonlight won't work anymore!


    This addon IS working on rpi2?
    Thx

  • How can i make the picture fullscreen on my 1080p TV?


    I set the in game 1080. Kodi is running 1080 but with Moonlight (i know Kodi shuts down if streaming starts) i get black stripes left and right.

    Top and bottom is ok. Tried something in the config.txt but nothing helps.


    Here my config.txt


    I want it to 1:1 and no stretch per TV settings or something ;)



    Also after a Nvidia update i get double entries of games in Moonlight. After the update there was no entries anymore in

    GeForce Experience so i add some games, start Moonlight on Kodi and see the double entries.

    .

    How can i delete the complete data of moonlight? Reset the addon in Kodi doesn't help.



    LibreElec 8.1.2 on RPi3

  • Ok display issue solved! I must change my monitor resolution (1920x1200, 16:10) also to 1920x1080.


    No i cant get 5.1 sound. Witcher 3 only in stereo (starting from moonlight addon, not from desktop!).

  • I ve installed moonlight addon (from LE ADDON REPOSITORY, latest update 107) on my rpi3 (with libreelec 8.2.0.1) and it works great:)


    NVidia drivers 388.13, GFE: 3.9.0.97

    Edited once, last by Haris1977 ().

  • HI I'm trying to compile the latest version of moonlight binaries and I'm struggling with the dependencies issues on LibreElec.

    As LibreElec is missing a lot of dependencies (and may even use different versions of some libraires), I'm trying to compile the binary in static mode, but I just can't get to it, even by modifying the makefiles created using the cmake command.

    As I clearly can see that the current version has been compiled that way, can someone tell me how to perform that?


    For info I'm simply trying to get the 2.4.4 moonlight to work on my Intel Nuc, and trying to add the X11_vaapi option in the binary (which is currently only using SDL ie software unaccelerated decompression). I'm compiling under a Debian 9 VM and except this library dependencies issues I'm almost done.

    I'm also struggling with the ffmpeg_vaapi source file using a (apparently) deprecated structure version but I can leave without the vaapi acceleration.

  • Does this work on S912 hardware?

    I've seen reference to that kind of hardware on the Moonlight GitHub. I guess so because there are sources files specific to sxxx hardware, I guess you can find which one is supported or not.

  • Moonlight 2.2.2 from LE repo is nonfunctional (claims to pair then fails to stream)

    Updated to this update moonlight-embedded to 2.4.3 As it was reported to work.

    Actually nonfunctional, error is missing libcrypto.dll so i added that in, this allowed moonlight to actually "function" when called through SSH, via the inmenu kodi item absolutely nothing.


    Now running into the RTSP error mentioned by Cris_ above.

    All default settings, confirmed its not a server error by pairing to my phone.


    Please fix.

    Running Leia, jan16 build on a RPi3

    PC running GFE 3.12.0.84


    Also the install addons from zip button doesnt work unless you go into the menu for it.

    ie

    Addons > Install addons from zip thumbnail = nonfunctional

    Even when the button is favourited it remains nonfunctional

    Addons > Install from repo > back out > install from zip menu item = functional

  • I build Moonlight by updating 3 packages (moonlight-common-c, moonlight-embedded and moonlight) and then addon worked. (tested by hdkiller on irc with LE 8.2.2).

    Gone...

  • Just tried that, seems to be missing default mapping file?
    That errors out, other than that doesnt seem to be a problem. ONly got this far via going through SSH, app says check logs but it didnt create logs :X


    Cant create a mapping file via SSH (input ignored) or through the actual kodi application :/


    /e: ignores controller configuration when i point to the mapping file, ie moonlight map /path/to/file instead it attempts to connect to it as if its a server


    Seems like this issue?

    PS4 controller not mapping correctly · Issue #513 · irtimmer/moonlight-embedded · GitHub


    /e2: Calling a stream through SSH ie moonlight stream <ip> -mapping <path/to/controllerdb.txt> causes it to launch the stream window under whatever kodi is doing (the menu) which is kind of obnoxious, not certain what im doing wrong D: ontop of that it caused the Xbone Controller to become non-responsive even after restart, just rolled back to before i fiddled with moonlight.


    Tested on the libreelec alpha branch #117 on RPi3.\


    Might just grab a Steam Link box, and setup a remote switch to go between Kodi and that box at this rate tbh, especially after reading that moonlight for LE is beta. Or just install raspbian and setup the pi again which wouldn't take too long tbh, Just concerned about slowdown if i go for the bulkier OS.