RetroELEC Kodi+Wayland+Emulationstation+RetroArch (x86/XU4/RPi)

  • Come to think of it, this exact issue has been reported several times in this thread. I believe they all had Chromeboxes as well. The error message you get is from the bootloader, it can't find a configuration file (i.e /flash/syslinux.cfg or /flash/EFI/BOOT/syslinux.cfg).


    As for resizing your partition, there are a million ways... "parted" is included in this build. "Easy" is subjective.

    Edited once, last by escalade ().

  • OMG OMG, I was able to install after resizing with gpart boot cd.


    This seems to be amazing, Thank you Escalade, I guess I have a lot of hours to configure.. Hope to be able to run my roms from SD CARD or Network..


    Congrats, this is a masterpiece distro

    Edited once, last by jtadeia ().

  • I suddenly have a very low volume.
    It was working fine actually, but then suddenly low volume.
    I can't check the sound level as there's no alsamixer.
    Using the latest build on a rpi 3.

  • New build 20160930 for generic uploading:


    - Added TigerVNC (systemctl start tigervnc ; systemctl enable tigervnc) - VNC password is "libre"
    - Added Vulkan demos

  • I was finally able to resolve my bluetooth/screensaver issue.


    tl;dr
    I had old devices listed in bluetooth standby from copying files from a previous installation. I needed to manually remove them and then all worked well.


    If you want more details please read here:
    LibreELEC


  • New build 20160930 for generic uploading:


    - Added TigerVNC (systemctl start tigervnc ; systemctl enable tigervnc) - VNC password is "libre"
    - Added Vulkan demos


    Vnc working great :) What are vulkan demos and how do run them?
    Vice seems to work now, think the problem was my end.
    Awesome stuff as usual mate. How did you get on with ps2 after? I remember you mentioning you were trying to get it in the build before you'r holiday.

  • LibreELEC.tv/package.mk at emu · escalade/LibreELEC.tv · GitHub



    As for PS2, I couldn't get it running under Docker. Well, I could get it running but was unable to load ISO files. Most likely it's using some kind of kernel call to read the UDF structure and that failed. Could be because of missing 32 bit support in the LE kernel, haven't really had time to troubleshoot it more. It might be possible to use the binaries from a different distro and bundle all the required 32 bit libraries with it, but that would be a bit ugly. I'll look more into it at some point but no promises :) Too bad the PCSX2 devs don't care about making it work on 64 bit. Most likely it will never get 64 bit support either as apparently it's quite complicated to do.

  • Hi all,
    I'm trying to get accomplished the following stuff (some I have already workarounds, wish I'm also sharing).
    Can someone give me a hint ? Thanks in advance.


    - Why can't I start fba roms ?
    lvl2: Attempting to launch game...
    lvl2: /usr/bin/retroarch.start -L /tmp/cores/fba_libretro.so /media/SDCARD/roms/fba/1942.zip
    lvl1: ...launch terminated with nonzero exit code 256!


    - Some SNES also give the same error:
    Resolved, it seems that I can't run zipped roms


    - How to exit Dolphin ?


    - How to run Roms via SD card?
    Workaround - Create symbolic link to run Roms always from sdcard labeled SDCARD (Note that emulationstations will not boot without sdcard):
    # mv /storage/roms /storage/roms_BAK
    # ln -s /media/SDCARD/roms/ /storage/roms


    - How to keep scpraped images in SD card ?
    Workaround - create symbolic links
    # mv /storage/.config/emulationstation/downloaded_images/ /media/SDCARD/
    # mv /storage/.config/emulationstation/gamelists/ /media/SDCARD/
    # ln -s /media/SDCARD/gamelists/ /storage/.config/emulationstation/gamelists
    # ln -s /media/SDCARD/downloaded_images/ /storage/.config/emulationstation/downloaded_images

    Edited once, last by jtadeia ().

  • Ok, so after a bit of troubleshooting th problem is that the sound is not going through hdmi.


    so if I do:


    LibreELEC:~ # amixer cset numid=3 2
    numid=3,iface=MIXER,name='PCM Playback Route'
    ; type=INTEGER,access=rw------,values=1,min=0,max=2,step=0
    : values=2


    then after a reboot I get:

  • Is anybody else having issues running PSX from emulationstation?
    I've tried more than 10 different roms (cue files + bin), I have all the bios in 3 different places "roms/psx", "bios" and "bios/psx".


    Whenever I try to run a rom, I get a black screen.


    Processes running:
    1238 root 0:00 sh -c /usr/bin/retroarch.start -L /tmp/cores/mednafen_psx_libretro.so /storage/roms/psx/Mega\
    1239 root 0:00 {retroarch.start} /bin/sh /usr/bin/retroarch.start -L /tmp/cores/mednafen_psx_libretro.so /sto
    1243 root 0:45 /usr/bin/retroarch -L /tmp/cores/mednafen_psx_libretro.so /storage/roms/psx/Mega Man X4 (USA).


    Any suggestion ?
    None of the following files give useful information


    -rw-r--r-- 1 root root 56 Sep 30 17:19 emulationstation.log
    -rw-r--r-- 1 root root 392 Sep 30 17:29 retroarch.log


  • The core name changed at some point. I manually edited my es_systems.cfg in /storage/.config/emulationstation to fix the issue.
    It should be fbalpha_libretro.so not fba_libretro.so.


    I submitted a PR for escalade at one time but I'm still learning git(hub) so I royally botched it and ended up having to close the PR.



    With snes9x2010 I am able to use zipped roms without issue.
    [hr]


    Since its happening across many roms, it sounds like its either a BIOS related issue or (similar to your fba issue) it might be an issue with es_systems.cfg. Try using PCSX rearmed instead. pcsx_rearmed_libretro.so

    Edited once, last by jaykass ().

  • jtadeia


    Post the logs. Zipped snes roms work fine here.


    I'll rename the fba core in the next build, meanwhile you can edit /storage/.config/emulation/es_systems.cfg and do it manually.

  • jaykass, escalade, Thanks a lot.


    snes zip roms are now working fine, it was the rom issue, I just tried to zip the smc version and it worked.



    fba issue also solved, thanks a lot, if anyone is having the same issue, just run the following command:
    # sed -i -- 's/fba_libretro.so/fbalpha_libretro.so/g' /storage/.config/emulationstation/es_systems.cfg



    Now I'm only missing PSX, I don't have the core you mentioned (pcsx_rearmed_libretro.so), should I get it manually? I have these only
    ls -ltr /tmp/cores/*psx*so
    -rwxr-xr-x 1 root root 2340352 Sep 30 00:36 /tmp/cores/mednafen_psx_libretro.so
    -rwxr-xr-x 1 root root 3018616 Sep 30 00:36 /tmp/cores/mednafen_psx_hw_libretro.so

    Edited once, last by jtadeia ().


  • The pcsx_rearmed core is for ARM (i.e. RPi), you should be using mednafen psx. Again, post the logs :)


    Ok, I see.
    Regarding the logs, where can I find the relevant logs?



    But I've just noted that I don't have the following bios, which are mentioned in the info file "mednafen_psx_libretro.info"


    LibreELEC:~/.config/emulationstation # find / -name scph5500.bin
    LibreELEC:~/.config/emulationstation # find / -name scph5501.bin
    LibreELEC:~/.config/emulationstation # find / -name scph5502.bin


    Will get the files and get back to you.

    Edited once, last by jtadeia ().

  • Ok guys, this is getting better and better.. Finally got PSX working also.
    I had the bios, but they are case sensitive, so I had to rename them :)
    Thanks again for your help