wont boot

  • hi guys well i ben testing for a while i have a mxq pro 4k i install the latest version 7.0.3.010 (2016-12-09) using tree gxbb_p200_1G_100M.dtb


    i have used rufus to burn imagen as instruction i have used a usb the build work awsome on the box if i boot from usb tested everything (factory remote wont work i have copy the remote.config to /storage/.config still dont work i had to use a mini keyboard) well so i have flash to the system i did the command (installtointernal)it did work it copy all file but once i remove the usb and reboot without usb it stay at black screen try a few time still black screen if i plug the usb back it turn on normal to kodi and i can remove the usb and the kodi still work any help to fix this problem thanks guys


  • hi guys well i ben testing for a while i have a mxq pro 4k i install the latest version 7.0.3.010 (2016-12-09) using tree gxbb_p200_1G_100M.dtb


    i have used rufus to burn imagen as instruction i have used a usb the build work awsome on the box if i boot from usb tested everything (factory remote wont work i have copy the remote.config to /storage/.config still dont work i had to use a mini keyboard) well so i have flash to the system i did the command (installtointernal)it did work it copy all file but once i remove the usb and reboot without usb it stay at black screen try a few time still black screen if i plug the usb back it turn on normal to kodi and i can remove the usb and the kodi still work any help to fix this problem thanks guys


    I might be wrong but I think you are rebooting to recovery. Boot from the USB then try to make it boot to normal startup. The usb booting is a recovery hack to make the system boot it from recovery.

  • thanks for the reply what you mean ? so the command dont make the box boot without usb so i have to leave the usb there all time ? or how i do the starup ?


  • thanks for the reply what you mean ? so the command dont make the box boot without usb so i have to leave the usb there all time ? or how i do the starup ?


    Did you try installing again? The instructions say it might happen.




    CAUTION: If your box has a non-standard partition layout, you will see an error when trying to boot from internal memory for the first time. To solve it, you need to boot one more time from SD card and run installtointernal again.

  • Did you try installing again? The instructions say it might happen.




    CAUTION: If your box has a non-standard partition layout, you will see an error when trying to boot from internal memory for the first time. To solve it, you need to boot one more time from SD card and run installtointernal again.


    yes i did install it like 10 time also tested diferent version still black screen with no usb if i add the usb it will boot nice

  • Some boxes don't allow writing device tree outside recovery, I have yet to discover why. One workaround that I found (it might not be working all the time) is to execute fw_setenv upgrade_step 2 before running installtointernal. This might help writing device tree to internal partition.


  • Some boxes don't allow writing device tree outside recovery, I have yet to discover why. One workaround that I found (it might not be working all the time) is to execute fw_setenv upgrade_step 2 before running installtointernal. This might help writing device tree to internal partition.


    awsome thanks buddy i will try that today and let you know what happend

  • awsome thanks buddy i will try that today and let you know what happend


    i have done the command you told me still no luck the box only boot from usb or sd card has to be mounted for libreelec could work if i remove the usb or sd card and restart y wont boot it stay in black screen Note : i got the remote working nice


    box : mxq pro 4k 1gb 100m

  • I have same problem mate.. I was searching solution for atleast one month, but unsuccessfull.. idk what can we do with that.. but atleast I can help you with device tree, I think u using wrong device tree.. I have at home 10 mxq pro 4k boxes and all of them need [gxbb_p201.dtb] device tree.


    Maybe that's why u had problem with your remote controller.


    My solutions was.. I bought 1GB SD cards and I'm running OS from that

  • yes mate the remote i have fix it it had the wrong remote.config also i have try a few tree including the one you told me but well not look i gess i have to used a sd card for now until i buy anothe box thank you for you help


    Sent from my SM-N920T using Tapatalk

  • Have you solved that? I'm stuck with the same issue. Install to internal succedes, but I can only boot from sd. Boot from internal always fails with black screen