Gamestarter: Retrogaming add-ons (RPi/Generic)

  • I think you should ask IARL developer... Internet Archive ROM Launcher

    In fact yes and finally Got it!

    It's kind confusing at first, but reading this IARL reply at forum realize that for each "console collection", we must define at the context menu what core should run as external command (for each console-core). Maybe this little explanations could be added to your IARL configuration instructions for no future confusions! :D


  • Just posting to comment that I am switching Gamestarter Addon into a Kodi Repository for LIbreELEC (RPi & Generic) that includes individual addons for RetroArch & EmulationStation. So everybody can install just what he/she needs and it is easy to backup, uninstall, restore and update.

    At this moment there are only available the following addons:

    - RetroArch

    - EmulationStation

    - Advanced Emulator Launcher

    - DraStic RPi emulator.

    If you want to give a try just download and install this repo zip: m36qLT

    Feedback is welcome!

    UPDATE: log files are in /storage/temp/

  • Tried to repository on the current version 8.0.2 Libreelec and find that EmulationStations doesn't start. It ends up restarting kodi?

    What am I missing?

  • I was unable to locate the 3 log files you mentioned.

    it is strange, it should be at /storage/.kodi/temp/emulationstation.log

    when you launch emulationstation addon, it should ask you to exit kodi, then ES splash screen should display, is this happening?

    did you try to launch retroarch addon first?

  • Finally found them.

    Here is emulationstation.log

    EmulationStation [ADDON] :: Wed Aug 2 17:57:20 EDT 2017


    EmulationStation [ADDON] :: Kodi is ready.

    EmulationStation [ADDON] :: Generic.x86_64-8.0.2 - Wed Aug 2 17:57:21 EDT 2017

    EmulationStation [ADDON] :: Stop kodi...

    Emulationstation [ADDON] :: Launch Emulationstation (See process output in emulationstation_debug.log)

    EmulationStation [ADDON] :: Restart kodi...

    Here is emulationstation_debug.log

    /storage/.kodi/addons/game.emulationstation/game.emulationstation-Gen: error while loading shared libraries: cannot open shared object file: No such file or directory

    I have tried uninstalling both apps, rebooting and reinstalling both and still the same problems.

    Kodi just restarts when trying to start emulationstation.

  • Ok, I see the problem: missing libs. I am going to update addon with that one but if you can ssh into your device and paste here the output of this command we can check if more libs are missing:

    ldd /storage/.kodi/addons/game.emulationstation/game.emulationstation-Gen

  • LibreELEC:~ # ldd /storage/.kodi/addons/game.emulationstation/game.emulationstation-Gen (0x00007ffe225d8000) => /usr/lib/ (0x00007f3310acc000) => not found => not found => not found => /usr/lib/ (0x00007f3310ff0000) => /storage/.kodi/addons/game.emulationstation/lib/ (0x00007f3310462000) => /storage/.kodi/addons/game.emulationstation/lib/ (0x00007f3310ed3000) => /usr/lib/ (0x00007f33101fc000) => /usr/lib/ (0x00007f3310179000) => /usr/lib/ (0x00007f330fdf9000) => /usr/lib/ (0x00007f330faf5000) => /usr/lib/ (0x00007f330f8de000)

    /lib64/ (0x00007f3310e64000) => /usr/lib/ (0x00007f330f6d1000) => /usr/lib/ (0x00007f3310ebb000) => /usr/lib/ (0x00007f330f4cd000) => /usr/lib/ (0x00007f330f2b0000) => /usr/lib/ (0x00007f330f25b000) => /usr/lib/ (0x00007f330f0a6000) => /usr/lib/ (0x00007f330ee9e000) => /usr/lib/ (0x00007f3310e97000) => /usr/lib/ (0x00007f330ee6f000) => /usr/lib/ (0x00007f3310e94000) => /usr/lib/ (0x00007f330ec5f000) => /usr/lib/ (0x00007f330eb34000) => /usr/lib/ (0x00007f330eb26000) => /usr/lib/ (0x00007f330e90f000)

  • LibreELEC:~ # ldd /storage/.kodi/addons/game.emulationstation/game.emulationstation-Gen

    Thanks for your help, now a new ES version is uploaded in repo including those missing libs for Generic devices, you need to go to "Install from repo" option, and use kodi's context menu to force repo update, then ES v.0.0.4 should appear. It is strange because in another device running LibreELEC for Generic it worked without them...

    How do you change guns in Doom? I am using a gamepad.

    libretro prboom port utilises normal Retroarch control configurations found in the RetroArch menu by pressing 'select+start' on your controller after the game software has launched. From the RetroArch menu, navigate to 'Quick Menu' and then to 'Controls'.

  • Two questions:

    If I have version 2.9 but want to try the Repo route, do I need to uninstall my current setup?

    2nd question: Can I delete the various consoles in the list in the AEL if I don't have ROMS for it (and never will) ? I just want NES and SNES to come up for example.