Gamestarter: Retrogaming add-ons (RPi/Generic)

  • Thx for the newest update! Any idea when we can expect updated cores? Heard the newest retropie was tailored more towards the RPi.

    I think cores are up to date enough as libretro core packages are from Lakka 2.3.2 ..which is latest..they where updated 4 months ago.


    Saying that you can always replace and download them yourself as some cores are modified and updated daily.


    bite_your_idols can enlighten us more on this.

  • Hi!


    I hope you can help me. I am desperate. I use an openelec build in rpi 3 because I have it for some years now. I am having the same problems with emulation station and retroarch. When it boots it takes me back to kodi. I am not sure how to solve it or were to look for the logs. Could you help me?


    Thank you so much!

    Edited once, last by Pablinho: UPDATE: I updated to libreelec (didn't know that was possible). But I still have a problem while booting ES. This is the emulationstation_debug.log: ConfigPath /storage/.config/emulationstation Couldn't load settings from "/storage/.config/emulationstation I don't know if I should erase everything in that folder so that it is created again. Would that work? ().

  • Hi!


    I hope you can help me. I am desperate. I use an openelec build in rpi 3 because I have it for some years now. I am having the same problems with emulation station and retroarch. When it boots it takes me back to kodi. I am not sure how to solve it or were to look for the logs. Could you help me?


    Thank you so much!

    Hi,

    I had the same problem with my RP4!


    This solves it on my pi:

    1. Uninstall RetroArch

    2. install the oldest Version you can find from Gamestarter Repo.

    3. Try to open RetroArch (on my pi nothing happens)

    4. Now update RetroArch the latest version

    5. After that go to the settings of retroarch an download liberty cores.

    6. Now try to start RetroArch


    No it works perfectly on my Raspberry Pi 4.


    good luck ;)

  • Hi!


    I hope you can help me. I am desperate. I use an openelec build in rpi 3 because I have it for some years now. I am having the same problems with emulation station and retroarch. When it boots it takes me back to kodi. I am not sure how to solve it or were to look for the logs. Could you help me?


    Thank you so much!

    Best you update to LibreElec before you try anything.

  • Hi!


    Thanks so much for the help. I updated to libreelec! It was a walk in the park, I was afraid of starting from scratch but the update from openelec to libreelec its awesome.


    Retroarch works like a charm now. I just have a doubt. When I want to play some games from Internet archive game launcher, for example pokemon blue, it opens retroarch, but for super metroid it gives me an option of snes emulators that work directly on kodi.


    Any idea why this is happening? I tried to make it run on retroarch but I couldn't find the option.


    Thank you so much for all the help!

  • After excessive tests i would stay in kodi for 2D games. Frametimes are a teeny tiny bit better there for some reason. Even with the same core.

  • After excessive tests i would stay in kodi for 2D games. Frametimes are a teeny tiny bit better there for some reason. Even with the same core.

    I tested with supermetroid but I didn't pass the new file selection because sound was shattering a lot, also it was a little slow.

  • I tested with supermetroid but I didn't pass the new file selection because sound was shattering a lot, also it was a little slow.

    Sounds like higan. Thas too much for the poor Raspi. Try snes9x current.

  • Sounds like higan. Thas too much for the poor Raspi. Try snes9x current.

    Yes! Was just waiting for your reply! I already tried with the snes9x and ran way much better. It has some sluttering but was playable. Seems like the power supply wasn't powerfull enought. I changed the power supply and now it runs perfectly on snes9x and now runs with slutter on kodi. You were able to run supermetroid on kodi without problem?


    So far everything is running perfectly in all aspects!


    Thanks to everyone!

  • Yes! Was just waiting for your reply! I already tried with the snes9x and ran way much better. It has some sluttering but was playable. Seems like the power supply wasn't powerfull enought. I changed the power supply and now it runs perfectly on snes9x and now runs with slutter on kodi. You were able to run supermetroid on kodi without problem?


    So far everything is running perfectly in all aspects!


    Thanks to everyone!

    Hey. I can run SNES both in Retroarch and IAGL (Kodi) without any problems. Just noticed slighty better frametimes, not fps, in Super Metroid and F-Zero in IAGL/Kodi for some reason. I have the Raspberry overclocked but that should really not be of any importance for SNES emulation. Be sure to have all the latest Libreelec updates installed (9.2.1, eeprom etc)

  • Hey. I can run SNES both in Retroarch and IAGL (Kodi) without any problems. Just noticed slighty better frametimes, not fps, in Super Metroid and F-Zero in IAGL/Kodi for some reason. I have the Raspberry overclocked but that should really not be of any importance for SNES emulation. Be sure to have all the latest Libreelec updates installed (9.2.1, eeprom etc).

    Gonna check that right now. What emulator you use in kodi? Maybe that is my problem. Since I am totally new with libreelec I don't know anything about playing directly in it.

  • Gonna check that right now. What emulator you use in kodi? Maybe that is my problem. Since I am totally new with libreelec I don't know anything about playing directly in it.

    The current snes9x. In Retroarch as well as in IAGL.

  • Gonna check that right now. What emulator you use in kodi? Maybe that is my problem. Since I am totally new with libreelec I don't know anything about playing directly in it.

    Best bet is use same choice of cores/launchers you use in retroarch also in retroplayer..they are the same libretro cores just modified to work in kodi..I tried a few of the main cores I m using in RA and moved them to retroplayer and they still work fine...you just have to rename them game.libretro.xxxx.so

  • Just test it. You are totally right! Until last night I didn't knew anything about the emulators so I was trying with th first one that appeared (one with a bug) and it was ultra slow. Then tried with one on retroarch that just crashed. I just tried snes9x on retroarch because I didn't notice that kodi also has it.


    Both options work great now that I now that the way to go is snes9x.


    Thank you so much Peter!

  • Hello all,


    First I would like to say thank you to all for your work in developing and supporting the Gamestarter add-on. Your efforts are gratefully appreciated!


    I am a new user to Kodi, LibreELEC, and RetroArch, so apologies in advance if my questions seem very basic or wording is not precise. I have LibreELEC v 9.2.1 installed with latest Kodi 18.6 on a Raspberry Pi4, and have been enjoying the Kodi experience so far. I have installed and used some of the Kodi Retorplayer cores to play some games to success, but would like to try RetroArch for additional cores and settings that may not be supported on the Retroplayer. I have installed your Gamestarter addon 3.0.0 and installed Retroarch v. 9.186.20, and selected the optional option to install all libreto cores.


    I am having difficulty getting my test games to run properly on Retroarch through LibreELEC, and some overall difficulty in navigating through the Retro Arch menus.


    On all the different roms and cores I have tested on (SNES - Snes 9x Current; PCEngine - Beetle PCE Fast; PS1 - PCSX ReArmed; Saturn - Yabasue; PSP - PPSPP), all seem to be running very slow (I would say around half framerates, cannot get display framerate option to save correctly). I have done very minimal setting changes in Retroarch besides mapping a controller, but any general advise I should try out to get my performacne to improve in Retroarch through LibreELEC (I can post settings log if kindly pointed navigation to correct log file needed to review)


    Also, another headache I have been having is difficulty navigating Retroarch. Specifically, whenever I seem to press the back button to return to previous system menu screen on any type of sub menu (Display Overlays options, ending game content and trying to load another game/core, updating system configs, etc), Retroarch is always closed and LibreElece starts Kodi back up. I managed to save the controller mapping configurations, but any other type of system config I cannot seem to get back to the main menu to successfully and always forced back to Kodi. I am using a 8bitdo bluetooth controller, and also had this issue when using a keyboard on initial load. Am I doing something wrong in trying to get back to Retroarch main menu, or did I accidentally change a Retroarch menu setting?


    Sorry for the long post, I would be most appreciative for any advice on how to make my Retroarch experience in Kodi a little better!

  • Also, another headache I have been having is difficulty navigating Retroarch. Specifically, whenever I seem to press the back button to return to previous system menu screen on any type of sub menu (Display Overlays options, ending game content and trying to load another game/core, updating system configs, etc), Retroarch is always closed and LibreElece starts Kodi back up. I managed to save the controller mapping configurations, but any other type of system config I cannot seem to get back to the main menu to successfully and always forced back to Kodi. I am using a 8bitdo bluetooth controller, and also had this issue when using a keyboard on initial load. Am I doing something wrong in trying to get back to Retroarch main menu, or did I accidentally change a Retroarch menu setting?


    Sorry for the long post, I would be most appreciative for any advice on how to make my Retroarch experience in Kodi a little better!

    Hi,

    are you using the default Ozone menu, or the older XMB?


    I have been playing with exactly similar setup (RPI4/Libreelec. 9.2.1/Kodi 18.6) and when I first installed Retroarch (few weeks back, clean install, not an upgrade), it was crashing immediately every time when trying to navigate the into any of the submenus in the settings.

    What helped me was to ssh into the RPi, find the config file for Retroarch and switch to xmb instead of Ozone for the menu.


    It seems that PeterB and MisterHans had also the same issue with Ozone on the same setup (RPI4/Libreelec. 9.2.1/Kodi 18.6), see post #1,068 and #1,075 above


    Seems that this exact issue is documented also here, with Retroarch installed on Lakka on Rpi4: When using the Ozone menu driver, navigating into any submenu causes RetroArch to crash · Issue #793 · libretro/Lakka-LibreELEC · GitHub .

  • Hi bite_your_idols,


    I've just started trying to get going with your repo on my Pi4 running libreELEC 9.2.1. I've downloaded the zip, and installed it. - Memory stick, enable allow unknown sources, install from .zip file. But I can't see any difference / new options. I have the official KODI repository for game emulators and the such (which I think is default)


    Have I missing something?


    Does this plugin create a GameStarter menu item in either the repos submenu or via the main menu Games option? I'm not seeing anything that looks like the first screen shot on your github page. I wonder if this is down to using a RPi4 or some other variable?


    I'd really like to use your plugin as there are so many other emulator options via the main KODI repo - a little unsure where to start with that lot!


    Many thanks in advance

  • Go to program addons/apps and games addons folders and all should be there..