Gamestarter: Retrogaming add-ons (RPi/Generic)

  • Hi


    I'm using LE 8.2.5 together with raspberry pi 3+ and I have downloaded gamestarter zip, added the repo and installed emulationstation and retroarch. The installation was straight forward.

    I tried to follow the instructions from GitHub - bite-your-idols/Gamestarter: Retrogaming kodi add-on repository for LibreELEC

    and put my roms /storage/emulators/roms/ and also configured emulationstation and retroarch under add-on + downloaded


    e.g. SNES under /storage/emulators/roms/snes/


    I'm using XBXO 360 wireless controller together with a USB bluethooth wireless receiver (it's similar to https://www.amazon.com/ortz-wireless-receiver-windows-vista/dp/b00tgl39ti/ref=sr_1_4?ie=utf8&qid=1549633937&sr=8-4&keywords=bluetooth+usb+receiver+xbox+360).

    When being inside Kodi the xbox 360 controller works fine and I can control it completely with the xbox 360 wireless controller.


    Try to play SNES games:

    Emulationstation: When I start emulationstation it starts fine (load the list of games for SNES) and I can even use the xbox 360 controller to navigate through the list of games, but as soon as I start a game, it shows a yellow message "XBOX 360 wireless controller (1183/...) not configured" and the game does not react to the xbox 360 controller.


    Retroarch: I couldn't control the menu via xbox 360 controller, but after using a USB keyboard, I was able to set the keys for "input 1 player" to use the xbox 360 controller 1 and also my second xbox 360 controller. Afterwards I was able to control the menu with the xbox 360 controllers as well. As soon as I start a game within retroarch I get again the message like in Emulationstation, that the XBOX 360 controller are not configured. (yellow message).


    -> I guess I'm missing the configuration of the controller for the in game and it seems to me, I need to configure the xbox 360 controllers somewhere else to be able to use them inside the games.

    Does someone know where I should configure the controller as well to be able to use them inside games ?


    Thank you very much

    Edited 2 times, last by muran ().

  • When you ran Emulation Station first time..did you get the configure controllers menu?If I remember well that will also set the controller for retroarch...

  • Hi Mario


    Yes, good point. I forgot to mention that for Emulationstation, I got the menu pop-up to configure my controllers -> I did configure them and the controllers are working in the menu (e.g. I can scroll up and down and also select a game with "A") -> but they don't work "inside" the game

  • Hi bite_your_idols .


    I have a quick question.


    Is there anyway to keep Kodi running in the background whilst using retroarch.


    The reason I ask I because I've just started trying out internet archive game launcher.


    It works fine with your gamestarter add-on but what I find annoying is then when I exit a game it loads Kodi again from start.


    It would be nice if it could just keep Kodi running and go back to the game list from internet archive game launcher.


    Thanks

    Rob

  • ...

    did you try downloading retroach autoconfig files from retroarch settings "online updater" menu? also you need to set your player 1/2/3/4... buttons from general input settings not from a context menu of a game, just in case.


    @robmcc83 is not possible... kodi takes a lot of resources and killing it is the way emulators run smooth... Maybe I can talk to IAGL dev and try to find put a solution. For instance, with AEL I save into a variable the section you were and after exiting retroarch and loading kodi again it takes you to that last section...

  • Thanks bite_your_idols

    That would be great as the cores on retroplayer main psx are not as good as retroarch.

    Or maybe the reason why is that Kodi GUI is still running.

    Either way IAGL seems like a good add-on so I'll see if I can get on with it keeps going back to home screen for the time being.

    Thanks

    Rob

  • did you try downloading retroach autoconfig files from retroarch settings "online updater" menu? also you need to set your player 1/2/3/4... buttons from general input settings not from a context menu of a game, just in case.


    @robmcc83 is not possible... kodi takes a lot of resources and killing it is the way emulators run smooth... Maybe I can talk to IAGL dev and try to find put a solution. For instance, with AEL I save into a variable the section you were and after exiting retroarch and loading kodi again it takes you to that last section...

    Thank you for your answer.

    I did do most of the "update" parts of retroarch menu "Online Updater" (e.g. update assets, joypad profiles, cheats, databases). Do you mean "Update joypad profiles"?


    I didn't configure the controller inside Kodi itself, because they are working without configure them (I guess it the default profile). When I go to "Input -> Configure attached controller -> Controller configuration" I see the Kodi profile of a controller looking like the xbox 360 and I can define the buttons. I went through all the buttons and set them there.

    -> Now the controllers are working inside the game. That was the solution (I guess I didn't run through the KODI controller setup).

    Thank you


    May I ask two last questions: How can I make the yellow message on the left corner "Frame ..." constantly counting upwards disappear?


    Thank you very much

    Edited once, last by muran ().

  • Thank you for your answer.

    Which part of retroarch would "did you try downloading retroach autoconfig files from retroarch settings "online updater" menu?" it be?

    I did do most of the "update" parts of retroarch menu "Online Updater" (e.g. update assets, joypad profiles, cheats, databases). Do you mean "Update joypad profiles"?

    I didn't configure the controller inside Kodi itself, because they are working without configure them (I guess it the default profile). When I go to "Input -> Configure attached controller -> Controller configuration" I see the Kodi profile of a controller looking like the xbox 360 and I can defien the buttons. I went through all the buttons and set them there.

    Do I need to do the "general settings" also somewhere else?

    Yes I mean "joypad profiles". In kodi you don't need to config anything... After setting gamepad inputs in retroarch, if it works ok in retroarch menu it should work in games... you can try to enter context menu when in a game and set buttons/keys for that core...

  • Yes I mean "joypad profiles". In kodi you don't need to config anything... After setting gamepad inputs in retroarch, if it works ok in retroarch menu it should work in games... you can try to enter context menu when in a game and set buttons/keys for that core...

    Thank you. That solved it.


    Do you know how I can get rid of the yellow frame count on the left hand side? (Frames ....)

  • Thank you. That solved it.


    Do you know how I can get rid of the yellow frame count on the left hand side? (Frames ....)

    Yeah, that's annoying... this line is needed in retroarch.cfg:

    Code
    1. framecount_show = "false"

    and you can switch it of manually from retroach: Settings>Onscreen Display>Onscreen Notifications>Display Frame Count>Of


    I just updated same addon version and this is fixed for new installations, but for existing installations it must be made "manually" because retroarch.cfg file is not overwriting, to maintain your custom settings.

  • Yeah, that's annoying... this line is needed in retroarch.cfg:

    Code
    1. framecount_show = "false"

    and you can switch it of manually from retroach: Settings>Onscreen Display>Onscreen Notifications>Display Frame Count>Of


    I just updated same addon version and this is fixed for new installations, but for existing installations it must be made "manually" because retroarch.cfg file is not overwriting, to maintain your custom settings.

    Perfect. Thank you.

  • Yeah, that's annoying... this line is needed in retroarch.cfg:

    Code
    1. framecount_show = "false"

    and you can switch it of manually from retroach: Settings>Onscreen Display>Onscreen Notifications>Display Frame Count>Of


    I just updated same addon version and this is fixed for new installations, but for existing installations it must be made "manually" because retroarch.cfg file is not overwriting, to maintain your custom settings.

    hello bud, can you help me with this

    Quote

    I dont have pulse audio driver in retroarch to get my bluetooth headset working any idea?