Gamestarter: Retrogaming add-ons (RPi/Generic)

  • Also im using a pi3+ you know way more about it than I do but the games run very smoothly so it doesnt really seem like its running short on memory.

  • In those logs I can not really see what is happening, I just can see you are launching a N64 rom.... let's try this, remove all logs then launch ES addon, then you need to try to launch psp game again, then grab those log files, then you can exit RA, ES, LE or shutdown your RPi.

  • Ok thank you. The other logs had n64 because i ran a couple games that worked before i tried the PSP games just for a comparison. This time I did as you said, I deleted all the ES and RA logs, ran the ES addon, attempted to load 3 or 4 different PSP games only, then went to fetch the new logs before quitting the ES addon. However RA did not make a new log at all only ES. Here it is it doesnt really look like anything is happening at all when i click on psp games in ES..

  • Mario, make sure what changes are saved exactly? the es config file? I reposted it after changing it looks to have saved it.

  • ok, since it doesn´t even try to launch retroarch it seems it is something related with ES and core name or path.... I can be that ES wants to launch standalone PPSSPP emulator instead libretro core...


    you can try this little hack, rename your psp core filename to psp_libretro.so then edit your es_systems.cfg file and change back the 144 line

    to

    <command>/storage/.kodi/addons/game.retroarch/addon.start psp %ROM% ES</command>


    Also you can go back to ppsspp line in es_systems and try using PPSSPP standalone emulator, by the way PPSSPP standalone used to had better performance


    Mario77 do you launch PSP libretro core from ES and it works ok for you?



    * please attacth all log files everytime because I need to follow the trail... XD

  • YOU ARE THE BEST!!! That did it thank you sooooo much. That file name must have just clashed with something else, I changed the cores name like you said to psp instead of ppsspp, then changed the es system cfg path back to psp and boom it works perfectly. Thank you Both so much for all the incredibly fast and helpful replies.

  • When I did the script PSP core was so laggy so I used PPSSPP emulator. So if the script recognizes that you want to launch a psp game it tries to launch standalone emulator... this is a bug in my code, sorry guys... I really don't use my Pi for emulation since I use My PSVITA so I really don't know when I will solve it... but if this workaround works it is nice!

  • installed gamestarter no sound from retroarch. intalled reborn remix got sound from retroarch. installed older 8.2.5 with gamestarter no sound. like retroarch getting used to it got set device to alsa , using chromebox . help with sound please

  • installed gamestarter no sound from retroarch. intalled reborn remix got sound from retroarch. installed older 8.2.5 with gamestarter no sound. like retroarch getting used to it got set device to alsa , using chromebox . help with sound please

    Check post #741 on this thread to get audio..

  • Thanks Mario77 was working on this for a few days. that was the exact problem. hope this can help other people with no sound in retroarch.


    In retroarch settings-audio- audio device enter hw:0,3 .thanks again really helpful Mario77

  • Thanks Mario77 was working on this for a few days. that was the exact problem. hope this can help other people with no sound in retroarch.


    In retroarch settings-audio- audio device enter hw:0,3 .thanks again really helpful Mario77

    Glad you'r sorted..Enjoy!

  • Hola! Antes de nada disculpa por no hablar en inglés, he visto en otro foro q hablas español, espero no incumplir ninguna norma.

    Es una pena que el addon original este abandonado. He instalado el repo y desde ahí el retroarch... pero como se configura? No se abre a pantalla completa, viene sin ningún core activado y tiene muchísimos parámetros de configuración. Trasteando he conseguido cargar una ROM de snes, pero me ha costado lo suyo. Luego tb he instalado emulationstation. Me reconoce bien las roms pero no me abre ninguna, imagino que es algo que debo configurar en retroarch...

    A todo esto uso un htpc con libreelec y arquitectura 64 bits. La última versión del addon (creo que fue la 2.9) me valdría para configurar retroarch, ES... Etc.?


    Gracias!

  • Hola! Antes de nada disculpa por no hablar en inglés, he visto en otro foro q hablas español, espero no incumplir ninguna norma.

    Es una pena que el addon original este abandonado. He instalado el repo y desde ahí el retroarch... pero como se configura? No se abre a pantalla completa, viene sin ningún core activado y tiene muchísimos parámetros de configuración. Trasteando he conseguido cargar una ROM de snes, pero me ha costado lo suyo. Luego tb he instalado emulationstation. Me reconoce bien las roms pero no me abre ninguna, imagino que es algo que debo configurar en retroarch...

    A todo esto uso un htpc con libreelec y arquitectura 64 bits. La última versión del addon (creo que fue la 2.9) me valdría para configurar retroarch, ES... Etc.?


    Gracias!

    Did you have a look here?

  • Did you have a look here?

    Yes! But I forgot this step:

    "Before launching the addon, you can download full Lakka core package (RPi/Generic) in settings window"

    Then I had to do some adjustments in audio and video outputs, and now is working fine. Even ES is doing well its job. The scraper is not working but that's another story. I will try AEL


    Thanks for your answer!

  • Yes! But I forgot this step:

    "Before launching the addon, you can download full Lakka core package (RPi/Generic) in settings window"

    Then I had to do some adjustments in audio and video outputs, and now is working fine. Even ES is doing well its job. The scraper is not working but that's another story. I will try AEL


    Thanks for your answer!

    Try this one for scraping from PC FastScraper...I scraped all my roms with it and works fine.