LibreELEC (Omega) 12 Beta1

  • Thank you for the new release. I just downloaded it and I am testing it now.

    As it seems, it still has the same issue with wifi that le 11 had, because iwd and connman could not work well together. Instead of rebooting until it works, which is what I did on le 11, this time I tried disabling and re-enabling it from le settings. The first time it started after 2 or 3 tries. This time I have already tried 9 or 10, but it still does not come up, so I connected via ethernet to ssh to it, get logs etc.

    So, what should I include on the new thread I am about to open?

  • As it seems, it still has the same issue with wifi that le 11 had, because iwd and connman could not work well together

    If this is about your ageing Amlogic box? the primary issue is the unmaintained Realtek vendor drivers it requires that are not fully conformant to modern kernel wireless frameworks, so no point/need to start threads on them. If you're lucky I might be able to persuade the person working on upstream support for RTL8192DU to look at RTL8189ES/FS in the mid-term future.

  • The download links for Pi 4 and 5 give a 404 because the URL still says "arm" instead of "aarch64", but once I found the correct link, the build for Pi 4 seemed to work fine. I had to manually install a couple of the LibreELEC add-ons, namely InputStream Adaptive and Network Tools, because the compatible versions don't come up in the repository yet, but that's pretty expected with a beta.

  • No, it is about x64, the generic-legacy img and my old laptop. Sorry for not mentioning it.

    The le 11 issue with wifi is/was platform independant though. I faced it on the nightlies of le 11 from May to September of 2022 on my rpi3b+, until I gave up completely on le there.

  • Thank you Hias, Netflix is happy again!

    Just for anyone else that has to RTFM open the Inputstream Helper addon and select Settings, under Expert choose (Re)install Widevine CDM library...



  • I get instant reboot with this in the logs when attempting to play videos over the network:

    2024-03-22 04:39:55.875 T:1215     info <general>: Creating InputStream

    Strangely when playing youtube video's via the youtube plugin everything works fine.

  • Raspi 4 now on Omega b1. Appears great and very stable. Many thanks!

    Have been on the nightlies for a long time with very few issues so no surprise really.

    The only issue i am still seeing is that sometimes HDR does not work after boot. A reboot fixes that, 100% repeatable.

    Have tried delaying the start of the Raspi a while after the AVR but does not help so far. No biggie but reported FWIW.

    Edit: some minor tweaks to the boot sequence in Home Assistant appears to have fixed it. So unlikely a LE issue.

    Edited 2 times, last by houser: update (March 23, 2024 at 10:51 AM).