DTS-HD Master Audio & Dolby TrueHD on 11.0.6 issues

  • Hi guys

    I just installed the latest 11.0.6 on my HTPC and instantly noticed no playback of DTS-HD Master audio or Dolby True-HD. Even tho in settings it was switched on. The HTPC is plugged directly into my Marantz SR7013 receiver via HDMI.

    The max I could get was Dolby Digital Plus or Dolby Atmos and DTS Surround.

    I removed the version and went back to an older version (19.5 Matrix) and instantly DTS-HD and Dolby worked again.

    I then re-installed the latest 11.0.6 and using the same backup I got the same issue. My AV receiver just couldn't get the HD Audio track.

    Any ideas?


  • We already had such misunderstanding a couple of times. Users think, an LE version is causing a loss of audio features, but most of the time that's not correct. Just a slightly higher HDMI data rate can remove audio features, when using a bad HDMI cable. "Bad" means bad shielding of the cable.

    In short, get an HDMI cable, which is conform to HDMI 2.0 or 2.1 standard. Such cables have better shielding, and are able to transmit higher data rates, as necessary for HD audio.

  • All of my HDMI cables are 4K rated as is my AV receiver, my TV etc.

    If the HDMI cable is faulty (which is isn't as its brand new from my work) why would I get a 4K picture on both KODI versions but no HD audio on the latest Nexus version? The audio formats I get on 19.5 Matrix are DTS-HD, Dolby TrueHD, IMAX Enhanced:DTS:X. On the new Nexus version they don't work, which tells me there is a possible issue with the new version.?

  • As mentioned, we already had such audio issues. Every non-4K cable has it's own limits. I assume you have pass-through activated at the audio settings. To figure it out on your setup with 4K cables...

    Please provide a full debug log.

    How to post a log (wiki)

    1. Enable debugging in Settings>System Settings>Logging
    2. Restart Kodi
    3. Replicate the problem
    4. Generate a log URL (do not post/upload logs to the forum)

    use "Settings > LibreELEC > System > Paste system logs" or run "pastekodi" over SSH, then post the URL link
  • Hi again

    Alright i have managed to create a log.... that link is below. Plus I have images to support the issue. I have also made hardware changes. Passthrough is always on and all audio selectors for Dolby/DTS etc etc are turned on.

    Link = paste.libreelec.tv/genuine-catfish.log

    Now I have upgraded the motherboard and have installed a Nvidia RTX3050 graphics card and grabbed an 8K HDMI cable from work. Made no difference whatsoever.

    Now in in the attached images, looking at Image 1, you can see that the file has DTS-HD Master Audio soundtrack. That shot was taken on my Windows PC... and I do get DTS-HD there.

    In Image 2 you can see that the KODI file listing it clearly states that it has that HD audio track. Now bear in mind that all of my movies that have the same audio track work perfectly fine with DTS-HD MA and DTS:X IMAX, Dolby True HD etc.

    In Image 3 you can see that the file is only playing in DTS. And in Image 4 you can see that I only have Dolby Digital and DTS. No HD tracks anywhere. If I revert back to 19.5 Matrix these files work perfectly with DTS-HD MA.

    I also looked at the log above and saw DTS HD Core there, so it's definitely there but for some reason the latest KODI version is blocking music videos HD audio tracks. Really odd I know. All of my music videos that have HD audio won't work with Nexus and I just get standard Dolby or DTS. Where Matrix they work fine.

    Hope this info helps.


  • Usage of banned add-ons means no support.

    March 15, 2016 at 1:02 AM
  • The problem is the file extension (.ts). Kodi introduced a bug a few versions back which caused this problem. See these 2 threads:

    Nexus doesn't seem to support DTS-HD Master Audio using the .m2ts file extension

    February 1, 2023 at 9:40 PM

    Convert one of your files to .mkv using MKVToolNix and it should work normally

    Kodi never corrected this problem

  • Cheers for your help... I kinda did a batch but each file had to be done manually, even tho they were all loaded at once. I had over 200 files in the old M2TS format. All working great now :)