RPi4 - No signal/image on Samsung QE55S95B (4K OLED)

  • I recently purchased a Samsung QE55S95B (Model 2022).

    When I tried to connect my RPi4 (running LibreELEC 10.0.2) using a deleyCON cable (HDMI 2.0/1.4a - High Speed with Ethernet - ARC 3D 4K Ultra HD 1080p 2160p) the TV keeps saying "no signal" or "power on device". I'm connecting to HDMI2. The Pi was working properly previously on my Samsung HDTV (UE42F5700).

    Adding "config_hdmi_boost=7" to config.txt and/or cmdline.txt didn't help.

    A fresh install of LibreELEC 11.0.3 had the same result.

    A fresh install of PiOS (64-bit) had the same result.

    I tried swapping out the HDMI cable for a different one but to no avail.

    What is odd is that when I start the PI without an SD-card, I do get a signal on the S95B. So this would imply that both cable and television are working properly.

    Anyone out there who would be able to help me troubleshoot this?

    Anyone out there with a similar TV who already faced and solved this issue?

  • Please provide a full debug log.

    How to post a log (wiki)

    1. Enable debugging in Settings>System Settings>Logging
    2. Restart Kodi
    3. Replicate the problem
    4. Generate a log URL (do not post/upload logs to the forum)

    use "Settings > LibreELEC > System > Paste system logs" or run "pastekodi" over SSH, then post the URL link
  • OMG!

    This morning I replaced the deleyCON HDMI cable with an official Raspberry Pi Micro to HDMI cable (it has the RPi logo on the connectors) and that did the trick. Sound & vision. Seems like the deleyCON cable is either faulty, too long or out od spec. I need to investigate further.