LibreELEC on NUC 11 audio cuts out

  • Hello, I have installed LibreELEC generic version on my NUC 11 Pro (NUC11TNHi3) with 16GB RAM, 500 GB SSD, the installation process went smooth.


    but I am having issues with the audio when playing a video, I have my TV connect it to receiver HDMI out and my NUC to receiver HDMI in.


    I have passthrough enable on kodi, when I play a video it every few second audio keeps cutting out. is there anyway to fix this?


    I have a Raspberry PI 4 with LibreELEC and Android TV box connected on the other HDMI in ports and both Kodi audio passthrough work great without issues.

  • I have passthrough enable on kodi, when I play a video it every few second audio keeps cutting out. is there anyway to fix this?

    Make sure you are running latest BIOS and have installed all firmware updates if available (e.g. HDMI firmware) - see here.
    If this would not solve the problem then try to search NUC forums for hints what should be the BIOS setup (like disable power management etc), it seems that NUC has often issues with hdmi audio on Linux distros.

  • I swapped hdmi cables, I installed the latest nightly v11, I updated my BIOS to the latest version and it still cuts out.


    I couldn't find any HDMI firmware for Nuc 11, only for Nuc 10 and below.


    On the Raspberry Pi and Android TV box, when I'm not playing a video on Kodi it says decoder off on my receiver, but with the NUC it says PCM and the 3 channels light up and keeps blinking a few seconds.

    Edited once, last by euroecua ().

  • I swapped hdmi cables, I installed the latest nightly v11, I updated my BIOS to the latest version and it still cuts out.

    Try with Power/Dynamic Power Tech switched to Off in the BIOS settings.

  • It’s interesting that it happens in windows too.


    May I ask what is the complete setup? What amplifier / receiver, TV etc.

  • It’s interesting that it happens in windows too.


    May I ask what is the complete setup? What amplifier / receiver, TV etc.

    Sony TV KDL-46EX520, Yamaha RX-V579 Receiver, NUC11TNHi3.

  • Have u tried bypassing the Yamaha and going straight into TV. Just to see if u get dropouts. Also I’m assuming u have Kodi set to 1080p and match frame rate turned on.

  • Have u tried bypassing the Yamaha and going straight into TV. Just to see if u get dropouts. Also I’m assuming u have Kodi set to 1080p and match frame rate turned on.


    When connecting directly into TV there's no dropouts, it only happens when I connect to the Yamaha, it also happens with VLC. on Windows 11

    Yes kodi is set to 1080p and match frame rate turned on.


    I connected my NUC 11 Enthusiast to the Yamaha and there's no dropouts with Kodi and VLC, so it's not the Yamaha.

    It seems the issues is with the NUC 11 Pro passthrough.

    Edited once, last by euroecua ().


  • When connecting directly into TV there's no dropouts

    Interesting. Considering that both Win/VLC and Unx/LE have similar issues with hdmi through Yamaha this might suggest some HDMI hw (edit: or rather firmware) incompatibility between that version of NUC and your Yamaha receiver. I wonder if you find any other people complaining for that specific combination of NUC-Rcvr?

    Edited 2 times, last by adam.h. ().