ScummVM add-on could not be loaded an unknown error has occurred

  • Hello,

    I am trying to run ScummVM and I am getting this error:

    ScummVM add-on could not be loaded an unknown error has occurred

    I can play other emulators just fine, is there anything I can do ?

    I am running LibreELEC 10 - Kodi 19.4

    Thank you

  • can you test a LE11 nightly (make a backup, you can't downgrade afterwards) ? maybe itis fixed there already

    Oh so its a LibreElec issue? nothing to do with the actual add-on

  • Oh so its a LibreElec issue?

    it is a undiscovered build issue, it works if A builds it, it does not if B builds it

    no build errors in both cases

    for LE11 we have a new build system that maybe just works for that case :)

  • Just tried…103-bb2fca8-rock64.img.gz and ScummVM didn't start.

    To be honest I'd prefer to fix it somehow manually in the actual stable I use. Is there somewhere documented how to "reproduce or not" the build-problem?

    If I could "not reproduce" the problem would I have to install the whole image or just replace the add-on?

    Edit: As I understood from what I read the build problem only exists on github and is not reproducible when building on other machines. A build I would do on my notebook (e.g. inside a docker image) should work and should not reproduce the problem, right?

    From what others wrote I guess that I'd have to replace the add-on only - like with one that vpeter build previously for people in this thread and that WebEye confirmed that it worked.

    Edit: Checked out libreelec-10.0 and build it successfully - what a ride ;-). Then build the addons game.libretro and game.libretro.scummvm. Updated my rock64 to the freshly build libreelec and installed the two addons. I could start scummvm - great!

    Added Monkey Island (first one, german version, files: 000.LFL 902.LFL 904.LFL DISK02.LEC DISK04.LEC 901.LFL 903.LFL DISK01.LEC DISK03.LEC) to scummvm and started it.

    Sound started, the midi tunes seemed to be mixed up, but I still could recognize them. Screen stayed black.

    On my notebook the same files work in scummvm.

    Updated my rock64 to the official version 10.0.3 again.

    Recognized that I may need to use 10.0.3 and checked out that tag to build the add-ons from that tree again and test them.

    Edit: Didn't make a difference. Or maybe a git checkout 10.0.3; git pulldidn't do what I expected. Anyway, opened an issue.

    Edited 4 times, last by ChriChri: update ().