Adding boot parameters to the rpi (and any arm build probably)

  • LE master (LE11) switched to iwd around a month ago. LE10 will remain on wpa_supplicant. The kernel splat you've posted is WARNING not ERROR, so probably not fatal. NB: I'm only reading the last few posts not the full thread, but I saw mention of "no b43" and wl shows in a log snipped. Historically we've used the wl vendor driver because it supported more chips, but this might need patching for the latest kernel changes, or perhaps dropping for in-kernel b43 if it disagrees with iwd.

  • Thank you for the info.


    I tested wifi on le 11 x64 a bit more, like so: boot > libreelec settings > connection > check if wireless is (at least) available in there right after boot > reboot and repeat. Out of 10 boots, the wifi was available only in 2 or 3 of them and never twice in a row. The good part on that is that is was also connected those 2-3 times it was available.

  • Please run "journalctl | paste" after clean boot and waiting ~2 mins after the Kodi home screen comes up. I want to see URLs for two logs; one for a good boot (WiFi working) and one for a bad boot (WiFi not-working) to see if there are any obvious issues. Test with LE11 as that's using newer drivers/kernel/iwd and should be the target for any changes (if needed).

  • Good boot

    http://ix.io/3IV8


    Bad boot

    http://ix.io/40Ae


    I had to connect via ethernet so as to ssh to it and do all that. The 2 minutes of waiting that you asked were checked via uptime, because I am no good at timing stuff without a clock :P

    Weird thing of the day is that the first boot was a good one, the second was a bad one and the third was a good one too. I booted for the third time because I wanted to check dmesg about wlan0 and it does say whatever is mentioned above with the warning.

  • When trying to get the paste for the good log, the url was returned after 3 tries. The first time a message like "nothing to paste" or something like that, the second time it got me back to the prompt without any url and the third time it got the url I posted above, which is obviously wrong.

    This situation has happened before, when I was trying to paste some relevant logs from the rpi. So, if the default paste service le is using is faulty, please consider switching to a different one.


    I will get a new good paste will be in a few minutes, because I am now troubleshooting some nfs share on my system.


    ---edit

    New paste from good boot

    http://ix.io/40Bd

    Edited once, last by jim_p ().

  • Thank you for the heads up. I just upgraded both my rpi and x64 installations to ccaf8be, so let's see what happens.

    On today's first boots, before the upgrade, none of the 2 systems connected wirelessly on boot, but I did not try connecting them after the upgrade.

  • The good news so far.

    The wireless on the x64 installation has come up after each boot so far, although I only did 2 with 20220625, and that long text of warnings does not show up anymore in dmesg

    I am now waiting for it to upgrade and boot to the 20220626.


    About the rpi, it connected wirelessly as it should after the upgrade to 20220626, but let's see how it goes the following days.


    ----edit

    I spoke too soon for the x64. First boot after the upgrade to 20220626 and wireless is down again. I brought it up with "ifconfig wlan0 up" and tried to reconnect with connman, but only to get that "Error /net/connman/technology/wifi: Not supported" error.

    Do I downgrade to 20220625 now or do I keep trying and post a new set of pastes for good and bad boots?

  • A difficult day started for the rpi. After 2 days of wirelessly connecting with no issues, I had to go wired today for the upgrade.

    I started downloading the 20220627 nightly and minimised putty's window. On my tiny 12Mbps connection, it takes ~100 seconds to download the ~1`20MB image for the rpi, so I let it run. I checked it again a few minutes later and it had frozen at ~50% of the way!

    I closed that connection, I sshed to it again from a new instance of putty, killed wget, for which I have no idea why was it still running, deleted the existing file just in case, downloaded the file again and rebooted when it was done.


    When the rpi boots, I usually wait for the green light to stop blinking before connecting via ssh, but this time it was lit up for 5+ (if not 10+) minutes straight, with no or minimal blinking! I sshed to it to run htop or something, but it came up again with the access denied error (like I said in message 53). Instead of unplugging the ethernet cable like last time, I decided to schedule a shutdown in the next 15-20 minutes with "shutdown -P 8:30".

    The green light turned off ~1 minute after I gave the command and at that time the system already at least 10+ minutes of uptime according to uptime (and uptime -s).

    I checked dmesg for anything weird, like ext4 corruption, but the only notable thing was that message about cec timeout. I then powered it off. I then started it again (cold boot) and tried to finally connect to the wireless via connman, but I got this... new behavior on the first try

    Code
    Agent ReportError wifi_bxxx_4xxx_managed_psk
    invalid-key
    Error /net/connman/service/wifi_bxxx_4xxx_managed_psk: Input/output error
    Agent request cancelled by ConnMan

    but it connected as usual on the second try, asking for the key again (as usual).

  • Instead of tracking down connman for errors and new messages when the rpi is not wirelessly connected, I decided to give it a static ip.

    It has become really annoying to unplug and move the rpi next to the router and connect it via ethernet, because it happens roughly once every 2 days. If that has no results, I will stop using the nightly on the rpi as well

  • Setting static ip on the wireless did not help. After a 2-3 of days with no issues, it failed to connect and I had to use ethernet again. This is what was happening all those days with dhcp, so no surprise there.

    However, I checked my router's log and the mac address of the rpi is nowhere in there. This means not that it tries to connect and fails, but that it does not even try to connect!

  • I want to scrub everything and start fresh (on x64, probably for le 10 nightly) and I know that libreelec's backup option practically backs up the entire /storage/.kodi folder and some stuff from here and there, e.g. stuff in the /storage/.cache folder.

    I think it does not back up stuff that do not belong to the above, e.g. files (that get_nightly and some scripts of mine) that I have under /storage or the forementioned change for the boot parameters. Am I right?

  • Thank you. Is there a way to start the backup task via ssh? I cannot access a hdmi-cec capable tv to do it via kodi :P

  • Backing up and starting fresh with le 11 on x64 had no impact on wifi's behavior.

    On second thought, the same could be done from option live of the boot menu. It saves a lot of time backing things up :P