Red screen of Death, while instaling LE Generic 10.0.0

  • Hi All so I tried this back a while ago when it was RC and though maybe it would be fixed by now.

    When starting a new install from USB with a freshly DL Image LibreELEC-Generic.x86_64-10.0.0.img.gz

    I get a redscreen you see below:

    My Machine is running B450M Pro4 P4.30 board with AMD Ryzen 5 2600 six core processor, 32 GB of DDR-2133 ram (2x16GB sticks)

    and a Gigabyte GeForce GTX 1050 Ti OC Low Profile 4GB GDDR5 128 bit PCI-E graphics card

    Prior version of OS ran perfectly no issues

    Hope some one can help


  • The first OOPS is the important one.

    Add pause_on_oops=100 to the APPEND line of /syslinux.cfg and take a new picture.

  • It's crashing while writing to the FAT FS. But there is no obvious error source visible.

    1. Have you already tried a different stick on a different USB port?

    2. You can test if a more recent kernel does behave better by booting a LE11 nightly from Do not install, LE11 is to unstable for daily use.

    3. For BIOS update 5.20 one description is "Improve USB compatibility", but I really do not like recommending BIOS updates.

  • Hi and again thanks for the qucik response.

    I even tried originally to do an upgrade and it get the same issue...

    Tried diferent stick, 3x different ports no success.

    Bios is at most current for recommended Processor type.

    Tried the nightly LibreELEC-Generic.x86_64-11.0-nightly-20210923-7455a76.img and get the exact same error gets to like 65% on the install

    its strange as i can install the LibreELEC-Generic.x86_64-9.2.6.img.gz with out a hitch :)

    Love the product been using it since 2013 keep up the great work, this is a brand new box build all new hardware so it perplexing why the 9.2 installs fine and this does not

    • Official Post

    Many years ago I had a main board with 4 RAM slots. I've been used RAM slot 1 and 3, slot 2 empty. That was a problem for the BIOS, and I had RAM access errors. So make sure you are using RAM slot 1 and 2, no omissions. Background: LE 10 is probably larger than 9.2.6, so the installation buffer might switch to the second RAM slot.

  • Hi Da Flex,

    Tried moving the mem to slots 1-2 from where it was 1-3 and made no difference :( and these chip set are 16GB each so thatys alot of memory for an install :)

    It must be the MoBo/CPU AMD combo as I even tried putting in a extenal SSD instead of using the MoBo m.2 and stilled failed

    it funny I just also upgrade my chromebox which is super inferior to this box and went flawless.

    maybe one day will swap out the board with an i5 intel chip and MoBo, but that when I have some spare $$$, unless something changes in the install

    Thanks again

    • Official Post

    Thanks for the info. My next theory is that it's related to a new Linux driver. I don't have the skills to compare all involved drivers.

    As a workaround, I suggest to install a regular Linux (like Ubuntu), and autostart Kodi.

  • It must be the MoBo/CPU AMD combo as I even tried putting in a extenal SSD instead of using the MoBo m.2 and stilled failed


    Maybe there are warnings/errors in the kernel log. Boot into installer, press <Alt-F3> to get the debug console and type:

    mount -o rw,remount /flash
    dmesg >/flash/dmesg.txt

    Put the file to a pastebin site and post the URL here.

    As a wild guess: we did enable IOMMU support in the kernel at some point. You can try amd_iommu=off kernel parameter to disable it.

  • Hi All,

    Hope I did this correct if you need me to do it again tell me..

    So I tried to do the install, it failed,

    I then ran the install did the Alt-F3 and followed the above

    paste bin URL is: MJASRock450 -

    on a side note I eve tried to run live and it barffed up LOL

    If this paste bin is wrong or grabed at the wrong time tell me and I will try again

    Thanks U all rock!!!!

  • Unfortunately there is nothing visible in the log.

    There is still the pause_on_oops=100 parameter in the Kernel command line, you can remove it now.

    amd_iommu=off is missing. Did you try it? (I'm getting out of ideas).

  • hi Melanie,

    Yah if adding that line to the same line as the pause_on_oops is where it goes tried that and still failed.

    I will go ahead and reinstall 9....

    And restore from that backup, was super excited for the release as have it running on my chrome box, but built this machine to run the 2k blurray movies with dolby atmos

    I have an Intel i5 but need to get a lga 1140 MoBo for it so maybe I will onedat try that build.

    Thanks for you help..

    You can close this out if yah want.

  • So Just becaus I like things to be completed or have a final answer...

    I swaped out the MoBo with an Gigabyte B450M DS3H V2 $75 investment, same CPU, Memory, M.2 SSD and was

    able to install LE 10

    Again thanks for all the help.