After Upgrade to LE 10 - missing german muted vowels of EXIF-Data in add-on (picture slideshow screensaver)

  • Hi everybody!


    I'm not shure, if this thread schould be placed here - or in the "add-on" branch. I decide to settle it here first.


    Preliminaries:


    1) RPi 4, 4GB RAM

    2) LE 10

    3) Picture Slideshow Screensaver 6.3.3


    The problem:


    Under LE 9.2 the shown EXIF Data in the add-on "Picture Slideshow Screensaver" was complete right - inclusive the german muted vowels (Ää,Üü,Öö an the "ß"). Without touching the terms in Kodi/LE, under LE 10 this changes. I've got now "special characters" in place.


    As a "non-professional" I experimented only with the settings in the Kondi standard skin - and - in the LE settings first, unfortunatly without any effect. My resarch in the net just gave me a hint to the different ways of saving those informations (XMP, EXIF, IPTC). If there is a way to solve it changing those settings in my prefered program that administrates my picures, this is not a real solution to touch thousends of pictures and editing something.


    I'm aware, that it seems that the add-on is no longer supported/further developed, but ist still in the repository for Kodi 19, isn't it? If not, I didn't find an adequate add-on to replace it yet.


    I would appreciate any hint, where LE 10 changes in comparison to 9.2 in the character settings - especially, as I did not change anything in that regional settings by updating the system.


    Thanks a lot for any help!


    R.

    Edited once, last by MacNoname ().

  • I've just looked and I do not see this add-on in the Kodi repo.

    Thanks for yor reply! I found it here (under matrix add-ons):



    Im not shure, but this (kodi.tv) isn't "official"? I thought it is..... Or did you refer only to the LE rep?


    Thanks for your answer! :)

    R.

    Edited 2 times, last by MacNoname ().

  • Ahh, it's under screensavers. I looked under picture add-ons. See if installing/setting a German locale (use the locale add-on in our repo) makes any difference. If not, post the problem to here: Picture Slideshow Screensaver which is the authors support thread in the Kodi forums.

    Hhmmm... I did not find a German local setting, For this add-on worked on LE 9.2.8 very well, I assumed, that it is a matter of LE 10 ... but I can post it there as additional information source, shure ..... :)

  • LibreELEC repo > services > locale

    OK. Thanks :) .


    But I think, there was a missunderstanding. I thought, you meant a locale, that should be delievered with the add-on (a locale, which obviouslydoes not exist, I'm afraid). The Kodi/LE German locale worked fine before within Kodi/LE after the update. But inspite of that, I hopefully installed thle locale out of the rep - and it had no effect.


    As you suggested, I posted it in the Kodi.tv blog an I'am still waiting for an answer. But I believe, that the problem is hidden in a change form LE 9.2 to LE 10..... :) I'll keep you informed ....


    R.

  • Did you install and then set the system locale to DE and reboot .. or just install the add-on?

    I did it the way you said: Installing, set the system to the german locale and rebooted the system.


    I also changed the presentation state within my photo program (from EXIF to XMP and IPTC) by incident. This succeeded to my surprise, but means in the end to touch and to edit thousands of pictures, which I try to avoid by all means, as you can imagine :-/ .


    Greetings!

    R.

    Edited 4 times, last by MacNoname ().

  • Sorry, it's not clear. Did setting the locale work? .. or you made some other changed that worked? Or it is still not working?

    :) - no matter.


    a) I installed an rebooted the system the way you suggested.

    b) Afterwards I edited the EXIF-Data of some pictures with my windows program and saved them (standard presentations: XMP instead EXIF).

    c) Obviously, that worked fine in the screensaver (all muted vowels were shown)


    Because it worked under LE 9.2, b) is not the desired soution, as this means to edit manually thousands of pictures .....


    So far now clear? Anyway, thanks for your replies and help!


    R.

  • I suggest you flag the issue to the add-on author via the Kodi forum thread.

    Tanks. I already did, but no respose yet.

    But, I still believe, that -if - it is an LE "problem", since the add-on uses the LE locale (and it worked before the upgrade to LE 10), as far I can see.


    I'll keep you informed, in case I 've found a solution. :)

    R.

    Edited once, last by MacNoname ().

    • Official Post

    Each Kodi version bump necessitates some rework from add-on authors, which creates an opportunity to fiddle and change things, and K18 > K19 included the Python2 > Python3 change which almost certainly mandated some rework. So where, say, the Krypton and the Leia versions of the add-on are probably quite similar, the Leia and Matrix versions are very likely to have bigger changes. The author is key..

  • Each Kodi version bump necessitates some rework from add-on authors, which creates an opportunity to fiddle and change things, and K18 > K19 included the Python2 > Python3 change which almost certainly mandated some rework. So where, say, the Krypton and the Leia versions of the add-on are probably quite similar, the Leia and Matrix versions are very likely to have bigger changes. The author is key..

    Hi!


    It seems, that I'll recieve no answer to my questions from the author.


    Thanks a lot for your support. In case I'll find the/a solution, I'll post it here.

    R.

  • Short appendix


    Little steps forward:


    a) I found out by myself where to edit charactersets within the application of the screensaver (guy.py), but I'didn't get a satisfying result yet

    b) Reading the Kodi Log, I found the following line:

    "ERROR <general>: WARNING: problems with charset recognition (b'\x1b')


    After a short research, I guess it belongs to problems with python 3 and "iptcinfo", as far I understood it ("the code is parsing the value of Iptc.Envelope.CharacterSet wrong" someone wrote elsewhere). Or am I totally wrong? I'll keep on investigating ... :)

  • A closer look at the comparsion of the code (gui.py) of the screensaver version 5.0.9 in LE 9.2, which worked perfectly, with the code in version 6.3.3 (which does not), let me guess, that there must be the reason in using python3 modules "exifread" and "iptcinfo3" (instead of EXIFvfs and ipctinfo in LE 9.2.). That are the main differences - and the main reasons of my problems, in my opinion. As I'm no programmer, my capabilities are at an end, for now. I decide to downgrade my whole environment back to LE 8.2 an Kodi 18 Lea, because this workes perfectly for me.


    Thanks for every support I received here.