Advice on Wetek Play 2 Replacement

  • Hello dear LibreELEC community,


    I have been a so happy with my Wetek Play 2 and now it seems it is time to upgrade due to lack of support on that board (unless I didn't find the secret build!) and also the acquisition of a new TV 4K HDR / Dolby vision capable.
    After browsing the forum here and the CoreELEC one as well, I am a bit lost as to what to pick TBH.


    It seems I will have to accept losing DVB-T/S capability built in, I do have on the other hand a USB DVB-T/C2 dongle.


    I am now in New Zealand and that is also restricting a lot of sources of suppliers.


    From my research so far to get HEVC 10Bit, 1Gbps LAN port and HDR support:

    • Odroid N2 + seems old, expensive and hard to get. Supplier in South Korea has also a very limited warranty
    • Building a PC or getting a NUC feels too expensive and I will be losing CEC capability ( I do like having only one remote :) )
    • I could source from amazon US a Beelink GT king, but it seems sort of old and I read quite a few complaints about them
    • Nvidia Shield Pro forces me to have Android TV, when I just want Kodi (Netflix, Amazon Prime and whatnot are built in my TV) so maybe too expensive for stuff I don't need.
    • I never own a Raspberry Pi and I read a lot of good stuff about the PI4. All out of stock here in NZ or overpriced, could get it from Amazon US. I was surprised about the mini HDMI port though
    • Then I checked all sort of Amlogic boards, Rockchip and Allwinner, but it's hard to figure out which will bring all the needed features, stability and won't break too soon.

    So that's where my research ended so far, with nothing super convincing or a clear upgrade path that could last another 2 to 3 years.

    /shrug

    Thank you for your advise,

    Matt

    • Official Post

    Index of /testing/ has an LE10.0.0 "box" image for WP2 (vendor u-boot) or brave souls can erase the emmc and then install mainline u-boot (to emmc) via the "wetek-play2" image but support for hardware decoding in the upstream kernel is still a bit rough and the DVB tuners are not supported. These days fewer people are shipping DVB cards in-box and my advice would be to separate "head end" with tuners that is accessed over the network from a dumb(er) "client" device. If you need the tuner and the WP2 still works; you can keep it going with current software just to serve the tuners while using a newer client device.


    4K/HEVC and 1080p H264 is handled well in RPi4B, but it is missing VP9 which (along with any other codecs) is software decoded, the chip has lots of grunt though so up to 1080p that's not a big issue. Allwinner/Rockchip have continuous ongoing work around the hardware decoders but they are now quite mature and shaping up .. but there's a mix of older chips and newer ones and it's a little confusing. Amlogic (LE) has the same issues on G12/SM1 boards as the WP2/GXBB device you have (if anything they are worse, the newer chips have more complicated HEVC/VP9) but CE with legacy vendor kernels is a better option, but AFAIK they do not have DV running. OSMC does support it in their Vero 4K box, and you'll find Android devices that do it (but that's not my area of expertise).


    Not sure that helps. I'm personally a fan of the RPi4B. There are lots of devices with technically better specs but it has (and will continue to have) great software support and IMHO that's the most important thing for longegivity of devices.

  • Be warned that LE10 on the RPi4 is lacking deinterlacing, so is no good for live TV. Once the Pi get deinterlacing it would be a clear winner in my view.

  • Thanks for you answers so far. I read in depth also this Kodi post START HERE - Pick the right Kodi box (updated Dec 2020) where I think it might not be up to date with the current release.


    I'm not too sure I understand how well the RPi4 handles HDR and heavy video format...

    Here is an example of what the Wetek Play2 has no issue whatsoever to play, except outputting the correct colour space.




    Plex embedded TV app, even with the pass (for HDR) failed miserably with the above and, my Panasonic TV cannot output the audio when that file is played from a USB key within its own video file app.


    If you all tell me I will have some peace of mind with a RPi4 and LE, I found this that can be delivered to NZ from amazon bundled by CanaKit for not too much sur-charge.

    Is LE10.0.0 "box" image for WP2 (vendor u-boot) only possible to install on the EMMC?

    • Official Post

    I don't include or support the community scripts for instaling stuff to emmc with vendor u-boot; my knowledge of it all is poor and the scripts often cause problems. If you boot from the "box" image you can download the "wetek-play2" image and write it to emmc (replacing vendor u-boot with mainline which I understand more) using "emmctool" .. but I'd caution against doing that unless you're comfortable with how to restore it back to the original WeTek code again should you not like it. IMHO there's not a huge difference between running from a decent SD card and eMMC.

  • Tried all 3 USB ports with no luck. (used new USB key and tested with both the version 10 you shared and LE9.0.2).

    Would the internal port be worth a try?

    I tested holding the SD card in and it manages to boot on my previous install. The moment I let go, the SD is out and disconnected. However, using another SD card, I cannot boot your version 10.


    Since the WeOS is out of date and rubbish, I'm thinking if I could get it working with latest, I could wipe the EMMC and run LE from internal only. The SD-Card slot repair is likely no worth the effort of trying to repair.


    However, I'm not sure how I can achieve that install. Anything that can be done from the Android recovery loader?

    • Official Post

    The internal port might be worth trying .. I always forget about it. If not, perhaps hold the card in with a woodworking clamp (not too tight) to boot and then download/overwrite the eMMC with LibreELEC-AMLGX.arm-10.0.0-wetek-play2.img.gz. Once you flash mainline u-boot you'll be able to boot/run the LE10 image from eMMC fine (seems to work okay for me) although the current state of Amlogic in LE10 is far from perfect.

  • Thanks for this chewitt.

    Is it only a simple dd to the eMMC from the downloaded img file or is there something more to do within bash of LE9.0.2 once booted?

    • Official Post
    Code
    cd /storage
    wget https://chewitt.libreelec.tv/testing/LibreELEC-AMLGX.arm-10.0.0-wetek-play2.img.gz
    emmctool w LibreELEC-AMLGX.arm-10.0.0-wetek-play2.img.gz

    ^ that downloads the file, writes it to emmc, expands the storage partition, changes disk labels, then sets extlinux.conf to boot from the new disk labels (so SD boot still works).

  • I might of messed up something: blank display and cannot get to boot back to SD.


    Though the output seemed ok...


    • Official Post

    There are two issues:


    a) I'm still jetlagged and a bit distracted after vacation, which means I forgot something rather important

    b) You've erased u-boot


    GXL (S905X) and newer boxes look for a magic boot header in the 1st sector of emmc or 512th sector of emmc or SD or USB, but older GXBB boxes like WP2 only look for it in the 1st sector of emmc (or 512th sector of SD or USB). The problem is, the first sector is also where the MBR partitioning data lives, so you have the choice of partitions and no-boot, or boot and no-paritions. Amlogic "vendor" u-boot implements a custom offset-MBR partition scheme to workaround the design mistake (which is corrected from GXL onwards).


    If you connect the UART cable (WeTek did ship them with the box) you'll see it endlessly looping with something like:


    "GXBB:BL1:08dafd:0a8993;FEAT:EDFC318C;POC:3;RCY:0;EMMC:800;NAND:81;SD:0;READ:0;CHK:0;"


    It's not bricked. It simply means it cannot find the magic boot header. The normal way out of this is to write the "wetek-play2" image to an SD card and leave it connected. It will then boot from SD and you can tweak things to store data on emmc if desired. In your case the SD slot will not permanently latch/retain the card, but you'll need to figure out a temporary way to hold/fix the card in for long enough to boot from SD and perform some remedial steps. I would start by zero'ing the emmc (the z option in emmctool) and then "dd" u-boot.bin.sd.bin-wetek-play2 directly to /dev/mmcblk1 (no offsets, seeks, etc.). This will put mainline u-boot and the magic boot header in the 1st sector, so the box will boot from emmc, and u-boot should find the "wetek-play2" image on a connected USB stick.


    The alternative is putting the original vendor image back by writing Dropbox - backup-wp2.img.gz - Simplify your life directly to /dev/mmcblk1 and then rebooting. This is a raw backup of my box taken a couple of years ago .. but should work.


    Apologies again .. I'd completely forgotten that GXBB has the extra hoop to jump through.

  • No worries, these things happen.

    just so I don't do a mistake, what do you mean by write the "wetek-play2" image to an SD card and leave it connected? Are you referring to your builds? Today I couldn't boot back to the SD after the erasure. ( I did find a way to keep the SD in place by the way).

    I'm off to bed as it is the time on this side of the world and will try to sort it out tomorrow with fresh eyes :)

    Thanks again for your assistance

  • Hooray!! I got it booting from internal storage after a dozen attempts. Thought there is no sound which is strange as when I booted from the SD sound was working perfectly out of the box. I'll try to figure it out.


    Here the extract of what I did on my final attempt that worked:



    What is strange is dd did not work


    Code
    dd if=/storage/u-boot.bin.sd.bin-wetek-play2 of=/dev/mmcblk1


    Unless I miss-read, dd without options should not offset or seek. If the command is correct, I took an strace just in case if you need it.

    I'll dig into the sound issue and will let you know.


    Thanks a lot! :D


    How can I send you beers or coffee over?