No picture and sound via Yamaha Surroundbar

  • Thanks for testing. HDMI modes on both logs are the same, so that part of the pass-through works.

    The logs are the same because the HDMI infos are all replaced by the hdmi_safe settings - and therefore the number of audio channels is also only 2 (that comes from the failsafe settings, too).


    To get any meaningful logs or info about the TV or soundbar these hdmi settings need to be removed from config.txt before.


    so long,


    Hias

  • Now the sound works via the soundbar, but the TV remains dark

    Raspi 4, Argone One m.2,LibreElec 10.0.0

  • Thanks a lot for the logs!


    If you have to use hdmi_force_hotplug on the RPi then I suspect the hotplug-detect signal might be indeed the culprit and the soundbar doesn't detect the TV because of that.


    When directly connected the RPi got a valid edid from the TV, indicating 1920x1080p60 as preferred mode.


    The edid from the soundbar looks like it sent a fallback safe-mode one - preferred mode is 1280x720p60 and the 24Hz mode from your TV are missing. But AC3, DTS and multi-channel audio support is listed.


    The hotplug detect issue could be caused by the cable (hotplug not wired up or cable broken) or it could also be caused by your TV "misbehaving". Both of that happened to others before, too.


    Using a different HDMI cable and/or HDMI port on your TV would be the easiest thing to try. Other than that I'm out of ideas - if the TV and soundbar don't play well together because of the TV's hotplug issue I'm not sure there's anything easy you could do about it.


    so long,


    Hias

  • It works.

    I plugged in another HDMI cable and another port from the TV (HDMI3 instead of HDMI1).

    What still doesn't work is that the Surroundbar switches on when a signal comes from the Raspi and switches off when the Raspi shuts down.


    Is there anything else I can do?

    Raspi 4, Argone One m.2,LibreElec 10.0.0

  • On LG soundbar (SL10YG) I had to turn on the setting "Auto Power On/Off" to make that work.

    My setup in livingroom is RPi4 HDMI -> TV HDMI, TV HDMI ARC <-> Soundbar HDMI ARC.

    (Optical is conected but not used)

    => Just my 5 cents...

    ..//Jocke.Sve

  • On LG soundbar (SL10YG) I had to turn on the setting "Auto Power On/Off" to make that work.


    Yes is with me also so is unfortunately not in the supplied manual.have had to look in the Inet.

    Raspi 4, Argone One m.2,LibreElec 10.0.0