libreleec 9.97.1/10.0 matrix Networking not connecting automatically

  • Just installed as a fresh image but each time I reboot the pi I have to go into librelec settings and manually connect to my wired network. If I tick the connect automatically box and hit save as a soon as I go back into it to check its deactivated.

  • I had the exact same issue with a Pi4 with LE10 connected via ethernet to a switch. Even with 'Wait for network' enabled with timeout at 30 seconds, and even if I set all the IP settings for the connection manually instead of using DHCP, the 'connect automatically' switch would not stay enabled.... if the Pi or the switch was rebooted, the network connection became idle and had to be manually refreshed to connect.

    The problem went away after a did a full clean install of LE 10 and re-did all my settings instead of importing from a LE 9 backup, which also fixed a range of other small, funky things.

  • Same problem with my P4 and LE10. Probably it came up after recent Update to 10.0.1, but I'm not sure. My wired connection used to connect automatically. But after I have tried manual, I am not able to save the change when I set the slider back to automatic.

    I tried the same with the wireless connection. After I had activated wifi, I left the automatic setting. Then I changed to manual and guess what: I wasn’t able to save the settings when I set the slider back to automatic.

    Is there a way to edit a LE config file directly to make the change there instead of via Kodi-LE menu?

    I upload the log/journal to But I think it doesn't make sense to run journal export a second time as the amendment in the network configuration isn't saved anyway.

  • Editing the add-on's settings file is possible when you first stop the Kodi application, edit/save the file, and restart Kodi.

    systemctl stop kodi

    nano oesettings.xml

    systemctl start kodi

    You'll need to be in the correct add-on folder first to edit the xml file, of course.

    I would also check first if the storage partition on the SDcard isn't in a readonly state with the Gparted tool, because settings not being saved is weird.