10b2 - Poor transfer speed

  • I came across another issue, the network speed.


    My Setup : 3 Raspberry Pi 4.

    One Raspberry Pi is the Master. Holding a Samba Shared HardDrive and a MariaDB Database.

    The other two have access to the network drive and the database.


    I'm with the Beta2.

    Im copying the files from a windows 10 computer thru the network on the Master Pi.

    All the network is Gigabit and fully tested with network tool hardware.


    My child pointed me that issue because the file was "lagging". I was copying new files on the hard drive at this time.


    I did notice the speed was not stable, from 40mb/s to 8mb/s. Normally Im doing 75mb/s (limited by the hard drive speed).



    I have my previous SD card with the same setup but with 9.2.6. I've changed all my SD card and reverted the setup to 9.2.6.

    Now, I do not have any other issue like this.


    My score in 9.2.6 :


    If nothing is playing 75mb/s.

    If there is one 4k file playing I can do 45-55mb/s.

    If there is two 4K file playing I can do 30-40mb/s.

    If there is three 4k file plyaing, I can do 20-30mb/s.

    And at no point I notice a "lag" in any file.


    With 10 Beta 2, I CANNOT copy new file while playing a 4k file.

    If nothing is playing, Transfert speed varry between 45mb/s to 10-15mb/s.


    Note : All raspberry pi driver are up-to-date (chipset,usb).

  • If nothing is playing 75mb/s.

    If you are talking about speeds measured in megabytes per second, 75 MB/s equals 600 Mb/s (megabits per second) is not bad for a small gadget. What did you expect?


    The transfer speed is always determined by the slowest device.

    Edited once, last by elonesna ().

  • read my post


    On 9.2.6 I do 75mb/s. That perfect.

    On 10b2 I do BARELLY over 40mb/s and it is not constant... and drop at 8mb/s.