Files not playing via NFS share but OK via local USB

  • Using 9.2.6 on an Intel NUC6CAYH for a long time with no issues. Recently, certain video files will not play or even have thumbnails shown, while the same files placed on a thumbdrive play no problem. The files are served from an NFS server in my local network and are fully browseable, just not playable. Many files remain playable. Until the issue showed up, everything was playable. There have been no changes to the Ubuntu-based NFS server config other than ongoing normal Ubuntu updates.


    A full reinstall of LE did not help, neither did upgrade/downgrades.


    Log is at http://ix.io/2X0P. Note the "Error creating demuxer" entries. Any ideas?

  • It's Ubuntu 20.04.2 LTS (GNU/Linux 5.8.0-50-generic x86_64). Thought I was going mad so glad to see it's a known issue.


    Github mentions it was fixed in 5.10.15 so looks like I will have to wait for Ubuntu 21.04 to receive that.


    Thanks a bunch !

  • Likely the 5.8.0-50 kernel now include a backport of the failing patch. Yo can try to continue using 5.8.0-49 or 5.8.0-48 until the bug is fixed.

    • Official Post

    I thought I had some NFS hiccups too when going from UB 16.04 server to 20.04 (it's been a while).

    So I installed 18.04 instead, and it works as advertised.

  • I'm having the same issue. The NFS share is on a Ubuntu 20.04.2 LTS box and LibreElec on 9.95 version


    Is there another solution besides downgrading?

    • Official Post

    Chances are, that the NFS bug is in all Ubuntu 20.04 flavors...


    BTW, I'm running Ubuntu Server 18.04 off a USB device dangling on the outside of the PC/server from an USB3.0 port. I can recommend it. Once the OS has started and all is running, I don't notice any difference from an internal SSD system disk.

  • I suddenly got the problem where NONE of my movies would play on Libreelec.

    Libreelec Leia with NFS shares from a Debian OpenMediaVault Server - all worked - then DID'NT


    After a LOT of experimentation I have found similar aspect to above...


    Copying a file from the server to the Storage folder of Libreelec - file plays perfectly.

    Attempting the same file over NFS - sometimes fails to play - other times crashed Libreelec.


    The NFS shares work perfectly when accessed from other Linus machines on the network


    Can anyone shed any light on this.


    BTW this is the SAME on the Beta version 10.


    JJ

  • In case of the bug linked in post 2 (or any other kernel issue) use a kernel on the server that is not affected, i.e. an older one.

  • I just bumped my Ubuntu version from 20.04.2 LTS to 20.10 and the issue remains


    ~ lsb_release -a

    No LSB modules are available.

    Distributor ID: Ubuntu

    Description: Ubuntu 20.10

    Release: 20.10

    Codename: groovy


    ~ uname -srm

    Linux 5.8.0-50-generic x86_64

  • Linux 5.8.0-50-generic x86_64

    Same kernel, same behavior (still assuming it is a kernel issue).


    If you like to test different kernel versions there is a script to easily administarte mainline kernels: GitHub - pimlie/ubuntu-mainline-kernel.sh: Bash script for Ubuntu (and derivatives) to easily (un)install kernels from the Ubuntu Kernel PPA. Please read the Warnings section. In addition test if the grub boot menu can be activated by pressing ESC or holding the Shift key on your machine before installing any additional kernel.

  • Hi,


    You're right. I've jumped to 21.04, and now it works.


    lsb_release -a

    No LSB modules are available.

    Distributor ID: Ubuntu

    Description: Ubuntu 21.04

    Release: 21.04

    Codename: hirsute


    uname -srm

    Linux 5.11.0-16-generic x86_64


    Just to confirm that I did not touch LibreElec setup at all. After the upgrade, the files served by the Ubuntu NFS server were playable again.