Many more data errors since updating to LE10 beta on RPi4

  • Hi,

    I recently updated my RPi4 to LE10 beta, and also tried a nightly build (16 April).

    I have noticed many more data errors and even failed recordings compared to LE 9.2.6. I am using three X-Box One TV tuners, which have been working fine with LE9, and the errors seem to occur on all tuners, which would seem to suggest it is unlikely that I am looking at a tuner failure.

    I have just had two failed recordings, and it would seem (at least to me) that the data errors occur when I am actively playing back the recordings, including skipping through with the remote (microsoft MCE USB receiver). I now have a recording running on the same channel/tuner as one that failed earlier, and it seems that as long as I don't touch it, the number of data errors is not increasing at a significant rate.

    Please don't think I am complaining. I know this is a beta version. But I wondered if someone could tell me what the situation is, so I can make the best decision (revert to 9.2.6 possibly) as this is my 'main' TV server.

    So, is there a known problem with USB tuners on LE10? I didn't install any driver packages. Should I?

    Any insight would be very welcome. I did post about this in the WinTV DualHD thread in the context of whether that tuner would be better, but it seems better to start a new thread for this issue.

    Service.txt shows lots of this

    2021-04-17 19:56:40.164 [WARNING] tbl-pass: pass-sdt: -: invalid checksum (len 260, errors 16)

    2021-04-17 19:56:41.269 [WARNING] TS: DVB-T Network/658MHz/Channel 4: MPEG2VIDEO @ #1101 Continuity counter error (total 5517)

    2021-04-17 19:56:41.269 [WARNING] TS: DVB-T Network/658MHz/Channel 4: MPEG2AUDIO @ #1102 Continuity counter error (total 1095)

    2021-04-17 19:56:41.542 [WARNING] tbl-pass: pass-eit: -: invalid checksum (len 278, errors 285)

    2021-04-17 19:56:43.827 [WARNING] TS: DVB-T Network/658MHz/Channel 4: MPEG2AUDIO @ #1103 Continuity counter error (total 371)

    2021-04-17 19:56:55.310 [WARNING] TS: DVB-T Network/658MHz/Channel 4 Transport error indicator (total 11931)

    2021-04-17 19:56:55.768 [WARNING] TS: DVB-T Network/658MHz/Channel 4: MPEG2VIDEO @ #1101 Continuity counter error (total 5737)

    2021-04-17 19:56:55.830 [WARNING] tbl-pass: pass-eit: -: invalid checksum (len 1387, errors 313)

    2021-04-17 19:56:57.239 [WARNING] TS: DVB-T Network/658MHz/Channel 4: MPEG2AUDIO @ #1102 Continuity counter error (total 1130)

    2021-04-17 19:56:57.490 [WARNING] tbl-pass: pass-pmt: -: invalid checksum (len 80, errors 58)

    2021-04-17 20:00:38.101 [WARNING] TS: DVB-T Network/658MHz/Channel 4 Transport error indicator (total 11970)

    Best wishes,


  • I encountered the same since upgrading to 10b1 (RPi4)

    I am using tv-headend Server and client plugin from the LE repo with IPTV from german Telekom. It worked nearly flawless with LE 9.2.6

    LE 10b1 has MANY changes, finding the cause will be a big deal i believe ;)

    I hope anyways that it get fixed in the future.

  • As an added data point, I've set up another memory card with LE9.2.6, and so far it seems to be fine - no data errors.

    So, it's either LE10 or the other microSD card.

    I am going to keep both cards running, so I can help with any testing.

  • Okay, so I'm struggling.

    I am still having some issues with 9.2.6, but it doesn't seem as bad as 10b1.

    It seems that when I play a recording back while it's still running, I get a lot more data errors. This happened this evening, but I didn't notice while it was running, so maybe it's always happened. Having checked the actual recording file, there was a massive amount of garbage after the actual programme, which may have coincided with when I stopped the playback.

    If something records in the middle of the night, no data errors.

    So, is the RPi4 just not up to playing back a recording while it's running? Is the problem that the MicroSD card isn't fast enough (SanDisk class 10)? Could it be something stupid like birds landing on the aerial?

    Next up is to plug a second Pi4 in for playback, and just have LE9.2.6 on the 'server'.

    Any more ideas for debugging this?

    Seems to be happening on LE9.2.6 and LE10b1, but definitely worse on LE10b1. Happening on multiple TV tuners. Aerial hasn't changed. Happens with two different microSD cards.

    Edited once, last by elliottmc ().

  • Hi, I have the same issue with rpi4, no solution for me so far.

  • Thanks for pointing out this thread. I'd missed it.

    So, it seems (initial testing) that this only happens if the playback is on the same raspberry pi. If it is playing back on another client on the network, it seems fine. I pushed the limit on this recording one HD and one SD channel simultaneously (two different muxes so two different tuners). Playing these in-progress recordings on a Windows PC over the network was fine.

    Of course, with the Pi, it's a question of whether the act of playing the in-progress recording is the problem, or perhaps the USB remote interferes with the USB tuner. Yesterday, I watched an in-progress recording most of the way through without a problem, and the recording only had problems at the end, which MIGHT have been when I hit the stop button and navigated out o f TV using the remote. This link does bear more investigation.

    More data points would definitely be useful.

    For me, I'm more than happy to put Raspberry Pi OS on one Pi to use as the TV server, and then have another one for the Kodi box. What I don't want to do is spend lots on different TV tuners, remotes, storage, and then find there wasn't anything I could have done.

  • Okay, I think I have progress.

    I created folders on my NAS for timeshift and recordings. Figured it wouldn't hurt to use that for all disk bashing. Obviously I had to mount them in LibreElec.

    At the same time, I dropped down to a single tuner plugged directly into the aerial, cutting out the signal booster. This seemed to work fine, so I dug out my previous signal booster and switched back to that.

    Touch wood, I haven't had any data errors.

    Of course, I don't know which of these things has had the biggest impact. I'm inclined to suggest the signal booster, although I was getting good signal reported.