Rpi 4 B Audio Stutter

  • You have disabled buffering with buffer mode 3. A minimum of necessary data still goes into RAM. With memory size 0 you will use microSD instead of RAM. To avoid an early death of your microSD, use memory size 0 just for testing, not for permanent usage.


    What's the result of your overclocking test?

    Which LE version do you use for testing?

    Does pastekodi show any unusual output when you get audio errors? If yes, post the link.H

    Here is a link to a Pastebin of the log of the current stable version of LibreElec while watching an episode of Star Trek: Enterprise. It usually has the audio stutter toward the end of the episode (note: stutter happens on Patton, the movie, as well as on other things randomly) and it happened around 01:37:43 PM or so and stuttered ever so often through 01:41 PM. I have included that log portion here for you to look at. Could you please see what you can see? I don't know what I am looking for. So I don't know if it seems to have an error or not. This is before I force turbo. Working on that now.


    Log File Paste

  • I believe I have enabled force turbo. I made sure to write out and save and exit. Can you confirm that for me based on my config file paste below? Is there any way to know in the GUI if it is enabled for sure?


    Config File

  • Your config.txt is OK, changes will have effect after reboot. If you enable debugging at GUI, you should see clock speed (I guess).

    Flexin' vinyl, jammin' break beats. 8)

  • Your config.txt is OK, changes will have effect after reboot. If you enable debugging at GUI, you should see clock speed (I guess).

    Thank you.


    Hopefully, my log file will put some light on what is going on. Can someone take a look and see if they see anything out of place? I'd appreciate it as I am new to LibreElec.

  • Thanks for the log! The log says "CAESinkPi:AddPackets Underrun (delay:0.00 frames:512)". This could mean that your network buffer runs empty. To avoid this, try this: Click!

    Flexin' vinyl, jammin' break beats. 8)

  • Thank you. Two questions...


    1. Does the advanced settings at the link above change based on the fact I am running a 8GB RPI 4B? If so, what would be the settings you would recommend? If not, I'll put them in verbatim as they are at the link.


    2. Does the network buffer still matter even though I am playing local MKV files through USB 3.0?


    Just to be clear I never see a buffer ring. The audio just drops out for a second and sometimes the video will slow very sightly at that point for a second and recover.

  • Sorry, for playing local files you need this (buffer mode 1):

    Code
    <advancedsettings version="1.0">
        <cache>
            <memorysize>2000000000</memorysize> <!-- 2GB buffer size -->
            <buffermode>1</buffermode> <!-- buffer all filesystems -->
            <readfactor>8.0</readfactor> <!-- doubles the default readfactor -->
        </cache>
    </advancedsettings>

    I think audio stutter can indicate a buffer underrun, especially because your video slows down a bit, too. 2GB buffer is a lot, but no problem for your 8GB device. Try it!

    Flexin' vinyl, jammin' break beats. 8)

  • Sorry, for playing local files you need this (buffer mode 1):

    Code
    <advancedsettings version="1.0">
        <cache>
            <memorysize>2000000000</memorysize> <!-- 2GB buffer size -->
            <buffermode>1</buffermode> <!-- buffer all filesystems -->
            <readfactor>8.0</readfactor> <!-- doubles the default readfactor -->
        </cache>
    </advancedsettings>

    I think audio stutter can indicate a buffer underrun, especially because your video slows down a bit, too. 2GB buffer is a lot, but no problem for your 8GB device. Try it!

    Ok I’ll try that just as you have written...


    <advancedsettings version="1.0">

    <cache>

    <memorysize>2000000000</memorysize> <!-- 2GB buffer size -->

    <buffermode>1</buffermode> <!-- buffer all filesystems -->

    <readfactor>8.0</readfactor> <!-- doubles the default readfactor -->

    </cache>

    </advancedsettings>


    Is buffer underrun related to what you referred to as the network buffer and the underrun in my log?

  • Is buffer underrun related to what you referred to as the network buffer and the underrun in my log?

    Yes, that's what I get from your log level 0 file. You can increase the log level, if you activate logging at GUI, and then use pastekodi.


    Anyway, tell me the results of your new settings first. This should do something. :)

    Flexin' vinyl, jammin' break beats. 8)

  • Yes, that's what I get from your log level 0 file. You can increase the log level, if you activate logging at GUI, and then use pastekodi.


    Anyway, tell me the results of your new settings first. This should do something. :)

    I activated the debug logging in the settings before. How does one use pastekodi?

  • Your config.txt is OK, changes will have effect after reboot. If you enable debugging at GUI, you should see clock speed (I guess).

    Update:


    Havent changed the advancedsettings.xml to your new recommendations yet. I wanted to see how it did with the force_turbo=1 change first. Watched an episode of Enterprise, no audio stutter. Started another episode and got 2 stutters within the first 5 minutes of the episode. Will make recommended changes and let you know.


    I activated the debug logging in the settings before. How does one use pastekodi?

  • Made the recommended changes. Does my changes to advancedsettings.xml look okay? Newbie question...I noticed on your XML recommendations that the lining up under the <cache> of the memorysize, buffermode, and readfactor lines are a little different from mine. Does that matter to the computer?


    Will test soon.


    Code
    <advancedsettings>
      <cache>
        <memorysize>2000000000</memorysize>
        <buffermode>1</buffermode>
        <readfactor>8.0</readfactor>
      </cache>
    </advancedsettings>
  • Update


    Tested with new settings on one episode. No audio drop outs/stutter. Will keep testing tomorrow. Will report back.


    I may or may not have noticed a slight video slow down. It is really hard to tell. It is so close I can’t really tell for sure.



    I did notice something I haven’t seen. When trying to play the John Adams HBO Mini Series MKV rips and even some of the Enterprise episodes I have tested with in the past it causes LibreElec to reboot and go back to the load screen. Never seen that before. Once it boots back up I click on them again and they play as normal. What could be causing this?

  • I did notice something I haven’t seen. When trying to play the John Adams HBO Mini Series MKV rips and even some of the Enterprise episodes I have tested with in the past it causes LibreElec to reboot and go back to the load screen. Never seen that before. Once it boots back up I click on them again and they play as normal. What could be causing this?

    If your current advancedsettings.xml solves the original issue, disable (comment out) force_turbo=1 at config.txt.

    If the reboot issue persists after this, open a new thread and provide a log file (pastekodi link) with debugging enabled on GUI.

    Flexin' vinyl, jammin' break beats. 8)

  • If your current advancedsettings.xml solves the original issue, disable (comment out) force_turbo=1 at config.txt.

    If the reboot issue persists after this, open a new thread and provide a log file (pastekodi link) with debugging enabled on GUI.

    Sadly, the issue has returned. Audio stutter returned several times with the recommended advancedsettings.xml and force turbo on while watching an episode of Enterprise today. I even let the mkv file buffer at the beginning before I continued playing it


    Any other recommendations? Below is the link to a new pastekodi log.


    Look at 2021-02-16 at times 16:43, 16:45:23, 16:46, 16:47:16, 16:48:40. I see a notice there with the underrun mentioned again.


    http://ix.io/2PFz



    Reminder: here are my current advanced settings. I am running the stable version on Sandisk Extreme Plus 64 GB MicroSD if that helps anything.


    Code
    <advancedsettings>
      <cache>
        <memorysize>2000000000</memorysize>
        <buffermode>1</buffermode>
        <readfactor>8.0</readfactor>
      </cache>
    </advancedsettings>
  • Thank you for this educational thread. I learned a lot.


    For what it's worth, I could never get my 4GB pi 4b to run without audio stuttering on most of my content. It wasn't a huge deal but annoying to have the audio drop out for a couple of seconds every few minutes.


    I switched to a nightly image some months ago and never looked back. It's been perfect.


    Index of /

  • Thank you for the info. I tried on a nightly image a few days ago and it did not work for me either. May I ask what your settings were on the nightly that resolved your stutter?