Posts by Matthewlawson3

    Sorry, I was irritated by your initial post, where you said, Samba is active.


    Can you replace your USB cable by a better one? If I remember right, that was the fix for some users.

    I tested the Patton film with my actual HTPC running an old version of KODI (Krypton) and the exact same cables (except for HDMI to HDMI instead of HDMI to Micro HDMI) and hard drive enclosure. Besides a .5 second glitch where the video went to black then quickly reappeared I did not experience any stutter or audio cut out at all. Video played fine. This was playing in standard DTS.


    On the PI last night, I switched audio tracks from DTS-HD Master to DTS standard and Dolby Digital and it continued to stutter regardless of the track. Sometimes a little, sometimes a lot.

    Sorry, I was irritated by your initial post, where you said, Samba is active.


    Can you replace your USB cable by a better one? If I remember right, that was the fix for some users.

    I can do that and sorry Samba is on, but I don't use it for media sharing. I am going to test my actual HTPC today and see if it stutters as well. That should tell me more.


    Just for clarification, do you think everything should have been resoloved once I switched the audio tracks to DTS standard and also Dolby Digital? Do I have to disable DTS HD MASTER in the passthrough settings as well?

    In case you are using large directories with Samba, add this to advancedsettings.xml (inside <advancedsettings> tag):

    Code
    <samba>
        <statfiles>false</statfiles>  <!-- speed up listings of large directories -->
    </samba>

    Thanks. This is all coming off my USB 3.0 Hard Drive enclosure. We tested a MKV on a USB jump drive and it stuttered as well, so I don't think this is a drive issue. I don't use network shares to watch media. Too slow for me.

    I wanted to give an update and pose a question. I have been using nightlies and on Star Trek: Enterprise MKVs barely experience any stuttering now running DTS HD.


    Here’s what is odd. I was watching the film Patton with the 02/25/2021 nightly with DTS HD Master from a MKV file on my hard drive enclosure and got several stutters and video slow down. I switched the audio track to regular DTS and Dobly Digital and still continued to get stuttering. I was under the impression that using those tracks would help and it hasn’t worked. Do I have to disable DTS HD MASTER in the passthrough settings as well to see an improvement?


    I did try to modify advanced settings and force turbo in the 02/21/21 nightly, as I did before with other builds, and it actually made it where KODI would only play one chosen video then all other videos chosen after that one would fail to play. You had to reboot to fix this. I changed everything back and that behavior stopped.

    I think your changes at config.txt and advancedsettings.xml don't solve the problem, so I suggest to remove both.


    You have two choices now:

    a) Update to the latest LE nightly as often as you can, and hope for HD audio improvements.

    b) Re-rip your videos to non-HD audio.

    Understood. Thank you.


    Can I just delete advancedsettings.xml with no problem?

    I had a look at your latest log. It says you are using dtsHD:

    Code
    2021-02-16 16:10:06.544 T:473310064    INFO: CAEStreamParser::SyncDTS - dtsHD (core) stream detected (6 channels, 48000Hz, 16bit BE, period: 512, syncword: 0x41a29547, target rate: 0x18, framesize 2080))

    Because HD audio isn't highly optimized on LE yet, I think you have to wait for an LE update with better HD audio implementation. Keep using the latest LE nightly, if you wish.


    If you re-rip to a non-HD audio format, it could solve it.

    I tried the nightly a few days ago with DTS-HD Master and still got the stutter. Should I try the latest nightly and implment forceturbo and the advancedsettigs.xml settings you recommended and see if that works?

    Thank you for the info. I tried on a nightly image a few days ago and it did not work for me either. May I ask what your settings were on the nightly that resolved your stutter?

    If your current advancedsettings.xml solves the original issue, disable (comment out) force_turbo=1 at config.txt.

    If the reboot issue persists after this, open a new thread and provide a log file (pastekodi link) with debugging enabled on GUI.

    Sadly, the issue has returned. Audio stutter returned several times with the recommended advancedsettings.xml and force turbo on while watching an episode of Enterprise today. I even let the mkv file buffer at the beginning before I continued playing it


    Any other recommendations? Below is the link to a new pastekodi log.


    Look at 2021-02-16 at times 16:43, 16:45:23, 16:46, 16:47:16, 16:48:40. I see a notice there with the underrun mentioned again.


    http://ix.io/2PFz



    Reminder: here are my current advanced settings. I am running the stable version on Sandisk Extreme Plus 64 GB MicroSD if that helps anything.


    Code
    <advancedsettings>
      <cache>
        <memorysize>2000000000</memorysize>
        <buffermode>1</buffermode>
        <readfactor>8.0</readfactor>
      </cache>
    </advancedsettings>

    Update


    Tested with new settings on one episode. No audio drop outs/stutter. Will keep testing tomorrow. Will report back.


    I may or may not have noticed a slight video slow down. It is really hard to tell. It is so close I can’t really tell for sure.



    I did notice something I haven’t seen. When trying to play the John Adams HBO Mini Series MKV rips and even some of the Enterprise episodes I have tested with in the past it causes LibreElec to reboot and go back to the load screen. Never seen that before. Once it boots back up I click on them again and they play as normal. What could be causing this?

    Made the recommended changes. Does my changes to advancedsettings.xml look okay? Newbie question...I noticed on your XML recommendations that the lining up under the <cache> of the memorysize, buffermode, and readfactor lines are a little different from mine. Does that matter to the computer?


    Will test soon.


    Code
    <advancedsettings>
      <cache>
        <memorysize>2000000000</memorysize>
        <buffermode>1</buffermode>
        <readfactor>8.0</readfactor>
      </cache>
    </advancedsettings>

    Your config.txt is OK, changes will have effect after reboot. If you enable debugging at GUI, you should see clock speed (I guess).

    Update:


    Havent changed the advancedsettings.xml to your new recommendations yet. I wanted to see how it did with the force_turbo=1 change first. Watched an episode of Enterprise, no audio stutter. Started another episode and got 2 stutters within the first 5 minutes of the episode. Will make recommended changes and let you know.


    I activated the debug logging in the settings before. How does one use pastekodi?

    Yes, that's what I get from your log level 0 file. You can increase the log level, if you activate logging at GUI, and then use pastekodi.


    Anyway, tell me the results of your new settings first. This should do something. :)

    I activated the debug logging in the settings before. How does one use pastekodi?

    Sorry, for playing local files you need this (buffer mode 1):

    Code
    <advancedsettings version="1.0">
        <cache>
            <memorysize>2000000000</memorysize> <!-- 2GB buffer size -->
            <buffermode>1</buffermode> <!-- buffer all filesystems -->
            <readfactor>8.0</readfactor> <!-- doubles the default readfactor -->
        </cache>
    </advancedsettings>

    I think audio stutter can indicate a buffer underrun, especially because your video slows down a bit, too. 2GB buffer is a lot, but no problem for your 8GB device. Try it!

    Ok I’ll try that just as you have written...


    <advancedsettings version="1.0">

    <cache>

    <memorysize>2000000000</memorysize> <!-- 2GB buffer size -->

    <buffermode>1</buffermode> <!-- buffer all filesystems -->

    <readfactor>8.0</readfactor> <!-- doubles the default readfactor -->

    </cache>

    </advancedsettings>


    Is buffer underrun related to what you referred to as the network buffer and the underrun in my log?

    Thank you. Two questions...


    1. Does the advanced settings at the link above change based on the fact I am running a 8GB RPI 4B? If so, what would be the settings you would recommend? If not, I'll put them in verbatim as they are at the link.


    2. Does the network buffer still matter even though I am playing local MKV files through USB 3.0?


    Just to be clear I never see a buffer ring. The audio just drops out for a second and sometimes the video will slow very sightly at that point for a second and recover.

    Your config.txt is OK, changes will have effect after reboot. If you enable debugging at GUI, you should see clock speed (I guess).

    Thank you.


    Hopefully, my log file will put some light on what is going on. Can someone take a look and see if they see anything out of place? I'd appreciate it as I am new to LibreElec.