Beelink Mini MXIII WIFI and BT

  • Hi


    It might just be me, but I can't get WIFI and bluetooth to work in LibreELEC. I got a Beelink Mini MXIII.


    I have tried both LE 7.0 and 7.9 and all possible dtb's.


    Can someone point me in the right direction?


    /Thomas

  • flash build 008 with gxbb_p200_2G_1Gbit_RealtekWiFi.dtb, you will need to flash twice on the MXIII.


    If WiFi does not connect try again or reboot, it should auto connect upon startup.


  • flash build 008 with gxbb_p200_2G_1Gbit_RealtekWiFi.dtb, you will need to flash twice on the MXIII.


    If WiFi does not connect try again or reboot, it should auto connect upon startup.



    Thankyou for your answer, I forgot to say that I have installed it on a SD card.


    I have tried multiple times with 008 and of course alsom rebooted a lot of times. But no WIFI or BT.


    Another question that I can't find a clear answer to is: will I be able to revert back to android if I flash LibreELEC to the NAND?


    /Thomas

    Edited once, last by thl78 ().

  • Are you sure you have the s905 MXIII and not the s905X MXIII II? It sounds like you have the s905X MXIII II which does not have working BT/WiFi on libreelec.


    Yes you can flash stock if you have the correct firmware using the usb_buring_tool, however you need a usb A to usb A cable.

  • Interesting. I hope it works. I'm still waiting for my box.

    MXQ M10 S805 - LibreELEC 8.1.9
    NEXBOX A5 S905X - LibreELEC 8.1.9
    BEELINK MXIII II S905X - LibreELEC 8.1.10

  • Hi


    JonSnow, you are right. It is in fact a 905X device I got.


    I upgraded to 009, but the WLAN driver does not load, i get this messag when insmodding:


    insmod: ERROR: could not insert module /lib/modules/qca9377-aml/wlan.ko: No such device


    I get the same message if I manually run autostart.sh after boot. However, for some reason it sometimes load the driver successfully when I run it manually, I have seen that two now. I have no idea why it sometimes works, I can't see a pattern. I'm trying to figure it out.


    Maybe you can see somthing from my dmesg, I can pastebin it if you want to see.


    /Thomas
    [hr]
    This is my dmesg just after the system has booted. And there is no WIFI


    [ [email protected]] Initializing cgroup subsys cpu [ [email protected]] Linux version - Pastebin.com
    [hr]
    And this is what happens when I rerun autostart.sh manually and it loads the driver:


    [ [email protected]] aml_wifi wifi.32: [extern_wifi_set_enable] WIFI Disable! 240 - Pastebin.com

    Edited once, last by thl78 ().

  • I flashed back to stock android without this (very) special cable. i have 2 SD cards, one to boot into recovery,then i changed the SD card with the Original FW and choosed update from sd card.
    Maybe easier if you have some old sd cards, than to find this cable.

    Edited once, last by Slaytanic ().


  • @thl87 Doed WiFi work when the modules load properly?


    Yes, when the driver load it works.


    I have not tested performance, I have just play video a couple of minutes. But I have not experienced problem of any kind.


    /Thomas


  • I don't know. [emoji56]


    @thl87 Can you tell if Bluetooth works as well?


    No, bluetooth doen not work.


    I enable bluetooth under Services and it says "No bluetooth adapter found" under "Bluetooth"


    By the way, I need to disable and enable Wireless Network before it scans for SSID's


    /Thomas

  • @thl87 Can you try the following in your autostart.sh (I know, it's an ugly hack...):

    Code
    1. insmod /lib/modules/qca9377-aml/compat.ko
    2. mount -o bind /lib/modules/qca9377-aml/cfg80211.ko /lib/modules/3.14.29/kernel/net/wireless/cfg80211.ko
    3. mount -o bind /lib/modules/qca9377-aml/wlan.ko /lib/modules/3.14.29/kernel/drivers/amlogic/wifi/bcmdhd/dhd.ko

  • @thl87 Can you try the following in your autostart.sh (I know, it's an ugly hack...):

    Code
    1. insmod /lib/modules/qca9377-aml/compat.ko
    2. mount -o bind /lib/modules/qca9377-aml/cfg80211.ko /lib/modules/3.14.29/kernel/net/wireless/cfg80211.ko
    3. mount -o bind /lib/modules/qca9377-aml/wlan.ko /lib/modules/3.14.29/kernel/drivers/amlogic/wifi/bcmdhd/dhd.ko


    Hmm i get this



  • @thl87 Can you try the following in your autostart.sh (I know, it's an ugly hack...):

    Code
    1. insmod /lib/modules/qca9377-aml/compat.ko
    2. mount -o bind /lib/modules/qca9377-aml/cfg80211.ko /lib/modules/3.14.29/kernel/net/wireless/cfg80211.ko
    3. mount -o bind /lib/modules/qca9377-aml/wlan.ko /lib/modules/3.14.29/kernel/drivers/amlogic/wifi/bcmdhd/dhd.ko


    Wifi works for me with your hack. I have rebooted 5 times and the driver loads every time. (five times in a row is the same as every time :-)


    The only issue with WIFI now is that I need to deactivate and activate wifi in the LibreELEC addon before it connects to a SSID.


    /Thomas

  • I'd like to contribute a solution from s905's build thread, for those who can't get the above hack to work, even if they did everything right:


    LibreELEC post #161

    Edited once, last by mytbyte ().


  • I'd like to contribute a solution from s905's build thread, for those who can't get the above hack to work, even if they did everything right:


    LibreELEC post #161



    Please could You post the autostart.sh file? I'm sure I have everything right but still can't get wifi after I execute the script.

    MXQ M10 S805 - LibreELEC 8.1.9
    NEXBOX A5 S905X - LibreELEC 8.1.9
    BEELINK MXIII II S905X - LibreELEC 8.1.10