HDMI sound NOK + Raspberry 4

  • Hello


    I have a raspberry 4 4M and Libreelec "LibreELEC-RPi4.arm-9.2.6.img.gz"


    I cannot use with sound.

    I tried with

    • config.txt + hdmi_drive = 2> nok
    • config.txt + audio_pwm_mode = 1> nok
    • disable "Allow passthrough"> nok
    • enable "Allow passthrough"> nok
    • 2.0> nok
    • 5.1> nok c
    • hange GUI probe> nok
    • PI: HDMI> nok PI: HDMI and Analogue> nok put the sound through my headphones



    I tried with Retropi the sound goes well (my HDMI cable is good) I think I go with Kodi the sound cannot be


    Who has another idea :?:


    Thank you so much <3

  • What's your HDMI setup? (which TV / monitor / AVR model, HDMI cabling RPi -> TV or RPi -> AVR -> TV)


    If you can't get analogue audio, chances are your volume is set to zero (check the bottom of guisettings.xml for volume size).

    Flexin' vinyl, jammin' break beats. 8)

  • Cable connected to the wrong port? .. must use the port nearest the power connector.

  • Hello

    What's your HDMI setup? (which TV / monitor / AVR model, HDMI cabling RPi -> TV or RPi -> AVR -> TV)

    HDMI cabling RPi -> TV Sony


    If you can't get analogue audio, chances are your volume is set to zero (check the bottom of guisettings.xml for volume size).

    I think this is good but NOK

    Code
    <volumeamplification>0.000000</volumeamplification>
    
    <audio>
    <mute>false</mute>
    <fvolumelevel>1.000000</fvolumelevel>
    </audio>


    Cable connected to the wrong port? .. must use the port nearest the power connector.

    with retropi the sound is good but on retropi + kodi NOK


    I am connected with a 5V 3A 15W power supply


    thank you so much

  • The volume settings are OK. Maybe you have to enable on-board audio at config.txt:

    Code
    dtparam=audio=on

    Flexin' vinyl, jammin' break beats. 8)

  • Did you try both HDMI ports on the raspberry pi 4 ?

    one screen does not work the other !! ??



    The volume settings are OK. Maybe you have to enable on-board audio at config.txt:

    Code
    dtparam=audio=on
    Code
    dtparam=audio=on 

    NOK

    Code
    dtparam=audio=on 
    hdmi_drive=2

    NOK


    thank you so much

  • Usually people have at least analogue audio. Can you make a microSD with Raspbian and update the RPi firmware from there?


    PS: Background: Maybe another RPi OS updated the firmware (you use multiple cards), and with that firmware LE can't provide audio.

    Flexin' vinyl, jammin' break beats. 8)

  • I had a problem with no sound on my RPi4, turned out the kids had turned the volume right down on the TV.

  • I had a problem with no sound on my RPi4, turned out the kids had turned the volume right down on the TV.

    volume right up on the TV NOK

    Usually people have at least analogue audio. Can you make a microSD with Raspbian and update the RPi firmware from there?


    PS: Background: Maybe another RPi OS updated the firmware (you use multiple cards), and with that firmware LE can't provide audio.

    I think this is good >> next NOK


    try again with an SD card with a USB flash drive beast USB drive SSD drive USB drive NOK


    but first of all what parameters to put in the oven with a new Raspberry Pi 4 config.txt, guisettings.xml, ....



    thank you so much

  • Stroke_Papy Can you write some more details, please? Does LE audio work with a different firmware? I don't understand what you wrote.


    The RPi firmware is written to the chip, so it stays active when you switch to another OS / microSD. config.txt / guisettings.xml are not relevant for this part.


    If the firmware is the issue, you have to find a version that works with all your OS'es. Maybe switch from Retropi to Lakka, if Retropi needs incompatible firmware.

    Flexin' vinyl, jammin' break beats. 8)