0bda:b812 rtl88x2bu kernel module

  • After having WIFI performance issues at the back end of my house with Kodi on my Google TV and my RaspberryPi 4 I decided to bust out my Rpi2 with this adapter. This solved all of the performance issues that I was having.

    I can't say for sure what brought on the performance issues. Either my router degraded in some fashion or there is too much radio interference near my house now.

    The Techkey-6B06 is a beast. Get one if you find it on sale like I did.

    I'll try to roll a RPi4 image with the driver and see how that performs too.

  • I've been using this adapter with my Pi4 for almost a week and it performs very well. Hopefully we can get a driver for this chipset rolled into the default kernel.

  • thanks

  • I tried following these steps and am having a bit of trouble.

    Unfortunately, I don't have enough free space on my local drive to do this. So I am trying off an external drive, but it fails with an error.

    To start with, when I follow these instructions to the letter, the build works, but fails when it fills the available space. I stayed with it for some 10 minutes, then left it to run overnight and when I came back, the error message was pretty explicit with "drive full", well into the build.

    Now, I am trying off an external HDD connected to USB and it fails after about 1 minute with this:

    stdout and stderr don't show any additional info:


    # cat build.LibreELEC-RPi2.arm-9.2-devel/.threads/logs/3/stdout
    config/functions: line 1257: /home/louisnichols/LibreELEC.tv/build.LibreELEC-RPi2.arm-9.2-devel/.threads/locks/ccache:host.build: Invalid argument
    FAILURE: scripts/build ccache:host has failed!


    # cat build.LibreELEC-RPi2.arm-9.2-devel/.threads/logs/3/stderr 
    [001/251] [FAIL] build   ccache:host
    The following logs for this failure are available:
      stdout: /home/louisnichols/LibreELEC.tv/build.LibreELEC-RPi2.arm-9.2-devel/.threads/logs/3/stdout
      stderr: /home/louisnichols/LibreELEC.tv/build.LibreELEC-RPi2.arm-9.2-devel/.threads/logs/3/stderr

    I tried to trick it by using ln -s from the external drive to ~/LibreELEC.tv/, but the result is the same.

    In fact, these outputs are from such an attempt with ln -s. But, without it, the result was exactly the same.

    After having these failures twice, I checked again that the build works out of a native folder and it does. So it really is something about using the external drive.

    Any suggestions?

  • Nevermind. It occurred to me that it was all very silly and the only difference between "local" folders and the external drive was they way they were mounted. The external drive was mounted through gnome vfs. So I remounted the external drive the old school way with sudo mount and now the build is churning.

    Thank you for these instructions! :)

    Later edit: some 7 or 8 hours later, the build was succesful. It did have a couple of hiccups and I had to restart the build 3 times. The first time I deleted .ccccache, but for the next ones I didn't bother. And it got to the end. It was all quite exciting. And then I realized I compiled for the wrong platform. :))) OK, well, one more try...

    In a ny case, this is probably the most complex build I've made since Compiz first came out. :D

  • Has anyone been able to compile the driver into LibreELEC 10? I'm running into errors on the same development machine that I used for rolling the driver into LibreELEC 9. I'm using Ubuntu 20.04.

  • Never mind guys. I was able to roll the driver into LibreELEC 10.0.2 and compile it for the Raspberry Pi 4 just fine. I'm not sure what went wrong when I tried to compile it a couple months ago. Maybe there was a bug in LibreELEC, the driver, or an Ubuntu 20.04 package on my build machine. I'll see if it works for the RPi 2 when I get a chance.

  • Hi,

    I am trying to use tp-link AC1300 with module 88x2bu. It works with RPi4.

    trying to use your advice with creating LibreELEC 10.0.2, I get:

    PROJECT=RPi ARCH=arm DEVICE=RPi2 make image

    ./scripts/image mkimage

    Traceback (most recent call last):

    File "scripts/genbuildplan.py", line 369, in <module>

    REQUIRED_PKGS = processPackages(args, ALL_PACKAGES)

    File "scripts/genbuildplan.py", line 298, in processPackages

    raise Exception(msg)

    Exception: Invalid package reference: dependency RTL88x2BU in package linux-drivers::PKG_DEPENDS_TARGET is not valid

    Any Idea ?

  • Quote

    Exception: Invalid package reference: dependency RTL88x2BU in package linux-drivers::PKG_DEPENDS_TARGET is not valid

    So the PKG_DEPENDS_TARGET variable in the package.mk that you added is incorrect in some way.

  • package.mk:





    # https://github.com/cilynx/rtl8…s/

    PKG_DEPENDS_TARGET="toolchain linux"


    PKG_LONGDESC="Realtek RTL88x2BU Linux driver"


    pre_make_target() {

    unset LDFLAGS


    make_target() {

    make V=1 \


    KSRC=$(kernel_path) \




  • Thanks, but it did not work. I changed to Raspian with kodi and that worked after compling 88x2BU.