Update URL/channel for nightly builds

  • Let's say I am on le 10 stable (10.0.2 as of today). If I switch that installation to le 10 nightly, will I be able one day to stop being on nightly and switch back to stable once 10.0.3 is released?

  • jim_p - yes. If you check the commit log for libreelec-10.0 versus 10.0.2 you will see it is very minimal changes. This is our stable release. The add ons are updated (to both the stable and nightly channels.) you will see the few kernel updates and some other minors. Basically you will be 10.0.2 (with an updated kernel and some fixes). When 10.0.3 comes out which will have the update Kodi patch release - it will be a matter of updating to that. The ability to update back an forward within 10.0.x works fine.


    LE11 nightlies are different. There have been some big changes that are harder (more complicated) to go back and forward. But are doable.

  • Thank you. Those "minimal changes" that you mention give me very little hope to see my issue fixed.

    If e.g. the kernel is the same, mesa is the same, xorg is the same, drivers are the same, then it probably won't make any difference.

  • what's so bad running nightly LE11 ?


    doing so since month without any complains.

    kudos ${developers} :)

    DigiBit R1, NUC8i3BEH

  • what's so bad running nightly LE11 ?


    doing so since month without any complains.

    kudos ${developers} :)


    I tried LE11 a couple of months back and it runs fine if you are just running vanilla Kodi. The problems occur for those users who are heavily dependent on Addons like I am (for eg YT, Trakt, Spotify, TED etc), and hence need to stay on Kodi 19.4.


    But who knows, I might give the 11 branch another go soon...


    I'm glad there's a 10.0.x nightly branch as I want to stick to Kodi 19.4 due to said addons.


    My setup is perfect but I'm still hoping the PVR seek issue when deinterlacing is enabled can be fixed for 10.0.2.


    It appears I will need to wait until 11.0 is officially released for this to be resolved (I think)

  • I had a similar problem running addon "Kodi-Addon-ARDundZDF" what initial isn't ready for LE11


    editing the addon.xml from it and changed the number to

    <import addon="xbmc.python" version="3.0.0"/>


    reboot and I was done.


    don't know if this trick works out everywhere ...

    DigiBit R1, NUC8i3BEH