Upgrading from Pi2 to Pi4 - No sound and CEC takes a few minutes to work if at all

  • Hello All,


    I'm a long time Pi user and have never had any issues relating to sound or the CEC. Short version: recently purchased a new Pi4, installed the latest image for Pi4 - LibreELEC-RPi4.arm-9.2.5.img, booted it up but now have no sound and the CEC takes about 5 minutes to work. I do have a keyboard/mouse attached - both work fine so at least I can move around within the app. In addition when I reconnect my Pi2 using LibreELEC-RPi2.arm-9.2.4.img,everything works as it should - instant sound and CEC response.


    Any help resolving the sound/CEC issue on the Pi4 would be welcome. If more detail is required (logs for example) pls let me know.


    Thanks in advance!

  • Thanks for replying, much appreciated!


    I've tried both ports, doesn't matter. I've now moved the hdmi cable from hdmi 2 to hdmi 1 on my samsung smart tv, seems to be working now! The old PI worked on any hdmi port on the tv.


    Perhaps I can close this thread.

  • I'm having a smiliar problem. I've had 2 Pi4 boxes for a while now, then suddenly on the same day they both stopped outputting sound.


    I checked everything, then eventually did a clean install of 9.2.5 and upgraded to Leia 18.8. Still no sound.


    Interestingly, a clean install of Xbian works just fine. :/


    However, I don't know if this is expected behavior or not, but I can only connect to the left side micro HDMI. The right side (closest to the power plug input) has never given me a signal. This has always been the case on both boxes, even when the sound was working.


    I've posted a log, hope I did it right. Any suggestions would be appreciated.