Official LE11 Test Images for Amlogic (Kodi-20)

  • I'm user of ODROID C2 - but it don't start my USBs Disk . The ports are quite 'dead' . The hdds dont event power ON.

    It's a long-time known issue with the upstream kernel, see this thread: - there is more follow-up since, but I can't seem to find the latest/follow-on thread at the moment.

    EDIT: here it is:…ber/011098.html

  • Thanks for info. Is it chance that the Patch will be implementet (somehow) in Libreelec (Your) Distribution ?

    If/when there is a patch, I will test it in my branch and then push it to LE. This has been ongoing for several years though so I wouldn't hold breath for a speedy resolution - although more progress/understanding on it has been reached in the last year than the previous 3-4.

  • I'm told device wake over CEC would need some changes in the driver. I'll add it to the long list of undone things, but It's not something I can do myself - to set expectations.

  • chewitt, I am trying to get wifi to work on this edal box with s905x, 1gb ram, 2.4GHz only and 100 LAN. I tried all the GXL s905x dtb files, all but the hwacom would boot and I can use the 100 LAN.

    It is not a big deal but would be good to get the correct dtb file for wifi to work too.

    It has been a long time since I used LE when I switched over to CE. I been using this CE gxl_p212_1g.dtb with success.

    Is the wifi issue due to the dtb or is the box firmware has disabled it?


  • hieppo It's the dtb. I can see there is no Broadcom WiFi device in the dtsi under the &sd_emmc_a; node:

    linux/meson-gxl-s905x-p212.dts at master · torvalds/linux
    Linux kernel source tree. Contribute to torvalds/linux development by creating an account on GitHub.
    linux/meson-gxl-s905x-p212.dtsi at master · torvalds/linux
    Linux kernel source tree. Contribute to torvalds/linux development by creating an account on GitHub.

    So assuming the box has a Broadcom WiFi chip? it should be trivial to add. If you use the p212 dtb it should have working BT? - share the URL generated by "dmesg | paste" when using the p212 dtb and I can see.

  • Odd, it probes the BT modeul but doesn't load. I'll have a poke around in the dts bits. I suspect the GXL box devices in the upstream kernel are a little unloved as the focus has mostly been on SBC board devices.

  • I found the stray patch cum bad commit that broke hardware decode .. so the next nightly that's build (scheduled for 5th Jan AM GMT) will have working hardware decode again. Impatient users can grab something from .. there are no functional improvements so GXBB/GXL/GXM are working nicely and newer devices still have some issues, but that's an improvement on black screens and no video everywhere.

    NB: I have added a possible workaround (not fix, workaround) for borked USB ports on Odroid C2 and the meson-gxl-s905x-p212 device-tree may now have working BT/WiFi .. I'm still not near my usual test devices so you'll have to test for me.

    Happy New Year!

  • chewitt

    Just tested 10.85 from you testing repo. Hardware decoding is working like back at 10.0.1. I think the dtb may be better now than before. The HDMI actually works cleanly on my Acer monitor, previous version would have artifacts on the screen. But unfortunately, it still does not detect the built in wifi. BTW, this box does not have BT. I did not notice some issue starting to play some file but after several attempts to start playing it did finally played it. It is kind of odd that it will not start right away. This is preliminary finding, I will report later if I see more as I use it more regularly.

    p212 s905x dmesg

    I will flash it to my S912 box and see if there are any initial issue.

    BTW, was it intentional for the boot logo to be already on Kodi Nexus? I am assuming the Kodi is Matrix version?

  • BTW, was it intentional for the boot logo to be already on Kodi Nexus? I am assuming the Kodi is Matrix version?

    Intentional, as I don't see much point in tracking Matrix since it's not the codebase I'm looking to use in the next release.

    You will probably have some issues with video decode still. We attempt to reserve 896MB CMA which is needed to handle 4K on boxes with 2GB or more RAM. However this allocation fails on 1GB devices so the kernel falls back to 256MB which is probably too little. The vdec driver needs a major rewrite/refactoring (splitting into two drivers) to fix that - known but unlikely to happen anytime soon.

    I still don't see any attempt to probe WiFi though (at least BT failing is explained by it not being present) so I have to assume the box does not have a Broadcom module. Realtek is most likely but I'll have to have a think about how to handle that.

  • chewitt

    Oops, I forgot to mention, this box does have a realtek. There is no rush for wifi since it is 2.4GHz only and not the quickest. I use the LAN mainly.

    Also, there is a thin purplish line at the bottom of the player using the s912. This occurs only when playback and not seen in the UI or when the player is paused and on the menu.

    Edited 2 times, last by hieppo: Does hevc seek work? (January 4, 2022 at 11:43 PM).

  • chewitt,

    The purple line comes up all resolutions and not just SD content. The Realtek is a RTL8189ETV.

    HEVC seek does not work properly on all files. Could be bad encoder but those same files seek correctly using Linux mpv and other players, so I am not sure if it is the files.

  • Quote



    bootargs=boot=UUID=0501-1634 disk=UUID=c94acf29-6106-4451-b782-057e2248491d quiet systemd.debug_shell=ttyAML0 console=ttyAML0,115200n8 console=tty0

    hieppo Please make a new SD card from…85.0-box.img.gz and then edit uEnv.ini to include an "overlays" line as above. It's not clear to me whether vendor u-boot supports overlays, or if the path to the overlays is correct, so if nothing magically works edit to drop the "dtb/" prefix and move the "wifi-rtl8189etv.dtbo" file to the root folder of the SD card. As usual, share a "dmesg | paste" URL so we can see if anything happened or not?