Official LE Test Images for Amlogic (Kodi-20)

  • chewitt


    First, thank you for your contribution to the development of LibreELEC on Amlogic.


    And I have a request if you could help me to run audio on the Audio/Video (jack) output?


    I am testing your image and everything works for me except that. The audio over HDMI works, however I depend on the jack output.


    I have a TV BOX device: U2C Z SUPER, S912, 3GB RAM, LAN 1Gbps


    Currently I'm running CoreELEC version 9.2.8 (Kodi 18) with gxm_q201_3g_1gbit.dtb tree - on it the audio on A/V output works for me.


    In LibreELEC I'm using meson-gxm-vega-s96.dtb tree because that's where most things work, I also tried meson-gxm-q201.dtb but it also doesn't work LAN (and sound on A/V)


    I attach dmesg from LibreELEC on meson-gxm-vega-s96.dtb: hastebin


    [edit]

    I have now tried the meson-gxm-q200.dtb tree and everything seems to work on it too except the audio on the A/V output.

    dmesg: hastebin



    I would be grateful for an answer.

    Edited once, last by tomaszc ().

    • Official Post

    tomaszc Most GXM devices have the headphone outputs wired up in device-tree, but I'm pretty clueless about alsa so the images are prob. using an incorrect alsa conf that prevents its use. Or you might need to install alsamixer to unmute things and switch the outputs around. I'm not really sure how all the plumbing fits together so I'm not sure what to advise, sorry.

  • chewitt


    I tried unmuting all channels in alsamixer, but it didn't help.

    Maybe the problem is that on LibreELEC this card is visible as P230-Q200 (under different trees), and on CoreELEC (where analog audio output works) it is visible as: AML-M8AUDIO

    Unfortunately I don't know how to change this, you would probably have to edit the tree file somehow.

  • Hello,


    many thanks for porting LibreElec on Amlogic devices. I have an old s905x 1G/8G Android box (Sammix r95) that worked really well on Libreelec 8. I tried this image:


    LibreELEC-AMLGX.arm-10.0.0-box.img.gz


    with this DTB: meson-gxl-s905x-p212.dtb


    The system boot fine but it can't detect the wifi chip inside the box. This chip was properly detected with Libreelec 8.

    Can you tell me if i should change dtb or if you need some kind of logs to understand better the error?


    Thanks again for this amazing work and for your support!!!

    • Official Post

    The system boot fine but it can't detect the wifi chip inside the box.

    The p212 dtb is expecting a Broadcom SDIO module and the one pic I can see of the board shows one (see below). So what wireless chip is in the box? - share logs from LE10 and the older LE8.x image.


    71uXUTybaVL._AC_SL1500_.jpg

  • Hello

    My tv box using meson-gxbb-p201.dtb in LE10 wifi not work,LAN is woking.it has loaded mt7601 modules ,but scan wifi no sign

  • Please help me, how and what kind of firmware can be installed on the device aun akey1, soc s905x,1gb ram, I prepared a flash card via libre usb-sd creater, but I could not install multi boot, all attempts to flash any zip through the update&backup utility ended with an error.

  • Minor progress on a couple of things: One of the issues with the audio driver used with GXBB (S905) boards was figured out so there is no longer any need to force output rates to 41KHz to output 48KHz media. See: https://patchwork.kernel.org/p…[email protected]/. This also leads to a major simplification for alsa configuration which we will send upstream. Sadly we still didn't figure out *that* static noise problem for GXBB/GXL/GXM devices yet, and this is what I regard as the minimum fix before some nightly images can resume. In the background I also have the full vendor sources and schematics for Minix Neo U1 (S905) and U9-H (S912) devices. I plan to extract and post the boot fips so that mainline u-boot support is possible. I can also validate the device-trees which have previously been created with user support (U9-H is upstream, U1 still wip).

  • Minor progress on a couple of things: One of the issues with the audio driver used with GXBB (S905) boards was figured out so there is no longer any need to force output rates to 41KHz to output 48KHz media. See: https://patchwork.kernel.org/p…[email protected]/. This also leads to a major simplification for alsa configuration which we will send upstream. Sadly we still didn't figure out *that* static noise problem for GXBB/GXL/GXM devices yet, and this is what I regard as the minimum fix before some nightly images can resume. In the background I also have the full vendor sources and schematics for Minix Neo U1 (S905) and U9-H (S912) devices. I plan to extract and post the boot fips so that mainline u-boot support is possible. I can also validate the device-trees which have previously been created with user support (U9-H is upstream, U1 still wip).

    Hi, chewitt.


    Can we hope to improve the LE 10 for the odroid C2?

    Odroid C2 2GB/Odroid N2 4GB/Rockpro64 4GB/Clone MXIII Plus 8-1.5GB

  • Can some one guide me to detailed install instructions on how to get this to boot on my Minix U1. Ive tried Belana Etcher, Rufus placing the correct dtb image on card. Toothpick method and nothing. Can someone guide me to a solution. Thanks

  • Can some one guide me to detailed install instructions on how to get this to boot on my Minix U1. Ive tried Belana Etcher, Rufus placing the correct dtb image on card. Toothpick method and nothing. Can someone guide me to a solution. Thanks

    Create an SD card from https://chewitt.libreelec.tv/t…LGX.arm-10.0.1-box.img.gz then set the minix u1 dtb name to use in uEnv.ini (the filename is in the dtb folder). NB: You do not rename anything to dtb.img or move files to the root folder (unless you want to break boot). I'm not sure what state the U1 dtb is in right now - I did work before but it wasn't widely tested. Also note there are a few audio glitches to resolve still (in addition to all the video things).

  • Can we hope to improve the LE 10 for the odroid C2?

    It should be quite usable for H264 things now (1080p, not 4K) and with the 41KHz/48KHz issue resolved I've re-enabled HDMI in the alsa-conf and passthrough works fine. I'm still trying to figure out why audio channels are mixed up with non-passthrough media, and the static noise bug is there as a nasty suprise when it happens. There's been some discussion on the linux-amlogic mailing list to "ask the audience" on that problem, but so far no eureka moment. No change to video - still neglected :)

  • Can we use installtointernal or only run off SD card

    There are too many issues that arise from install2internal scripts so I have no plans to support it. That said:


    Once I extract the FIP sources for Minix U1 and port the board to mainline u-boot it will be possible to boot modern u-boot from SD card and run the OS completely from eMMC. It is not possible to install modern u-boot and the OS to eMMC at the same time (as with vendor u-boot) as U1 is a GXBB device and GXBB needs to boot from the first sector of eMMC (so installing u-boot breaks partitioning .. and creating partitions breaks u-boot). The first stage boot from SD is a workaround, but it works and is much cleaner than the custom partition scheme that vendor u-boot implements. Minix U9-H boxes will be able to run fully from eMMC as GXL/GXM support an alternative offset for the magic boot header which allows partitioning to reside in first sector as normal. Until I get around to extracting the FIPs and doing u-boot work, the box must boot from an SD card. The performance difference is not so much.