Corded keyboard not working properly in Libreelec

  • I ran into a problem with Libreelec on a Raspberry Pi 4. I bought a Leopold FC660M corded keyboard to work with it but it appears that Libreelec doesn't recognize it properly. The arrow keys and enter work as expected as does backspace but other than that none of the keys seem to work. This means that manually typing out media titles for my library is impossible. The USB ports on the Pi are in working order as the device has no trouble with my mouse or even an older Microsoft keyboard I had lying around. The Leopold keyboard is in perfect working order as well as that is what I am using to type this message. I am not a particularly experienced Libreelec user so perhaps I'm simply missing something completely obvious here. If anyone can point me in the right direction that would be greatly appreciated.

  • Thanks for the link, my particular keyboard isn't listed on it although I'm inclined to belief that's simply owing to the fact that no one's ever bothered trying it. I've connected the keyboard to RPi and booted in Raspbian where it worked just fine, so I doubt RPi compatibility is the issue here.

    Still, thank you again for the reply. I've added the link to my bookmarks, always useful to have.

  • I see, the site that i posted shows all the official supoorted keyboard that work 100% with all projects so the keyboard that you have may work with some projects like raspbian, but in that case you can also try to map the buttons of the keyboatd using kodi . Useful links with the ways that you can map the buttons can be found here: Key map 1 keymap 2 but as i told you since the keyboard isn't officially supported you may face some further issues