What's the latest version for Wetek Hub?

  • Hi! I 'm currently running v9.0 with some problems in recognizing the bluetooth adapter. So I would like to know if there's a more recent version stable or beta and how could I download it.

    Moreover, if anyone with a wetek hub could tell me please what's the total memory that shows kodi in the settings/information section using libreelec. Mine shows 775mb( far from 1gb)...

    Many thanks!!

    • Official Post

    LE 9.0.2 is the latest official release. After this point we have abandoned all work on the legacy Amlogic 3.14 kernel and refocussed on mainline Linux support for LE10 (based on Kodi v19 which is still in a pre-Alpha state). This has some rough edges on playback but it otherwise in fairly good shape on Linux 5.6 .. I'm overdue to push a bump to Linux 5.7rcX to the master branch.

    Current test images are in Index of / .. use the AMLGX 'box' image from an SD card.

    NB: Kodi will always show under 1GB free because some RAM is reserved for system use (drivers and such) .. 775MB sounds about right/normal.

  • Thanks a lot for your help. I've installed the sd creator tool and it let me download the 9.0.2 version. Althought on the downloads wetek hub section on the web only appears v9.0. If I still have bluetooth problems, I will have to try that test images. Regards!

  • Sorry for bringing up this old thread, but didn't find any more recent statements regarding LE10 (?) (Alpha) (Beta) development for Wetek Hub and/or (as in my case) "Wetek Play 2" (I understand they are more or less the same when it comes to LE/Kodi).

    The Folder linked above by chewitt as of today don't contain any amlgx "box" images (or I am blind 8-) )

    So, is there any beta versions to try on my WP2? Is it in a state that would make sense for testing?

    Edit: Also found this

    LibreELEC (Leia) 9.2.0

    dating from April 2020.

    Question remains, any news for WP2?

    Edited once, last by wp2man (December 29, 2020 at 10:04 AM).

  • Thanks! Will have a go at it asap. If I got you right:

    1) the AMLGX-box-img you linked to *may* work from SD (just as the current LE9.0.2 does)

    2) the "dedicated WP2" image you mention needs the u-boot tweaking for sure

    Not sure if I want to touch factory u-boot (will have to look into how to do that); would that break booting the WP2 original firmware and/or the curren 9.0.2 booting fine from SD?

    This WP2 is our "daily driver" for TV... if I break it, WAF down to "minus infinity .... until infinity (and beyond!)")

  • The -wetek-play2 image will not boot from SD card unless you zero the emmc first (else the box always boots factory u-boot which doesn't understand the boot files) and I wouldn't do that if the box is a daily driver. The mainline kernel OS is great but still has a few glitches and missing things. There is also no DVB support as a demux driver needs to be written from scratch and there's not many volunteers.

    The -box image should boot though, and that's harmless enough to experiment witth.

  • chewitt, thanks again for responding.

    "no DVB support" means neither of the images will support DVB-T2 on WP2 image? Or also not with the "-box" image? I guess neither, since if there was DVB support in the -box image, it could be used for the -wp2 image, too, right?

    No DVB, no TV... no use ? Or am I missing something!?

  • Mh, are you saying that LE10 will lack support for any DVB, for any chipset, be it internal or external / USB-Sticks?

    A quick search gave me this

    DVB-C Tuner not being recognized

    which refers to LE 9.2 and the Sony D2837ER which also sits in my WP2 which is with a DVB-T/T2(/C?/S?) Tuner Module.

    Could this be the way in LE9.8 / 10, too?

    No DVB, no more WP2 :(

  • Apologies for reopening this thread.

    I own a Wetek hub which now has LibreELEC 9.0.2 and Kodi 18.2.

    Every time I boot it, it pops up several failures to update its components, and I would like to update it if possible. I only watch material present in a local NAS, I don't really need plugins with the possible exception of some way to download subtitles, but even that would be a nice plus.

    I noticed there doesn't seem to be any update package, nor any image available for download. However I discovered these nightly builds and I was wondering if the latest wetek-hub build was safe enough. I could install it on a brand new SD card and keep the old card as a failsafe.

    Thank you for your help.

  • The "wetek-hub" image is for installing to eMMC storage. It works for most, but for others (with the possible issue of dry solder joints on the board) it sees keyboard input during early boot causing it to enter the u-boot console and unless you have the UART cable connected this creates the impression of a bricked device. I couldn't figure out the issue so the only option was to discontinue that image. However, if Android is still installed to the device you need to use the AMLGX "box" image anyway so that's not a major problem. Have a read here: https://wiki.libreelec.tv/hardware/amlogic - AMLGX is not perfect but for basic H264/HEVC media over a local connection it works well enough and you're using latest Kodi and add-ons.

  • Thank you for your reply!

    It's been a few years since I installed LibreELEC and I can't remember all the steps I took but I am fairly convinced I just programmed the Wetek hub to boot from the SD, leaving its core memory intact (as a matter of fact I am not sure I ever used its OS at all).

    The page you linked me is very close to the very first page I entered when I first searched for this topic, which in turn brought me here, where I didn't see any new build for the Wetek hub, and that eventually brought me to post in this thread.

    Do I understand correctly that you are recommending the generic box image (Generic Box Image LibreELEC-AMLGX.aarch64-12.0.0-box.img.gz)?

    Do I also understand correctly that in order to install it, I just have to prepare a brand new SD with it and replace my current SD with that one and everything else should work (barring configuration etc)? Again, my current setup is working fine, just outdated.

    Thank you again very much for your help and have a nice day.

  • Yes, the AMLGX box image. It's so long since I booted a Hub with Android still installed that I can't recall the exact process, but either it will work with a simple SD card swap, or worst case you might need to invoke recovery boot by holding down the recovery button that's visible through the case holes (on the underside of the case), powering on (plug the cable in) then releasing the button after a couple of seconds.

  • Alright, so I burned the img file onto a brand new SD card using LibreELEC USB-SD Creator run in administrator mode (I run Windows). Swapped the old SD card with the new one, but the hub booted on WEOS which is not what I wanted.

    Put back the old SD card, and it booted to Kodi 18.2.

    I tried burning the SD again, but no progress.

    I read on the wiki that I was supposed to change a file called uEnv.ini in the root folder, but (at least from Windows) I can't see the file.

    Tried booting the Hub in recovery mode. I am presented the following choices:

    • reboot system now
    • apply update from ext
    • apply update from cache
    • wipe data/factory reset
    • wipe cache partition
    • view recovery logs

    None of them seem helpful to boot from a SD.

    I seem to remember that booting from the SD with a Wetek hub involved doing some shenanigans with the remote control. I actually tried to press/keep depressed the Power button during boot but nothing happened. And again, if I put the old SD card, it works perfectly. Perhaps I have to make the SD card bootable?

    Not sure how to proceed from here and I would truly appreciate a nudge in the right direction! ;)

  • My apologies; I mixed up my downloads. I burned and configured the correct one and it works perfectly (so far!).

    Thank you again for your help.