Resolution stuck at 2048x1536 with old Dell inspiron

  • I am trying to use an old Dell inspiron 1525 to run libreelec. Its display is broken and not available. I have connected HDMI port of the machine to my 4K TV through a 4K AV receiver. Although things work well, the resolution is stuck at 2048x1536. Only other resolution that is available is very low.

    With 2048x1536, part of the display is not shown. I disabled overscan in TV and also tried video calibration, but I cannot get the lower edge of the picture to align to screen edge - For me it looks like this is because the resolution is not 16:9.

    xrandr outout:

    I tried this command but screen goes blank:

    xrandr --output LVDS1 --off && xrandr --output HDMI1 --mode 1920x1080 --rate 60.00

    Any idea?

  • I would see if it's possible to change the primary display device in the BIOS to use HDMI1 not LVDS1 (broken screen). It may also be possible to toggle the output using F7 keys or such - if the toggle is done in hardware not software.

    /usr/lib/kodi/kodi-xrandr <= gives modes available to xbmc

    xrandr --output HDMI-0 --mode 0x1be <= sets the 0x1be mode on HDMI-0 using the mode shortcode

    it might also be possible to use a custom xorg.conf to force the output to HDMI, but it's no long since I fiddled with Xorg things I'm hazy on how that's actually achieved. NB: Raspberry Pi boards make much better HTPCs than recycled old/broken laptops.

  • thank you for the info. I tried BIOS setting but it does not allow me to disable the laptop monitor. I also tried your suggestion but it did nt work either unfortunately. But the good news is after I upgrade to the latest LibreElec it started to work! I should have done that as the first step..

    PS:I use RPI's for Kodi, but wanted one of the RPI's for some of my hardware experiments so wanted to use this laptop instead for the that TV. But thank you for the info again. Cheers.

  • You can try to disable the LVDS device in the kernel.

    The kernel name may differ from the xorg name. Verify it with:

    ls /sys/class/drm

    Remove the cardX- prefix and memorize the device name.

    Edit the kernel command line:

    mount -o remount,rw /flash
    nano /flash/syslinux.cfg

    Add  video=LVDS1:d to the APPEND line (replace the found device name). Save the file and reboot.