Unable to Enable Wifi for LiberELEC Kodi on Pi3 A+

  • First off let me say, I am a total newbie to LiberELEC. I have used Pi for other projects before - 3D Print Server. and an IoT Gateway node for Dmoticz. These installs are stable and in good working condition. But I recently configured a Pi3 Model A+ to be used as a Media server and sofar its been issues after another. Thats why I have come here to the experts to help me.

    I installed a fresh copy of LiberELEC as a Media Server. but it crashes immediately I click on the "Active" button to activate Wifi network under the Wireless Networks in LiberELEC settings window. My build is a fresh install of LiberELEC OS running on a Rasberry Pi3 without Network Port. Install is stable with a LibreELEC(Official) distribution. Version 9.2.0 running on a Linux 4.19.83 Kernel.

    To recreate the error, I start from System Settings - LIBREELEC - Network - Wireless Networks. As expected, clicking on the "Active" or the directly at the button should enable/activate the system to be able to search and list all available WIFI Networks and Hotspots around. These Hotspots should then be available under the Connections Tab.

    KODI crashes immediately I click on the "Active" button to activate Wifi network under the Wireless Networks in LiberELEC settings window.

    Steps to reproduce the behavior:

    1. From LerberELEC KODI Home page
    2. Select the Settings Icon at the tope left corner (the Gear Icon)
    3. In the System Settings page click on "LibreELEC" at the bottom of the page
    4. On the left pane, select "Network"
    5. In the Right pane, under "Wireless Networks" click on "Active" or Directly at the button on the right
    6. Pi Resets instantly and Reboots

    I have no screen shots except the picture of my Pi. looks like the image below. Its a Raspberry Pi 3 Model A+ 0J7010.1200.jpg

    I am unable to use my installation, though the system is installed, I am unable to connect or access it remotely or even upload media to it. I have tried unsuccessfully to get it to work, that's why I am trying this medium. I am sorry if the solution is trivial, I have tried several solutions without luck. Kindly help me. the details of my install are as follows.

    • [X ] Linux

    • [ X] Raspberry-Pi

    • Operating system version/name: LibreELEC (official) 9.2.0 (kernel: Linux 4.19.83

    • Kodi version: 18.5 Git: newclock5_18.5-Leia

    I thank you in advance for any help rendered.

  • How odd - I've used the Pi3 A+ with LE without any issues. Albeit not on 9.2.0.

    If you can somehow read the installed SD card, post the output from /storage/.kodi/temp/kodi.log and kodi.log.old

  • Nice to know that I have hope that this will work some day. Unfortunately, there is no way to read the Pi. No IP issued so I have no way to connect to read the log file. If you help with the code and how to. Will it still be relevant if I stick the SD card into another PI that can connect to the Wifi and extract the log file?

  • I've just tested on a RPi3 A+ on 9.2.0 and all works as expected. So it's possibly not an LE issue? Try installing Raspbian and see if the wifi works there (If not, it's possibly a H/W issue)

    Can you try 9.2.1 and set the Wifi on the startup screen and see if that works. (make sure you choose the RPi2/RPi3 image.

    Yes, the log files will be readable on any Linux based system.

    NOTE: Check that your RPi A+ looks exactly like the image. It doesn't seem to have a wifi chip. So it's probably a RPi 1 A+ which doesn't have wifi.

    This is an RPi3 A+

  • Thanks @Iriduim I have checked and the board is exactly the same as the one in your picture.

    So I will download the RPi3 Image and build a fresh install and revert,,, If it fails after that I will then post the Log files. Thanks once again.

  • Yeeepeee!!! Its working. I downloaded the Pi3 Image on this Forum and created a fresh SD card and everything is working now. Thanks. Many Thanks.

    Next step is creating source folders from my Windows Laptop to transfer Music and Video... any leads will help. But this issue will close. Thanks.