Help for Bluetooth support

  • Hi friends,

    I have a librelec 9.2.2 installed on a kind of Intel NUC (NVISEN Y-MU01, I7 processor). The combo M2 ngff wificard/bluetooth is a ATHEROS QCA9377. Unfortunately, only wifi is working, not the Bluetooth… in Windows 10, ID is USB\VID_0CF3&PID_E009&REV_0001, it's a QUALCOMM QCA9377 Bluetooth 4.1.

    I also have a CSR8510 A10 USB dongle which isn't reconized too.

    ...is there any solution to activate at least one of it?


    Thanks for your help...

    LAURENT.

  • Code
    1. [ 3.392029] bluetooth hci0: Direct firmware load for qca/rampatch_usb_00000302.bin failed with error -2
    2. [ 3.392032] Bluetooth: hci0: failed to request rampatch file: qca/rampatch_usb_00000302.bin (-2)

    ^ hardware is detected but firmware is missing. I'll see if I can find it..

  • Code
    1. mkdir -p /storage/.config/firmware/qca
    2. cd /storage/.config/firmware/qca
    3. wget https://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git/plain/qca/nvm_usb_00000302.bin
    4. wget https://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git/plain/qca/rampatch_usb_00000302.bin
    5. reboot

    ^ run those commands and you should have the right firmware. If you confirm it works, it's trivial for us to add the firmware into a future LE release.


    let us know..

  • Worked like a charm...everything is ok now!!! My Bluetooth headphones are appaired and fully working... thanks Chewitt for this incredible support!!!

  • The device is a combo wifi/BT atheros QCA 9377 (The wifi part was supported, not the BT part but now you solved the problem 😃). The card is a ngff size working in an M2 slot on the motherboard. I'm using the x86/x64 Librelec version installed dual boot on the hard drive in a chinese Intel NUC like (NVISEN Y-MU01) small PC.