Chrome Addon missing libxcb-dri3.so.0

  • As the Titel explains, I have the latest libreelec installed and now try to get the chrome addon to run. The addon gets installed , but when starting it nothing happens. So I sshed into libreelec and tired to start it from ther. this is the output:


    LibreELEC1:/ # chrome-start

    /storage/.kodi/addons/browser.chrome/chrome-bin/chrome: error while loading shared libraries: libxcb-dri3.so.0: cannot open shared object file: No such file or directory


    any help where to get the missing lib?


    kind regards

    Sebastian

  • LibreELEC:~ # ldd /storage/.kodi/addons/browser.chrome/chrome-bin/chrome | grep "not found"

    libxcb-dri3.so.0 => not found


    I can confirm it, try to get an fix on the way asap

  • There is a libxcdb already in that dir with a different name extension.

    Copy this to a new file in the same location with the missing name.


    this fixed my problem.

  • I have the same problem -

    \\MEDIACENTER\Userdata\addon_data\browser.chrome

    found the service.log file

    Which says

    /storage/.kodi/addons/browser.chrome/chrome-bin/chrome: error while loading shared libraries: libxcb-dri3.so.0: cannot open shared object file: No such file or directory


    But I don't know how to add that library.


    It seems that if I knew how to do a linux download from LibreElec I would be able to rename it like Ozyaus via the winExplorer over the network.


    Would that be a solution?

  • there is the libxcb-dri3.so.0, just copy it to the addon and reboot afterwards (or the system might not recognise it)

    /storage/.kodi/addons/browser.chrome/lib/libxcb-dri3.so.0


    not sure if this works for you

  • Thanks!


    Unfortunately I get the same error - it seems that we would need to hear from Ozyaus what he has installed and how it looks for him. My directory was all empty except the log file. Where are all the actual chrome files stored?
    I realize know how little I actually know about linux builds but I'm stumped as to where to look or how to manually add the missing library.

    All google searches take me to much more advanced users with some much harder questions.


    Is there a previous build before the most current that would work?
    Could it be that because I'm using Samba that I'm missing the stuff?

    I'm I in the entirely wrong place and poking around maybe?

  • Thanks!

    That took care of it.

    I first tried just throwing it in there with samba, but when that didn't work I rebooted and tried installing it properly as an add-on. And now it works great


    Thank you for your patience!

  • You need to go to

    Cd /storage/.kodi/addons/browser.chrome/lib

    Cp libxcb.so.1 libxcb-dri3.so.0


    hope this helps.

    Edited once, last by Ozyaus: Typo ().

  • Thanks for the updated Chrome browser. On my i3 system I've had my issues with Chrome. Once I was able to get the sound working last year it works very well for our needs. I can stream video from most sites with no problem but for some the audio is silent. Youtube audio works fine but a TV news channel plays video with no sound (sometimes). I've tried restarting the TV to refresh but doesn't seem to work. The next session sound is back. Kinda tweaks my brain a bit. A show I like to watch on Chrome keeps giving me the "Aw snap! Something went wrong message." I was hoping this new release might fix that but I tried it this morning and same error. I have to reboot to our Windows system then all works fine on a Chrome browser.

    In any case glad someone with the skills is keeping the Chrome browser addon alive and working for x86 users.

    Many thanks.

    RS

    :)

  • Great! I've been following another thread that this one superceeds; installed chrome 9.2.0.102 as suggested and bingo, all works as advertised!

    I tried updating Chrome from the kodi Libreelec add-ons and that still shows 101 as the latest.

    I think I've now ticked all my requirements for a usable mediplayer!

  • try the new chrome addon, that includes the fix from above, just install it over the existing one

    browser.chrome-9.2.0.102.zip


    for some reason the solution that sstetsen and Ozyaus are using are not working for me, maybe my setup is gone fubar for some reason

    Are these changes getting pushed to master anytime soon? I'd like to add a switch to enable Dark Mode, got it working on my setup. Thanks!