LibreELEC Pi4 Refresh-rate problem

  • Hello!

    I've been trying a lot (and did a lot of google search) to solve my problem which wasn't very effective. Now i need your help.

    I'm running a Raspberry PI 4 (LibreELEC 9.2.1) which is connected to a receiver (Pioneer VSX 1025) which is connected to a projector (Sony VPL HW 40ES).

    Here is my problem. When i'm playing sources which are 1080p23.98hz i have a constant tearing line at the top of my image.

    In my opinion the problem ist the "wrong" HDMI output state.

    LibreELEC:~ # tvservice -s
    state 0xa [HDMI CUSTOM RGB full 16:9], 1920x1080 @ 24.00Hz, progressive

    my config.txt

    I also have a RPI 3 (running with OSMC) connected to the same receiver and projector which gives me perfect output with no tearing.

    [email protected]:~$ tvservice -s
    state 0x12000a [HDMI CEA (32) RGB lim 16:9], 1920x1080 @ 23.98Hz, progressive

    here is the config.txt of the pi 3

    If i run tvservice -p (on the PI 4 with LibreELEC) i get the following output from tvservice -s

    tvservice -s
    state 0xa [HDMI CEA (32) RGB lim 16:9], 1920x1080 @ 24.00Hz, progressive

    After that the tearing line is gone but it stutters like crazy. In my opinion the problem ist that there is 24.00 Hz instead of 23.98 but i have no idea how i can change this.

    No matter how i change the config.txt after I reboot the PI it always shows

    state 0xa [HDMI CUSTOM RGB full 16:9], 1920x1080 @ 24.00Hz, progressive

    I hope anyone of you can help me with this problem.

    (And yes i need the PI 4 too because the PI 3 doesn't manage to play all h265 files)

  • I had a similar issue with my Projector/Receiver/Amp/Pi4 chain. In the end, no amount of config.txt-ing would cause the Pi to adopt the correct hdmi mode, so instead I added a line to /etc/rc.local, which runs at boot and switches the hdmi to the correct mode:

    $ sudo nano /etc/rc.local
    ## Then add in the command you want to run above the exit 0, ie:
    tvservice --explicit "CEA 32 HDMI"
  • Thanks for your input. Did you do that on LibreELEC? I have no /etc/rc.local file :/

    But the more concerning point is that if i type

    LibreELEC:~ # tvservice --explicit "CEA 32 HDMI"
    Powering on HDMI with explicit settings (CEA mode 32)
    LibreELEC:~ # tvservice -s
    state 0xa [HDMI CEA (32) RGB lim 16:9], 1920x1080 @ 24.00Hz, progressive

    the PI switches to CEA (32) but again with 24.00Hz which gives me constant stutter and makes movies completely unwatchable.

    Is there any known problem with PI 4 and 23.98Hz?

  • Ah! I missed your line about the stutter. I also had a stutter issue when I tried Libreelec on Pi4 (though strangely it disappeared if I connected the Pi directly to the projector, along with the HDMI mode problem)

    I ended up running a Raspbian build on the Pi4 and then manually installing Kodi and setting it to autorun on boot, which seems to have resolved the stutter issue.

  • Hmm thanks the info. Maybe i'll try and connect it directly to the projector. (It's a lot of work because my rack is not friendly for changes :dodgy:).

    Installing a new build is no option at the moment i think. At least there are only very few files i can't play. Lot's of the "broken" files have a black bar at the top and bottom so the tearing line won't appear anyway. Let's see if there is improvement with following LibreELEC updates.

    If anyone knows an easy fix i'd apreciate it.

    Thanks for your help Padre

    Plugging the PI directly to the projector didn't work.

    Edited once, last by Strampi5 ().

  • I did a fresh install on my PI 4 with Raspbian Buster and installed Kodi afterwards.

    The problem ist still the same. Therefore i think it's a problem with the PI 4 itself.

  • I don't know how long i've been playing with the whitelist without any progress.

    On thing i noticed is that on the PI 3 i can choose 23.98 Hz and 24.00 Hz.

    On the PI 4 there is only 24.00Hz.

    Actually I think the PI 4 doesn't support 23.98 Hz properly yet.

  • No, Pi 4 support 23,98.

    Did you connect via Receiver or directly to your TV ?

  • My cmd line output is also showing 24hz, I have 24 & 23.98 whitelisted, but I don’t have stutter if I use pass through audio.

  • The TV is not the problem. The picture is fine.

    But on my projector i get one tearing line without stutter only if the file is in 24 Hz. Other files (60Hz,...) are fine.

    I tried connecting it directly which doesn't help.

    The funny thing is i can only choose 24Hz but i can't select 23.98 Hz.

  • If anyone is interested:

    Today I solved my problem. (actually I don't know how). First i plugged the RasPI directly to my projector. Suddenly I could choose all possible refresh rates (23.98, 24.00, 30.00,etc...). Then I plugged it in my receiver again --> didn't work. Then I saw that i have a HDMI splitter (TV and projector). I plugged the RasPI in the splitter --> didn't work. So i thought there is the problem. (The Cable from the splitter to the projector worked fine.)

    Then i unplugged the power chord from the splitter and changed the 2 HDMI cables. Suddenly it worked. Then I changed it back. Still works. Now everything is plugged in as it was before but the tearing line is gone. The only explanation I have is that there was a loose contact.

    Nevertheless I'm glad it works now.

    Thanks again for all your ideas!