LibreELEC 8.2.5 freezing on Wetek Core accessing to Video->File section

  • Hi all

    One of my best friend has a Wetek Core, on which we tried (obviously I support him remotely due to the covid-19 beast....) to install the last LibreELEC version (9.2.1). The device is connected via optical cable to the AVR (which doesn't have HDMI input) and with HDMI to a FullHD TV.

    Media are stored into an HDD, plugged into an USB port directly to the home router.

    The 9.2.1 version however had a big issue managing multichannel audio. In the device list of the System->Audio section no SPDIF entry appears, and the "Audio Pass-Through" section in the lower part of the option panel was completely empty. Searching the forum, this seems to be an unresolved issue, so we decided to make a step-back and install the old one 8.2.5. The audio in this old version is instead managed perfectly, is possible to enable the pass-through and the audio streams are correctly send to the AVR.

    Well, we have got another issue.

    I use normally (and suggest to make the same to my friend) the Universal Movie Scraper to get info for the movie. It's the scraper addon which have the best configuration to obtain info in a given language (Italian in our case), and normally it recognize the 95% of the movies. My friend has around 120-130 movies stored into the HDD described above, all in a unigue root folder, following the naming convention name (year).ext .

    We have three issues:

    1) The scraper seems to scan all the movies (it possible to see all the titles appearing in the top-right current of the screen during the scan), but it recognizes only 46 on the total.

    2) Trying to access to Video->File section, Kodi freeze completely (we have to restart unplugging and plugging power cable, no other chance to do it)

    3) In the Event Log section there are many errors generated by TheTVDB addon. No source has been configured to use it, and this is surprising. To avoid it, is it enough to disable this addon?


    My first idea was about network issues : Internet for the scraper (1) , Intranet for the freezing accessing to Video->File (2).

    My friend however yesterday was able to play a movie (one of the 42 recognized by scraper) and it was played perfectly (with 5.1 audio too and without any video stuttering..)

    Any ideas? I suppose that there's some Video Source that locks Kodi. Is there any way to clean video source not accessing to the Video->File section? From Windows PC using Putty ? Or directly accessing through Windows File Explorer to LibreELEEC and then deleting some file/configuration/XML manually?


    In parallel, I suggest to my friend to enable the Debug Log, and to upload it using the Kodi Logfile Uploader official addon.

    Obviously, we didn't install any third party addons after the LibreELEC installation. The only one is Universal Movie Scraper.


    Thanks in advance for any help


    Andrea

  • There is a bug in 9.0.2 (there is no 9.2.1 release for the Core) and while a few people claimed to have fixed it nobody ever shared the fix so there's never been a 9.0.3 to resolve it. Since then we switched our focus towards mainline kernel support for Amlogic devices, and this is not currently possible for Meson8* hardware (no HDMI driver). Not the best report card, but that's the situation. LE 8.2.5 should work .. stick to that.

  • OK, thanks a lot for the quickly answer! So we'll stay on 8.2.5 forever and ever... :-)


    Regarding the issues related to scraper and freezing have you any suggestion?

    Obviously immediately after upload the log file I'll put the link here....