Image too far to the right

  • I've LIBREelec installed on Raspberry Pi 3. I'm using HDMI to a "HDMI ready" TV. It was "OKay" by default, but the edges of the menus were off the screen (top, bottom, left and right).


    The TV native resolution is actually 1366x768, so I thought it wise to select 1360x768 as my resolution. Now the top/bottom and right edges are exactly on the borders of the screen, as I would expect, but the image is about 1 inch in from the left hand edge of the screen. I have tried the calibration options. When I move the image left, the left edge of the image disappears (as if it had gone beyond the left edge of the screen).


    I did try 1080, but the display looked horrible, as if the odd and even lines were reversed. Unfortunately, I can't remember what the original resolution was.


    Any ideas what might be the matter, please?

  • It's "HD ready".


    Some TV's have picture optimization modes, which increases the picture size to outside the screen (not much, but visible).

    Check your TV settings, and disable all picture optimization modes you have.

    Flexin' vinyl, jammin' break beats. 8)

  • I've had the exact same problem in the past with one of my tvs (can't remember which one)


    I remember though that the only way to fix it was to change the input mode to pc.


    Hope this helps.

  • Responses are going to be slow. As a noob, it seems I have to wait a day or so between posts.


    Try to edit config.txt as suggested in this thread:


    1366X768

    I added this line (yesterday, but unable to reply). I see the boot screen scroll by, the LibreElect logo, but then I just get a blue screen. I think the blue screen is generated by the TV in response to the absence of an input signal.

    It's "HD ready".


    Some TV's have picture optimization modes, which increases the picture size to outside the screen (not much, but visible).

    Check your TV settings, and disable all picture optimization modes you have.

    I'd a feeling that would be significant! Like I say, native resolution is 1366x768. There are "advanced" menus, but they're greyed out and I can't see a menu option to enable them. I don't have the original remote, so there's bound to be something I'm missing.

  • Here is another config.txt setting for an older TV, which you can try: click. Maybe it does the trick for the final half inch.

    Flexin' vinyl, jammin' break beats. 8)

  • Here is another config.txt setting for an older TV, which you can try: click. Maybe it does the trick for the final half inch.

    Any idea which bit in particular? The most pertinent thing I see there is mode 16, but I can already select 1080p 60Hz from KODI. I think I'll have a play with overscan and forcing the frame buffer size and see what comes out. Thanks.

  • I think I'll have a play with overscan and forcing the frame buffer size and see what comes out.

    Exactly. Disable overscan and make frame buffer size fit to your selected resolution.

    Try LE's screen calibration whenever you check a new video mode.

    Flexin' vinyl, jammin' break beats. 8)

  • Exactly. Disable overscan and make frame buffer size fit to your selected resolution.

    Try LE's screen calibration whenever you check a new video mode.

    According to the Raspberry Pi people, overscan only affects the boot screen. Specifically NOT Kodi. I did the frame buffer size thing and recalibrate to no effect. I think it's as good as it's going to get. I just have this niggling feeling: there are pixels at the side of the screen asking to be used!! It's an analog set, so not worth buying the remote for ... on the other hand, it's got a bit of life left in it by the looks of things!

    Thanks for all your input.