[unoffical] LE-9.2/9.80-Images for RK3229/RK3228

  • Hi All, Can someone please point me in the right direction, it's my first time attempting to flash one of these TV Box units.
    I have a Scishion V88 4K, on the pc board its printed: MX4N-V02 2016-06-27 and there is a sticker on the board that shows: MX4N 8G/1G ZXD 2017-02-09 WW16120089
    I went to the downloads page and saw the bootable media creation tool, but i did not see the recommended "V88Mars LibreELEC-RK322x.arm-9.2-devel-20200301143855-b58333a-rk3228b-v88marsII.img.gz" firmware to download suggested by another user earlier in the thread.

    Are there any issue that i need to take precaution off (besides the UHC memory cards)

    What download page are you referring to?


    I see that the latest legacy builds list here: Release RK322x-le92-d20c7bc · knaerzche/LibreELEC.tv · GitHub the image for v88 4k is available

  • Hello everyone


    It is possible to install retroarch or some emulator on this distro,


    or if you can guide me how to activate the kodi emulation plugins for this platform


    Cheers

  • hello everyone... i have a problem with my box android...when go reboot. i want tried to update.... you can help me with instructions?

    i attach motherboard and version on my box....thanks advance and happy new year all you

  • Hi guys,


    good project and thank's for providing it. I play around to give a new life for an old android tv box with RK3229 and RTL8723 Wifi chip. I didn't try the ethernet connection at the moment, but would like to have a working wifi.

    I used the build for the D88 HDMI stick with same dtb file. The libreelec is running smooth and the wifi connection can be established. But after rebooting the box, the wifi is not reconnecting again. It needs to be connected again + entering the wifi passwort again. Did you observe the same behavior? Is there a solution for it or no hope and suggestion to use ethernet only?


    Thank's for your support.

  • Hello Guys!

    Any chance to rk3228a-h96mini image to work on the new H96 Mini V8 box?

    This is the specification of the box:

    • CPU: RK3228A, 28nm Quad core Cortex A7
    • GPU: ARM Mali-400 GPU
    • Memory: 1GB / 2GB DDR3 RAM
    • Flash: 8GB / 16GB eMMC

    Thank you!

  • The libreelec is running smooth and the wifi connection can be established. But after rebooting the box, the wifi is not reconnecting again. It needs to be connected again + entering the wifi passwort again. Did you observe the same behavior?

    Have the same problem with my TX2: wlan password has dropped during every boot.

    Each access point is duplicated besides.

    UART log says nothing.

    Rebooting LE after trying connect sometimes.

    RK3229_LE.txt

    Edited once, last by UART ().

  • Historically "wifi doesn't remember the passphrase" frequently traces back to wifi cards with a MAC address that changes on each boot. As the MAC is used in the connman service identifier, format "wps_macinbase64_ssidinbase64" each time you reboot there is no matching stored service and you are (correctly) required to configure the network again. You can diagnose this by checking the MAC listed for the WLAN interface in "ifconfig" over a couple of reboots. If yes, knaerzche might want to investigate adding RK details to the "ethmactool" script I wrote for Amlogic which basically sets the MAC from the CPU serial from userspace (regardless of what comes from u-boot/kernel) to ensure the MAC is unique and persistent.

  • Changing MAC address is a bad news.

    Try do like there but can't find any folders: "udev.rules.d" and "configfiles".

    Previous methods ("autostart.sh" and "[email protected]") are not worked.

    ---------------

    I located this folder, make those file - no any results.

    Edited once, last by UART ().

  • Взаимодействие с другими людьми

    Start by answering the question: does the wlan0 MAC address change on each reboot?

    Yes address has changed each boot.

    Also tried do this - can't run some commands:

    fw_printenv | grep ethaddr

    fw_setenv ethaddr

    "-sh: fw_printenv: not found"

    "-sh: fw_setenv: not found"

    Edited once, last by UART ().

  • Now I have autostart.sh in 'storage/.config/'

    [email protected] in 'storage/.config/system.d/'

    and 99-mac-address.rules in ''storage/.config/udev.rules.d'

    with that msg:

    MAC adress still changing every time.

    -----------------------------------------------------------------------------------------------

    Can I do like this:

    or something like this:


    and where it must be placed?

    Edited 4 times, last by UART: Edit ().

  • Create /storage/.config/system.d/wlanmac.service with ^ this content then enable it, and remove any other .service files and udev rules you have set in the system. The main difference is that I take the interface down before setting the MAC, then bring it up again.

  • Взаимодействие с другими людьми

    Create /storage/.config/system.d/wlanmac.service with ^ this content then enable it, and remove any other .service files and udev rules you have set in the system. The main difference is that I take the interface down before setting the MAC, then bring it up again.

    Thank You for help!

    I deleted all files, create and place wlanmac.service in '/storage/.config/system.d/' - no any results.

    I'm not sure about 'then enable it'. How this should be done? Set permissions to 0755 ?

    ----

    0755 didn't helped either.

    .

    Edited once, last by UART ().

  • Code
    systemctl enable /storage/.config/system.d/wlanmac.service

    ^ that, it has nothing to do with permissions (644 are fine)

  • Взаимодействие с другими людьми

    Code
    systemctl enable /storage/.config/system.d/wlanmac.service

    ^ that, it has nothing to do with permissions (644 are fine)

    Oh thanks! Now I will know how it's done!

    -------------

    At last!

    Mac address remains the same!

    Thank you Chewitt! You are a genius!

    Long life and lot of good luck to you, kind person!

  • Hello,


    Is there a windows tool where i can write the RK322x image to my MXQ Pro 4k? Does this only work in a Linux environment?