Virtual LibreELEC

  • Hi, I see with happiness on the virtual section (Virtual – LibreELEC) that KVM is supported. I am trying to create a VM from the ova, but when running the build, I get "Failed to start Xorg, is you GPU supported".


    Here are my steps:

    1. Download LibreELEC-Generic.x86_64-9.2.0.ova

    2. Extract the LibreELEC-Generic.x86_64-9.2.0.vmdk

    3. Convert the vmdk to qcow2

    4. Create a new VM, attache the LibreELEC-Generic.x86_64-9.2.0.qcow2 and boot.

    5. At this stage if I try and install or run live, I get "Failed to start Xorg, is you GPU supported"


    What am I doing wrong?

    Kind regards.

  • I'm not sure who added KVM to the OVA description but AFAIK no staff members run it on KVM and we've never formally supported "user" use on any form of virtual platform (we create it as a staff userspace development/testing tool) so the description should be corrected to remove the reference.

  • Hi chewitt, thanks for replying, although it saddened me to read it :(

    I was running LibreELEC on ESXi VMware VM with GPU passthough for the past 1.5 years for my main lounge TV, and was such a great experience. I have now moved my setup over to KVM (much more flexibility), and am trying to replicate the experience, with the same GPU passed through to my main lounge TV, which I use for live TV, Movies, etc. Im sure its possible, just need s bit of a fiddle. Just need help with which bits to fiddle with though.

    Would love to talk to the guy who added the 'KVM' label to the virtual download and get a bit more insight about how to get this working.

    Unraid has a 'built' in LibreELEC which is easy to get up and running, but it is a very old version.


    Kind regards.

  • The virtual build is strictly for vmware.


    However, you can use the generic build on kvm with a gpu passed through.

  • Hi aptalca, thanks for your reply. I must be doing something wrong, as I have tried this before with the same results, so I just tried it again, below is the procedure:


    1. Download LibreELEC-Generic.x86_64-9.2.0.img.gz

    2. Extract LibreELEC-Generic.x86_64-9.2.0.img

    3. On KVM, create a new VM, attach LibreELEC-Generic.x86_64-9.2.0.img image

    4. Passthrough my Nvidia Quadro 2000, video and sound

    5. Start the VM:

    a. Nothing is displayed on the external TV

    b. On the KVM console, I can see LibreELEC booting, but then get "Failed to start Xorg, is you GPU supported"

    6. I also tried removing the Display Spice component, but still nothing on the external TV


    I have also manually built a Linux 18.04 with Kodi, Nivida dirvers, and this is working on the same monitor, but really like LibreELEC.

    Can you see anything I am doing wrong? Is there a guide anywhere please?


    Kind regards.

  • You have the kvm console acting as the main display adapter, but libreelec lacks the gpu drivers for that. You need to pass the nvidia card as the main and only display adapter.


    I did this on unraid (which has a nice gui for managing kvm) so I can't help you with the exact steps but the kvm display is certainly the issue here.

  • I got it working in the end on KVM, but it certainly was not straight forward. I tried every possible scenario, nothing worked (nothing was ever displayed on my external TV), but in Unraid, the default LibreELEC worked straight away, although it is a very old version and the file is called 'LibreELEC-unRAID.x86_64-7.0.1.img (Specific to Unraid?).

    So, I copied this file to my Mac, mounted it. I also downloaded the latest 'LibreELEC-Generic.x86_64-9.2.0.img', also mounted that, then copied 4 files from the 9.2 image over the top of the 7.0.1 image:


    Files copied:

    KERNEL

    KERNEL.md5

    SYSTEM

    SYSTEM.md5


    Replacing the ones already there ion the old 7.0.1 image.

    I also edited the 'syslinux.cfg' file to:


    Code
    1. DEFAULT live
    2. LABEL live
    3. KERNEL /KERNEL
    4. APPEND boot=UUID=0806-3443 installer tty vga=current


    I then used this image to create the VM, BUT at first boot I left the KVM screen stuff there to complete the install. Once installed I removed 'EVERYTHING' to do with KVM screen / console, and passed the Nividia Quadro 2000 through, and finally I have a fully working up-to-date LibreELEC on KVM.

  • I also see the virtual download page has been updated to "Virtual machine image for KVM (just with NVIDA GPU passthrough) and VMWare."

    It would be great if there was a quick 'how to' get this working with KVM, as I was not able to.

    Thanks.

  • It would be great if there was a quick 'how to' get this working with KVM, as I was not able to.

    I look into it to get it working with Vbox and KVM too, there is currently everything upstreamed (no idea if this works tbh) but basically just not build by LE. Not too sure how it works out size wise - maybe this won't made it into the image - depending at the quirks needed.

  • Just looking at this again....

    I am trying to get any LibreELEC working, virtual and generic, with KVM and Nvidia GT 1030. I can get it working with Kodi on screen working fine, BUT... the sound acts very strange. after a few seconds I get a repeating audio (the GUI click sound), it gets stuck and repeats very fast until I reboot, after reboot I get the same issue.

    I am using Fedora 31.

    I have tried:

    1. UEFI with BIOS

    2. UEFI with i440 FX

    3. Using OS as CentOS

    4. Using OS as Debian


    All give the same result, repeating audio.

    Any suggestions would be gratefully received.

  • Sure:


  • I found the answer, in case anyone else has this weird Audio issue:


    Create file as root:


    nano /etc/modprobe.d/snd-hda-intel.conf


    Then add:

    options snd-hda-intel enable_msi=1


    Save, close, restart.