Amazon Fire TV Remote with Libreelec at Raspberry Pi 4

  • Hi,


    I am trying now for a long time to use my AFTV remote with Libreelec on Raspberry Pi. Yesterday I got my new Raspberry 4 and again I want to try to pair it with libreelec. For me it is the best remote control on the market.


    In internet I only can get snippets but not the whole way to configure and use it. That's why I try it here and I hope you can help me.


    After activating blueetooth in the settings->services menu I choose the menu entry "Blueetooth". Here some of my bluetooth devices are listed but not my remote. Somewhere I read that you have to press the Home-Button for a longer time to enable pairing mode. Somewhere I read you have to press for ~20 seconds and that up to ten times to work. I have tried but it didn't work.

    The remote works with the original device like a charme.


    Somewhere I read that the remote will fall in energy saving mode and you cannot wake it up anymore. Is this true and when how to avoid this?


    Has anyone this remote working and can exactly tell me what do? Is it possible at all?


    Help is much appreciated. I thank you a lot in advance :)


    Kind regards

    tresi

  • Maybe its allready solved, i know the post is nearly a year ago.


    But for those who still look for a solution:


    Open Libreelec in Settings, go to Bluetooth look for devices.

    Press and hold your Fire TV's home button until the LED flashes orange.

    You'll find a Bluetooth device called "AR" connect to it. Its your Amazon remote.


    Go to Game ad dons -> controller profile -> and install "TV remote"

    Restart Kodi!

    Now you Fire remote will work now. Except the context menu button ;(