LibreELEC 9.1.502 attempting to drive tv @ 13Hz

  • Hardware spec:

    Raspberry Pi 4B 4GB

    LibreElec version: LibreELEC 9.2 Beta 2 (9.1.502)

    Log file attached

    I updated the Raspberry Pi to the latest firmware (Oct 4 2019 15:15:29) via the kodi interface.


    All works fine when connected via HDMI to a computer monitor.

    When connected to my Sony A1 tv (TV spec), the LibreELEC logo displays when booting, then the TV switches to 4096x2160 @ 13Hz (according to the overlay text) and the display goes blank.


    I ran

    /opt/vc/bin/tvservice -m CEA

    which gave the output:

    Group CEA has 1 modes:

    (prefer) mode 16: 1920x1080 @ 60Hz 16:9, clock:148MHz progressive


    I tried adding the following to config.txt:

    hdmi_group=1

    hdmi_mode=16

    hdmi_force_mode=1


    It seems to use that setting when booting then after the LibreELEC logo has displayed the TV still switches to 4096x2160 @ 13Hz and the display goes blank again.

    I have tried using the resolution whitelisting within Kodi to just allow 1920x1080 @ 60Hz, but it made no difference.


    Output of dmesg attached,

    'lspci' gave command not found.

    Output of lsusb isattached.

    Files

    • kodi.log

      (68.92 kB, downloaded 74 times, last: )
    • dmesg.txt

      (23.95 kB, downloaded 64 times, last: )
    • lsusb.txt

      (271 Byte, downloaded 48 times, last: )
  • Just updated LibreELEC to 9.2.1 and still have exactly the same issue. LibreELEC is currently unusable for me on the Raspberry Pi 4.

  • Pleased to say I was able to get it working with some help from this thread.


    Latest output from
    /opt/vc/bin/tvservice -m DMT

    is:


    This is the settings I put in config.txt to get it working:

    Code
    1. disable_overscan=1
    2. hdmi_ignore_edid=0xa5000080
    3. hdmi_group=2
    4. hdmi_mode=88
    5. hdmi_cvt 3840 2160 15
    6. config_hdmi_bo*st=7
    7. framebuffer_width=3840
    8. framebuffer_height=2160


    Note the typo in "config_hdmi_bo*st" - the forum is censoring that word for some reason.