Upgrade/Downgrade Python on Libreelec 9.2.0 (Leia) on RPI4?

  • Okay, thanks. That's a no-go.

    Is there a possibility of downgrading to previous incremental versions of Python 2?

    Reason being, I'm getting niggly Python generated errors running the IPlayer WWW addon in Libreelec but not on OSMC.

    • Official Post

    LE bakes all compiled code into the SYSTEM image file which is read-only and there's no package management so it's not possible to change anything. The only way to change would be self-compiling with an older version. The better apprpoach would be reporting the niggly issues to the add-on devs via their support thread in the Kodi forums so the issues get fixed.