Ryzen 3 2200G compatibility issue with LE 9.2

  • I have a HTPC built with a Gigabyte B450M and a Ryzen 3 2200G using integrated graphics. It seems the new 9.2 that LE auto-updated on my HTPC is producing a display issue that is similar to what I used to encounter when I previously tried to install LE 9.0.2 and a few Linux OS (Mint, Manjaro) many months back. What happens is the display will freeze at a random time and then there will be artifacts here and there on the display. Keyboard inputs no longer work. I never figured out how to resolve it but I tried LE 9.1.002 alpha in the end and it has been working solidly until this update.


    What I did notice this time is that the HTPC isn't completely frozen like I thought. I could still transfer files back and forth using other computers in the home. I think the kernel is the same compared to 9.1.002 but I didn't check the Mesa version.


    I'm not sure if there's any way for me to produce any logs since once the display freezes, the keyboard stops working also. In the meantime, I will continue to enjoy 9.1.002!

  • I'm also running the 2200g on my build.

    Mine is working pretty solid now after tweaking for a little while.


    You must of been lucky, my system wouldn't boot until le 9.1.501


    No Linux os worked on my system until kernel version 5.0.x

    Anything 4.19 kernel or below wouldn't boot, I just got stuck with black screen.


    Maybe try a different bios version for your motherboard. That's what solved most of my problems simply by downgrading the bios.

  • I have the exact same issue with 9.2 on my Ryzen 5 2400G, the interface freezes and no longer works, but the system is reachable through SSH and seems to work fine.


    kodi.log

    kodi.old.log

    kodi_crashlog_20191207115249.log


    All the logs are from the multiple crashes I have had in the mere minutes. I'm currently running 9.2, updated from 9.0.2 since it auto updated to that version and started crashing.