Docker crashing in LibreELEC 9.2 beta 2

  • LibreELEC 9.2 Beta 2 and Docker

    I'm creating this thread to easily read and get support :), as the previous post was placed in the news section.



    Updated the system to Beta 2

    I have docker installed with only the official container for letsencrypt and nginx.


    a) At each 3 reboots, docker fails, at least 1 time - sometimes work, sometimes don't - always working fine in beta 1;

    b) Doing a "docker restart docker.linuxserver.letsencrypt" in ssh shell, takes a lot of time (compared to Libreelec Beta 1) and fails to start again a lot of times.

    c) System shutdown / reboot taking a lot of time (a stop job is running for docker container .... 3 minutes) - almost immediate with beta 1


    Logs from a failed docker start after system boot:

    External Content pastebin.com
    Content embedded from external sources will not be displayed without your consent.
    Through the activation of external content, you agree that personal data may be transferred to third party platforms. We have provided more information on this in our privacy policy.




    Note docker crashes in this lines:

    Code
    Apr 11 17:28:41 LibreELEC dockerd[369]: time="2019-04-11T17:28:41.760117072+01:00" level=info msg="libcontainerd: started new containerd process" pid=430
    Apr 11 17:28:41 LibreELEC dockerd[369]: time="2019-04-11T17:28:41.760551072+01:00" level=info msg="parsed scheme: \"unix\"" module=grpc
    Apr 11 17:28:41 LibreELEC dockerd[369]: time="2019-04-11T17:28:41.760600776+01:00" level=info msg="scheme \"unix\" not registered, fallback to default scheme" module=grpc
    Apr 11 17:28:41 LibreELEC dockerd[369]: time="2019-04-11T17:28:41.797000224+01:00" level=info msg="ccResolverWrapper: sending new addresses to cc: [{unix:///var/run/docker/containerd/containerd.sock 0  <nil>}]" module=grpc
    Apr 11 17:28:41 LibreELEC dockerd[369]: time="2019-04-11T17:28:41.797126520+01:00" level=info msg="ClientConn switching balancer to \"pick_first\"" module=grpc
    Apr 11 17:28:41 LibreELEC dockerd[369]: time="2019-04-11T17:28:41.797396094+01:00" level=info msg="pickfirstBalancer: HandleSubConnStateChange: 0x4d6ab50, CONNECTING" module=grpc
    Apr 11 17:28:41 LibreELEC dockerd[369]: time="2019-04-11T17:28:41.819133578+01:00" level=error msg="containerd did not exit successfully" error="signal: segmentation fault (core dumped)" module=libcontainerd




    Back to LibreELEC 9.1 Beta 1 .. All is fine with docker .. no more core dumps.


    I 've also tried a Beta 2 fresh install in a clean sd-card and got the same symptoms - testing several restarts, and docker fails to start 30% to 40% of the time

  • I was able to replicate the problem with a fresh install:


    I've Installed LibreELEC 9.1.502 in another new 8GB SD-CARD in my Pi 4 4GB.


    After 1st boot configured ssh, wired ethernet, fixed ip (into which my router forwards ports 80 and 443).

    Activated debug logging.

    Installed docker, linux.io repo and the add-on with letsencrypt and nginx

    Configured ddns in the add-on as requested per install.

    All seem to be ok.


    After another reboot, docker crashed as in my initial SD-CARD.

    (as before, this happens roughly 1 in each 3 reboots).


    This happens only in beta 2. In beta 1, All is ok.



    This url is for full untouched logs of this fresh install:


    http://ix.io/20xr

    (search for "segmentation fault")


    Hope this help in finding the issue.



    Thanks Guys.

    LibreELEC has been awesome !

  • I'm seeing the same with a 9.1.502 self-compiled build. docker service sometimes starts at boot or with a start command, sometimes not.


    When started and 'docker run hello-world' is used to test docker in a (ssh) terminal, it's similarly unpredictable. Sometimes the output is as expected, occasionally fails with an error before output, usually fails after output but with (various different) errors, sometimes output followed by hang which doesn't respond to CTRL-C.


    Edit: A roll-back to 9.1.501 seems to work.

    Edited once, last by sihy ().

  • After upgrading to 9.2.0, I've done several reboots and docker restarts

    The docker crashing issue seems to be solved with this version.



    Thank you !!!

  • I need to revive the thread:

    I've been noticing that my simple web server running over docker's container "linuxserver/letsencrypt" is stopping.


    After several days looking into the logs, I've found that it only happens after a docker update as the one following:

    Code
    Apr 20 04:05:00 LibreELEC crond[2632]: USER root pid 4212 cmd /storage/.kodi/userdata/addon_data/docker.linuxserver.updater/update.sh > /storage/.kodi/userdata/addon_data/docker.linuxserver.updater/update.log && /storage/.kodi/userdata/addon_data/docker.linuxserver.updater/prune.sh > /storage/.kodi/userdata/addon_data/docker.linuxserver.updater/prune.log


    At this time docker container stops and do not start again unless I reboot the system.


    I'm using LibreELEC 9.2.1 runnng in a RPi 4

  • Nothing after the one above.

    As I've rebooted the system, I will wait for the next fail to re-look into logs.