Crash problem playing VP7 video files

  • I have had this problem for a while now but only recently decided to figure out. I have some files that will crash Kodi the moment you try to play it. I don't have this problem with LibreELEC on PC's, only on Raspberry Pi. I have tried this on the latest distro for both a Pi 3B, and now a Pi 4B so it makes me think it is not a hardware problem.


    All of my other videos play fine that don't use that codec, and I have no other videos that use that codec it seems so I have a limited pool of videos to test with. I have tried to generate a Kodi log but the moment it crashes and reboots, the Kodi log gets cleared so I cannot get the log data before it gets wiped. I don't know what else to do or try so figured I would put this here.


    I cannot find any other reports or posts of this problem. Keep in mind that this happens on a fresh install of LibreELEC with no add-ons or anything. I have tried changing various settings, both system and playback settings but it always does it. I have provided the info that MediaInfo provides about the video codec if it is needed. I dont know if this is a known issue or not but hopefully there is a simple fix. My guess is the codec is not supported or installed. Thanks


    Video

    ID : 0

    Format : VP7

    Format profile : General

    Codec ID : VP70

    Codec ID/Hint : On2

    Duration : 22 min 55 s

    Bit rate : 928 kb/s

    Width : 576 pixels

    Height : 384 pixels

    Display aspect ratio : 3:2

    Frame rate : 23.976 (24000/1001) FPS

    Bits/(Pixel*Frame) : 0.175

    Stream size : 152 MiB (87%)

  • To replicate: on RPi4


    wget potter-700.vp7


    Rename to potter-700.vp7.wmv or mkv


    Try and play - Instant reboot.


    2019-11-02 12:14:31.202 T:2703336304 NOTICE: CDVDVideoCodecFFmpeg::Open() Using codec: On2 VP7

    2019-11-02 12:14:35.137 T:3011383312 NOTICE: VideoPlayer::OpenFile: /storage/videos/potter-700.vp7.wmv

    2019-11-02 12:14:35.145 T:2881561456 NOTICE: Creating InputStream

    2019-11-02 12:14:35.148 T:2881561456 NOTICE: Creating Demuxer

    2019-11-02 12:14:35.169 T:2881561456 NOTICE: Opening stream: 0 source: 256

    2019-11-02 12:14:35.169 T:2881561456 NOTICE: Creating video codec with codec id: 179

    2019-11-02 12:14:35.169 T:2881561456 ERROR: CMMALVideo::Open : Video codec unknown: b3

    2019-11-02 12:14:35.169 T:2881561456 NOTICE: CDVDVideoCodecFFmpeg::Open() Using codec: On2 VP7

    2019-11-02 12:14:35.173 T:2881561456 NOTICE: Creating video thread

    2019-11-02 12:14:35.173 T:2881561456 NOTICE: Opening stream: 1 source: 256

    2019-11-02 12:14:35.173 T:2881561456 NOTICE: Finding audio codec for: 86081

    2019-11-02 12:14:35.176 T:2863637360 NOTICE: running thread: video_thread

    2019-11-02 12:14:35.176 T:2881561456 NOTICE: CDVDAudioCodecFFmpeg::Open() Successful opened audio decoder on2avc

    2019-11-02 12:14:35.176 T:2881561456 NOTICE: Creating audio thread


    ------


    Video plays on X86 - K17 & K18 and VLC